Wired Router Set-up Question?.

Hi people, I am in the UK and have a virgin media cable modem which connects me to the internet. My OS is Windows 7 Home Premium and my desktop PC uses Comodo CIS for security. I have just bought and installed a Buffalo WHR-G300V2 router in order to connect my Panasonic Viera link tv to the internet and also use the DLNA function to connect to my PC as well, it is a wired connection not wireless. I followed the instructions and everything went well I can connect to everything and it all appears to work as it should. When I followed the instructions at the Comodo site to alter the DNS settings to Comodo secure DNS I found that I can enter the Router menu page via the address and “root” password mode but when I click on the Internet header at the top in the page which appears it shows some boxes momentarily and then they disappear. this happens on all the headers so that I effectively cannot change anything and am stuck with the default settings. I also found that port 113 is not stealthed while checking my security at GRC.com and cannot take the steps needed to rectify that either. Is this correct behaviour for a wired connection or do I have to do something else first, perhaps a new firewall rule or something. Excuse my ignorance but I am 62 and not very PC aware and as my son the family PC expert is out of touch for the time being I have no one else to ask. Thanks in advance for any help offered.

Have you tried a different browser for accessing the router? It may simply be a javascript or comparability issue.

With regard to port 113, unfortunately, this is a very common problem with a lot of domestic routers. The first thing to check, is for a section in the router menus, for something like firewall settings - I did scan through the manual but it wasn’t very detailed - If you can find that section, it may be you can find an option to close/stealth ports. Failing that, it may be possible to forward that port to a non-existent computer on your network, which should also have the desired effect.

Check the menus first - get some screenshots if you’re not sure - and we can go from there.

I managed to fix it myself anyway Radaghast. The problem was with the Dragon browser. I tried Firefox and could access the user menus straight away and managed to set it all up from there. Again thanks for your time and help.