Windows WSL not running properly with CIS

I just got a new laptop with Windows 10 and it is running Comodo Internet Security Premium 10.

I am having issues running WSL Ubuntu 16.04. When I try to run updates, there are I/O errors which says certain files or folder cannot be written. After doing some checking, I found CIS to be the culprit. When I disable all the Services of CIS, the WSL is working properly.

Now I do not want to keep disabling CIS everytime I need to use WSL. Is this a known issue? Cause I am unable to find anything about this on the internet. As I am new to CIS, I am not sure what kind of settings I need to do in order to “whitelist” WSL.

Any help is appreciated.


Almost each time I run a linux command in WSL, I get this containment pop-up.

Any idea how to solve this? This is getting really annoying.

Click don’t isolate again, that is what it is used for. Or go to unblock applications task and use unblock from all components for each WSL binary.

I know I can click on the don’t isolate again. But this is very damaging when I run some scripts for the first time and some commands get blocked. The script will end up failing and some stuffs implemented in the screen need to be reversed manually.

Isn’t there a way to unblock WSL all commands? Imagine having this kind of issue whenever we are trying to run Windows commands. All .exe need to be unblocked manually? Doesn’t make sense. WSL is system level commands which should already be allowed to run. I had no such issue when I was using Avast.

You can create an ignore auto-containment rule and browse to the folder where Ubuntu is installed in Windows.