Windows Live Messenger Won't connect if Defense+ and Sandboxing is enabled.

Last night, I upgraded (more or less uninstalled v3 of CIS and installed v4) to Version 4 of CIS and all went smoothly until reboot. Here are the list of problems:

  1. Windows Live Messenger won’t connect unless I turn off D+ and Sandboxing. I’ve tried leaving 1 on but doesn’t work. It’s not the firewall as when D+ and Sandboxing is off, it connects just fine.

  2. Copy and paste from the Web doesn’t work if Sandboxing is on, got to turn it off for it to work.

So far, I’ve had to turn them off and haven’t had any issues with firewall only. I’d like to turn them back on but I’m afraid the automatic restrictions are too much to put up with.

Make sure WLM is not running in the Sandbox.
I don’t use WLM, but Comodo should detect it as Trusted and NOT run it sandboxed.

Sandboxed programs cannot access the Clipboard.

The thing is, when I go to sandboxed applications, it’s empty. Nothing is in there and I have it WLM set to trusted application.

Add msnmsger.exe to the My Own Safe Files, close msnmsger.exe (check with task manager) and restart it.

The “Programs in the Sandbox” screen will only show programs you added through this screen only.

Thanks for the effort guys but still no luck. The only time it connects or the copy and paste problem goes away is when I turn off the two and let the firewall alone run. And yea, I tried all suggestions so far.

I had this same problem, but now it’s working fine. How? I don’t know exactly, but try that:

1 - Disable both Defense & SandBox
2 - Login in messenger
3 - Goto Defense+ → Advanced → Computer Security Policy → Add → Select → Running Processes → And then select the MSN (msnmsgr.exe)
4 - Use a Predefined Policy → Trusted App, then Apply & Apply
5 - Goto SandBox → Programs in SandBox → make sure that MSN is not there
6 - Turn back on both Defense+ & SandBox
7 - Use your MSN as normal, don’t close it yet.
8 - After some time, comodo will ask msn for some permissions, always mark they as “Trusted” or “Windows Application” (don’t forget to check ‘always…’)
9 - Be happy :slight_smile:

That worked for me :wink:

  1. I strongly advice no to set MSN Messenger as Windows Application. It can then start up other applications without notification. In case it would get infected by a virus the virus would have full reign over Messenger.

I don’t remember why, but at some point Comodo Defense asked for some action by MSN and the options were not that good (something like block or treat as windows system app). But in “Computer Security Policy” the MSN is still just “Trusted Application”, so I guess is not a big deal 8)

About a week ago. I let the computer on and went to sleep; when I come back I had several Comodo popup windows.

I think maybe Comodo updated itself and wanted to refresh some settings.
But this caused me a lot of trouble for 3 days! bacause I couldn’t log in Messenger (Windows Live) Until I find this post. Thanks MagusBR.

I can log in Messenger with Defense & Sandbox disabled. But I have to do it every single time!
When I try to add MSN to Defense I says its already there (it is)
And my snadbox seems empty.

Any help is apreciated.

Assuming you are using v5.

Can you make sure the file is not also in My Pending Files at the same time. If so, please remove it from there.
Also read Mouse1’s Introduction to the v5 Sandbox (see my signature) and How can I prevent software being sandboxed? and see if that brings any help.

Hi EricJH,

I now have the Comodo v5.0.16 and seems there’s no problem now with Sandbox, but I still have to disable Defense.
Where I can find “My Pending Files”?
(Unrecognized files is empty)

and I also can’t use copy/paste in Notepad! (well, I can copy; but can’t paste there anything if defense is on)

Sorry about “My Pending Files” that is called Unrecognised Files in v5. You guessed that right. :-TU

Can you see if you have a rule for WLM in Computer Security Policy → Defense + Rules. If so delete it and try again. May be you made a decision that is causing this.

Thanks EricJH, but that didn’t fix the problem =/
Nor for the Messenger* o Notepad (copy)

*(that now seems to not work well even conected, and I don’t know if is for Comodo)

PD. I think Comodo have a serious problem there, but maybe many people didn’t even notice it as Comodo one.