Windows hangs upon reboot after 3.0 install

Windows XP Pro, SP2, 32-bit.

I installed COMODO Firewall 3.0 (CFP_Setup_3.0.12.266_XP_Vista_x32.exe). It uninstalled COMODO Firewall 2.4 in the process, and did a reboot to complete the uninstall.

After that, the installation of 3.0 proceeded (with all default settings), then required another reboot to complete the installation. However, after the reboot, Windows would not load completely. It would display the blue desktop background, but never proceed from here - no wallpaper, no icons, no taskbar - just the blue background.

I was able to uninstall it from Safe Mode, and Windows would then load normally.

I gave it another try later today; this time only the basic firewall. Upon reboot, the same thing happened, and I had to uninstall in Safe Mode again.

Any ideas why this is happening, and what I can do to prevent it?

I too am having the same problem. I seem to be getting a bit further into the Windows Boot process through.

I saw v3 was out and downloaded it. Clicked the setup to install, it requested uninstallation of v2.4 which I told it to do. Then rebooted. Installed v3, rebooted got my desktop to come up with the icons etc. the start bar appeared at the bottom of the screen. But then the system would then hang and nothing would work, No icons where clickable, the start button failed, ctrl+alt+del wouldn’t work. The mouse would move but nothing was selectable. I had to force the shutdown with the power button.

I too had to boot into Safe Mode, which completed successfully, with the CPF v3 on the desktop, and I could load it and view all the GUI, settings etc, all seeemed ok. I rebooted and then hit the same problem before, system locking up.

I had to reboot into Safe Mode and uninstall v3.

I am running Windows XP SP2, 32bit. Fully patched.

If you require any further info let me know.

Hopefully like pwillener someone will be able to help

Seems like this forum is too busy at the moment. I will try to contact COMODO Support.

Hello pwillener and fantawttw

The forum certainly is busy. Welcome fantawttw to the Comodo forum

Very often when a program such as this is uninstalled you need to run a registry cleaner after the boot in order to make sure that there is nothing left behind. I am not sure how this installer handles it. Then it is also important to make sure that no other security apps are running when you install as sometimes it causes conflict with the installation. Follow the uninstall instructions elsewhere in the forum and try again. You won’t be disappointed. It is the best.


Thanks, JJasper! I will try to find the uninstall instructions, then try to apply it on Monday, as we also have a public holiday here.

Hi pwillener

Here is a good method by poster smilingralph at;msg106293#msg106293

Here i what he said he did.


"Like others I had problems installing v3 of the firewall, namely slow boots and general slowdowns and system freezes. I installed it using the following instructions and it’s working great so far. If this has been posted somewhere else or should be posted somewhere else I apologize. Hope this helps:

1.Uninstall all security programs that run at startup. Antivirus, AntiSpyware, Firewall, etc.
2. Cleanup files and registry (I use Ccleaner)
3. Manually delete folders related to these programs in C:/Programs files, C:/ Documents and Settings/All Users/Application Data, C:/ Documents and Settings/Owner/Application Data and C:/Documents and Settings/Owner/Local Settings/Application Data.
4.Disable all startup programs from Run>msconfig. Reboot.
5.Enter Task Manager and End process for any other non system process. (In my case this was Diskeeper, Wallpaper Toy and UPH Clean.)
6. Install Comodo Firewall. Reboot.
7. Reinstall AntiVirus, etc. one at a time as long as there is no conflict."
End Quote

This does not happen for the majority of installations but there are a few like yours that go wrong and this approach is needed.
Hope this works for you. Let us know how it goes.


Hi John,

I have now managed to get v3 installed and running, and so far so good. Here are the steps that I used to get it running. It might be that others find these of some use, but it made it work for me.

Do a complete uninstall of v2.4.
Disabled Access Scan of Virus scanner - not sure if this could cause problems but did it anyway.
Installed V3
I selected Advanced for all options, cos I wanted complete control over the system.
when it asks to reboot said NO - before I always selected yes.
Double click the desktop icon.
I then disabled Defense+ , not sure if this is the default for basic install?
Did a reboot.
Kept fingers crossed…
System came up all fine.
Had a beer :slight_smile:

As yet I have not enabled Defense+

So far the system is doing fine and very stable, as I say I have not enabled Defense+ as I believe this may be the cause of the problem, obviously everyone has completely different systems and software installed, so these instructions may not work for you.

Now I have the new version installed it is working great, after about 20mins of opening and running them all my usual programs and telling the Firewall what to ban and what to allow, it is now just happy sat there protecting my system.


Hi Jon

Glad you got it working. If you do not have another HIPS running on your system then you need to enable Defense+ as soon as you can to get complete protection. You will find it will give you a lot of popups that you will not have to answer as it reads your apps and makes policy for them.

Good Luck


Thank you for all replies, especially fantawttw’s, who suggested to launch the firewall before rebooting, and doing some configuration.

My COMODO firewall v3 now works fine!

What I did:

  • Launched COMODO firewall from the desktop icon, then defined three network zones (private networks):,,
  • Did a ‘Check for Updates’, which downloaded a large update, then requested a reboot.

After this, the reboot completed successfully. The private networks I defined were probably necessary, as I am inside a corporate network, and several connections may be needed during the Windows startup and login to the network domain.

I had significant windows hang up problems at boot trying to install version…276 on a XP fully patched SP2 machine. I did all the registry cleaning after uninstalling all anti virus/spyware/firewalls etc. Just could not get it to work. I had just installed version …268 successfully on a different XP SP2 fully patched machine so tried that version and it worked! So something is defintely causing a problem with version …276. Now I am not updating to new version till I here from the support group that the issue has been fixed!!! Spent too much time on this!!!

Ajo, welcome to the forums.

I have experienced precisely the same problem you described on my T43 laptop.

If you can locate a copy of v.273, it should work on your system. Otherwise, stick with your current installation of CFP until the next bug-fix release.