Windows Explorer crashes on Windows XP due to cavshell [M1890]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes, Every time.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Right click on folder
2:Select folder properties
3:Select different tab
4:Close properties
Video [at]attachment:;msg838552#msg838552
One or two sentences explaining what actually happened:
Few seconds later: explorer stopped working
One or two sentences explaining what you expected to happen:
Windows Explorer shouldn’t crash.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Any software except CIS/OS involved? If so - name, & exact version:
Windows Explorer
Any other information, eg your guess at the cause, how you tried to fix it etc:
Uninstalled CIS and everything seems to work fine again.
The problem has existed since version:, the last working version is:

Exact CIS version & configuration:
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
AV only
Have you made any other changes to the default config? (egs here.):
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Have you imported a config from a previous version of CIS:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows XP Home 32 bit language: Polish
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=None b=None

Can’t replicate would you please check with

I have the same problem with an Windows XP ???

The problem has existed since version:, the last that works on Xp is:

I can confirm it.
Bug was reproduced on two different PCs.
PC1: WinXP SP3 Prof RUS + CFP (firewall only);
PC2: WinXP SP3 Prof RUS + CIS
Zipped video examples (wmv) are attached.

[attachment deleted by admin]


  1. Disable Auto-Sandbox for 15 minutes
  2. Get ProcDump :
  3. Use following command : procdump -accepteula -ma -e -n 5 explorer.exe
  4. Replicate crash
  5. Kindly provide dumps by PM


I don’t use Auto-Sandbox.
ProcDump generated 5 dumps 99MB each. Post restriction is 15.5MB.

Please check PM.


Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time, availability, and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Please check this issue with version 10.


Looks like fixed. Couldn’t reproduce it on CIS

Ok thanks for checking moving to resolved.