Windows Desktop Search Troubles [resolved]

I just noticed that every time I shut down and boot up my PC the Windows Desktop Search (3.0) starts reindexing and all of its settings are reset to defaults (scan folders, protocol handlers, etc.).
Today I spent a lot of time reinstalling WDS, reindexing my drives, and rebooting my PC to figure out what was wrong. Nothing changed. Event log shows WDS unable to access JetPropStore, meaning it can’t access some files while it’s being started as a service.
Then my next suspicion was Comodo Firewall. I uninstalled the latest beta and restarted the computer and WDS seems to be doing OK now. It remembers the files it has scanned so far and the queue looks alright, too.
Later I installed back CPF 2.3.6 and will test some more. If WDS continues to act normally after the reinstallation I will accuse the latest beta of tampering with my desktop search. :smiley:
Hope someone else can test/confirm this as this is my production machine so I can’t waste a lot of time (or potentially lost data) in the next couple of days.
I hope I’m on the right track and you guys manage to find out and fix the issue.

Maybe it can be solved with beta by changing some settings. I added searchindexer.exe (the service) to the list of trusted applications but that did not help. Adding some dlls from the WDS installation folder also did not change a thing.
If I don’t reply back it will mean everything works with the latest release version…


Just to confirm… No problems at all with the latest release version.

Ok, thanks for the info MisterY. :slight_smile:

Some desktop search programs (Google?) need you to go to security/advanced/misc and check the “skip loopback… TCP”.
UDP is checked by default.

I will put resolved to the topic and lock it.

I haven’t changed the loopback settings in either of the versions and still WDS had problems while beta was installed but not after I reinstalled the previous (release) version.
My point was that beta version, for whatever was changed in it, somehow blocked Windows Desktop Search 3.0 from reading its settings.
Haven’t tried the later betas. They keep popping out so fast. :slight_smile:

Ok, but if you try any of the later beta’s you can let us know if it works. :wink:
Maybe you should try to check that “skip loopback… TCP” and see if it works.
Skip loopback TCP checked during installation and everything works OK. Windows Desktop Search does not reindex everything on boot.
Solved. :slight_smile:

Good to hear. :slight_smile:
I will put resolved in the subject line, and lock this thread so other users can find info about this easily.