"Windows cannot access the specified device..." error in Vista

NOTE: As explained in the “ADDENDUM” at the very end of this post, the problem described herein got resolved… but weirdly, and in a way which I believe indicates maybe a bug of some kind in CIS… so maybe this post might still be valuable to someone at Comodo who figures out these kinds of things.

There’s a free little utility by RJL Software that will allow one to open/close one’s CD/DVD drive that’s simple and I’ve used it for years. No anti-virus software I’ve ever used has seen it as virus-infected…

…that is, until I started using CIS (.477 version, virus sig 1012), which sees it as having some sort of as-yet-unknown virus in it when it’s still inside its .ZIP file during and after download to my wife’s new notebook (which, I should add, is running 32-bit Vista SP-1). I know this is a false positive. I know this software, and its author, and, believe me, it’s clean (I figure’s it’s a heuristics problem of some kind).

The utility in question is this cute little guy: RJL Software - Software - Utility - Open/Close CD

and if you, the reader, are going to follow the steps with me, here, to see if you get the same results, be sure that you download the “Compressed .ZIP file” version… and don’t unzip it (or allow it to auto-unzip)… just download it into your “Download” folder, or onto your desktop or wherever you normally download things. Just don’t unzip it yet. Keep reading…

So, anyway, whenever either during or after download CIS flagged it or warned me about it I just told CIS to ignore it and add it to my trusted list and all that kinda’ stuff so it would let me download the .ZIP; which .ZIP file, once I downloaded it, I just let sit (as an as-yet-unopened .ZIP file) in my “Download” folder for a few days… almost forgot about it, in fact. (If you’re following along, you don’t have to wait a few days, though, before continuing along with me, here.) ;D

Anyway, then I finally circled back and got around to setting it all up. It has no installer, so here’s what I did:

Created a folder under “Program Files” named “Open-Close CD” (you could call it anything, but that’s what I chose).

Moved the .ZIP file from the “Download” folder over into the new “C:\Program Files\Open-Close CD” folder.

Unzipped it into the new “Open-Close CD” folder.

Right-single-clicked on the “open_cd.exe” file to create a shortcut to it, and put said shortcut onto the desktop.

(Note: Since it’s a notebook, with only one CD/DVD drive, the command line in the shortcut doesn’t really need to be edited to include the drive letter… the software, I’ve learned, from experience, will find the drive and it will work; so the new shortcut can just be left alone once it’s on the desktop. If you have more than one CD/DVD drive, the command line in the shortcut might have to be edited, but it doesn’t need to be for our purposes here… so, for our purposes, here, just leave it alone and keep reading.)

Then I went to the desktop and left-double-clicked on the new shortcut to execute it and see if it will open the notebook’s CD drive, as expected…

…but, lo and behold, I got the error message “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.

Wha… ???

So I went back into the “C:\Program Files\Open-Close CD” folder and right-clicked on the “open_cd.exe” file and started to investigate the permissions situation. I won’t go into all the steps I performed here because, in the end, it turns out that the problem has nothing to do with permissions… it’s CIS, as I’ll explain in a minute. Suffice it to say that I did all the right things… I know about permissions… and ownership… and all the little tricks associated therewith. But no matter what I did (and, boy, did I do a lot), I could neither see the permissions situation for that file; or change its ownership…

…or even (I soon also discovered) edit the command line in the shortcut; or access the little icon file within the .exe file so that I could change its icon on the desktop… nothing. It would let me do nothing to it. And, no, it wasn’t “blocked.”

But wait… it gets better! Then I found that I couldn’t rename it, or move it, or delete it.

“Mygod… it’s a monster!” I thought to myself. :o

So I Googled the error message and started looking around in some forums…

…and found a guy who, in 2007, had the exact same problem with some executable file (not the same one we’re talking about here) on his copy of XP. “It ain’t Vista, but it might do,” I thought to myself… so I kept reading. After going 'round and 'round with everyone in the forum (and, boy, you should have seen the hoops they had this poor guy jumping through (good thing his instincts told him not to re-install Windows)), when he finally disabled (completely) his anti-virus software (I can’t remember what it was, but it wasn’t Comodo), voila!, he could suddenly do whatever he wanted with the file.

With eyebrows furrowed in wonder if that could be the sort of thing that was going on with me and this little “open_cd.exe” file on my wife’s machine, I right-single-clicked on the CIS icon in the system tray, and set the anti-virus component to “Disabled”…

…and, voila!, I could suddenly do to the file whatever I wanted. Error messages gone. I was able to move it, copy it, rename it, execute it, find the little icon image within it for the desktop shortcut, change its permissions… etc. No limits. Left-double-clicked on the desktop icon (which suddenly displayed properly), and, pop!, the CD/DVD drive opened. (Of course, since it’s a laptop drive, and has no drive retraction motor, the utility can’t make it close like it can on a CD/DVD drive in a desktop machine… but, hey, I’ll take what it does do on a laptop!)


So then I turned the anti-virus component of CIS back on and, poof!, all error messages and limits return!

Hmmm… again.

So then I fully opened CIS and went to the “Common Tasks” page for the anti-virus component, and then went into “Scanner Settings” and clicked on the “Exclusions” tab and added the “open_cd.exe” file (and even the .ZIP file from which it came which happened to be still sitting there next to it). I figured maybe that would make CIS ignore those two files from then on (or at least I hoped).

I, however, was wrong. All that did was make CIS ignore those two files during system scans (and, weirdly, it also causes the “Results” button after an individual file scan (executed from the file’s right-click menu) change from “Results” to “Close” which is kinda’ irritating because I then can’t see what virus CIS thinks is in it)…

…but it doesn’t cause the anti-virus component of CIS to actually, truly ignore the files… as in, don’t even worry about them… ever… no matter what… scan or no scan, just pretend they’re not there. It definitely doesn’t do that.

And that’s a problem… obviously… a huge one, in fact. In the end, it’s going to mean that I can’t use one of my favorite little utilities anymore… at least not for as long as I use CIS… at least until someone at Comodo fixes CIS’s wrongly identifying it as a virus (hint, hint). (And, yes, I submitted it… though I wish the submission component had a place where I could add a little note telling Comodo that it’s a false positive; and ask Comodo to please fix it).

So, then… clearly the anti-virus compoent of CIS needs another setting… a file-by-file, not a global setting. It could be either a checkbox on the edit screen within the “Exclusions” area; or maybe an entirely new area unto itself which sits alongside the other items (such as “Run a Scan” and “Update Virus Database” and the others) on the “Common Tasks” pane wherein one can tell CIS to not only ignore certain files during scans, but to also pretend said files don’t even exist, period. There needs to be a way to turn off CIS’s treating files (individually, not globally) as viruses when they’ve been so misidentified… or, better yet, to just tell CIS to pretend certain files just aren’t there, no matter how it identified them, or what the reason.

I’m suggesting this as a separate setting rather than suggesting that “exclude” (in the scan area) should be made to mean, bygod, exclude, because I can think of situations wherein one would want CIS to stop flagging a file during scans, but still protect one from it in all other respects. So it definitely needs to be a separate setting… again, either in its own area, or maybe, easier, as a checkbox in an “ignore” or “exclude” edit box or something or something like that.

In the meantime, it looks like I may have to go find another utility that will do what this little CD tray open/close utility does… and after using it for more than a decade! Sheesh… it’s like an old friend, after all this time.

If so, that’s terrible. Shame on CIS for that if that’s how it turns out. CIS should not have that kind of control over my life!

I sure hope someone sees to it that this gets this fixed! (hint, hint… again)

In the meantime, I’m going to experiment with turning off or lower the heuristics settings and see if that makes any difference. I’m not sure that I want those settings lowered, though. I kinda’ like 'em. So if it turns out that that’s what it takes to fix it, then won’t really be a fix. It will barely qualify as a workaround because it will potentially make CIS, as an important systemwide tool, weaker.

I want CIS’s heuristics and my pop-open utility.

Is that too much to ask? >:(

ADDENDUM: (Added a little while after this posting was first made.) Setting CIS anti-virus’s heuristics to “Low” seems to allow the file to work… but as I think about it, I think they were already set to “Low” back when the problem first started. Actually, I first tried it with heuristics set to “Off” and that let it work. So then I set it to “Low” and it still worked… and so I was happy to just assume that it must have been set to “Medium” before. But I really didn’t think it had been, so, to test that, I set it to medium… and guess what… it still worked. And I know heuristics wasn’t set to “High”… but what the heck, I tried that, too… and, lo and behold, it even worked with that setting. So the heuristics level must not be it… er… well… except that turning it off altogether – even if only for long enough to test it – and then back on again, seemed to fix it. It’s now set back to “Low” and seems to be working fine. But, again, getting there wasn’t direct. I turned it all the way off, first, then to “Low.” So, in the end, I think see this as some kind of weird bug in CIS… though I don’t know enough about the program to even begin to imagine what the nature of that bug might be. Hopefully this narrative will somehow help someone at Comodo figure it out.