Windows 7 RC problems

One of my systems is Windows 7 7127(pre escow RTM) X64. Also I've tested with 7100, it works fine too. CIS .509 works fine(not perfect). But you need to configure your windows first before install CIS. If you don't? CIS can mess your system. If you have any questions about Windows 7, make a new post please.

Ok so i downloaded the last version of CIS and (I am only useing the firewall) and its still not working well on my PC.

First my problem was:
I did not uninstall the old version of CIS from my pc, because i did not find how I can!
(Klick on it )

And i did not find in the Comode files.

So I had to update Comodo, after I restarted my PC. Its still not started with my Windows 7 RC. (its full updated) But i have set up the "start with windows:
(klick on it)

But i did not worry untill i opened the Comodo’s main window! I always had run: Windows Live Messenger/mail. Totalcommander for FTP. Media Player, IE or Opera or Chrome. And of course the Windows is useing the net too. And i get the next picture:
(klick on it)

After for sure i went to test it to a test sites… Just one picture:
(klick on it)

I think is here some big problem! Can you help for me, and i believe for us?

I think is here some big problem about it. I like my comodo back, what i am useing a long time ago on my XP. If you guys have any ideas what i should try, i will everything! But maybe you need to check what is going on!

Thank you for your support:


(sorry for my english… I am Hungarian)


Have you ever tried to install CIS ‘Run as Administrator’?
(Do not use Vista compability mode)
When you install CIS it asks you about ‘if you trust COMODO products something…always trust…’
check trust.

Did you check ‘a per-case basis’ instead of ‘stealth my ports to everyone’?

If not, try to use ‘a per-case basis’.

Have you ever tried to install Windows 7 as a clean installation?
What is your version of Windows 7?

If you still have problems, let me know.


Yes, i use Win7 RC x86, and clear install, on new partition, and the Comodo firewall was install as Administrator.

And only problem, is not starting with my Windows. Everything else perfect!.

Have you ever checked your ‘notification area’?
Isn’t there CIS icon?
If there are too many icons in ‘notification area’ with Windows 7,
Windows hide some of icons.

And did you check windows service and task manager?

Otherwise more details needed.

Because you installed on top of an older installation I suggest to do a clean install. The problem of no traffic showing is an old one that was reported it was solved. Hence my suggestion for the clean install.

Here is the procedure for a clean install (Removing Legacy keys is an elaborate task. You can choose not to remove them).
Start with exporting your configuration to a folder that is not part of the Comodo folder under Program Files. This way you can restore your configuration after the reinstall.

Uninstall CIS and reboot. Then run [url=]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See:;msg119226#msg119226

Now you should be good to go

I checked everywhere… so its not start, then i am going to program files/comodo…cis.exe and start. And its starting!
And the other thing is:
The program says, no inbound and no outbound connections, but i have run a many programs on internet. You can see, what i linked picture, . The other thing is:

Uninstall CIS and reboot. Then run Comodo System Cleaner to get rid off registry keys.

I dont have uninstall in the program folder and i dont have that in the controll panel.

You sure i have to do it all? For useing 1 Firewall? I cant, dont want to do that! I keep it, then maybe 1 time we get some easyer “medicine” to my problem!

Thank You guys!



In case of you situation, there is only one thing you can do now.
Clean install.


He doesn’t have the CIS unisntall information.

You can run the installer/uninstaller from the command prompt. First start the command prompt under Start → Run → cmd → push enter → now a dos box environment show ups → assuming CIS is installed in c:\Program Files paste the following in the box: “c:\Program Files\Comodo\COMODO Internet Security\cfpconfg.exe” -u → after puhing enter the (un)installer will start.

Thank you! Ill try it!

How i can do this?
Its always starting with c:\Users\Boboca:
Can i go back to c:\ ?

enter cmd in the search box, when it comes up “run as administrator”

Now type in cd “\Program Files”


My feel is= “i am totally idiote”

Nothing happen.

edit:new picture */

Copy/Paste the line Eric suggested,press ENTER and you should get this.(here`s the line again)

“c:\Program Files\Comodo\COMODO Internet Security\cfpconfg.exe” -u

[attachment deleted by admin]