Windows 7 IE9 - Solution to "Windows Explorer has stopped working" error

I’ve been using Verification Engine (current version running on Windows 7 Professional 32-bit for sometime now.

After installing windows updates which applied Service Pack 1 and upgraded internet explorer to v9, I got “Windows explorer has stopped working” errors whenever I opened windows explorer (my computer, my documents, etc, etc, etc). More worringly, I also got the same error message everytime I tried to open Control Panel or launch Add/Remove Programs via command line (control appwiz.cpl) or its .exe program so I wasn’t able to rewind back to the restore point just before the updates were applied. :cry:

Fortunately, the Event Viewer wasn’t affected by the Windows Explorer problem. The application log showed the same faulting module in every Application error log, namely VEngineIE32.dll. One of the event logs is shown below as an example:

Faulting application name: Explorer.EXE, version: 6.1.7601.17514, time stamp: 0x4ce796f3
Faulting module name: VEngineIE32.dll, version:, time stamp: 0x4b716d1d
Exception code: 0xc0000005
Fault offset: 0x0001d2e7
Faulting process id: 0x1060
Faulting application start time: 0x01cbf88e775422a3
Faulting application path: C:\Windows\Explorer.EXE
Faulting module path: C:\Program Files\Comodo\VEngine\VEngineIE32.dll
Report Id: d5677db4-6481-11e0-82d1-005056c00008

Solution to this “Windows Explorer has stopped working” error

Run program C:\Program Files\COMODO\VEngine\VESetup.exe
Allow program to make changes
At Welcome page, click on Next>
Select Repair
Click on Next>
At the “Do you want to keep your Verification Engine profile”, I clicked on Yes

VESetup repairs your installation

At Complete page, keep or reset the Reboot now option as required
Click on Finish

Hope that helps you,

Hi Alex, welcome to the forum

fighting the same demons ? :slight_smile:

Please read my yesterday post Troubles with IE9 upgrade & Vengine and subsequent link at the beginning

There are (were) some differences most likely due x64 - VE could not be uninstalled/repaired - no such option(s).
In addition, the 1st thing was anyway removing (rather disabling) VE Extension using 3rd party utility then deleting VE folder and cleaning the Registry

Anyway it’s not compatible neither with IE9 (which I’m never using) nor with Fox 4


Hi All
I have found a solution to the error and a fix that worked for me.

Restart your machine, then boot it in safe mode (F8 on my machine just after POST)

** TIP **
Save this to your desktop BEFORE you restart so you have a copy of it to hand, you can also start in Safe mode with network support and bookmark this page.

Press the WIN key + the R key you will get the CMD dialogue box, copy and paste this

regsvr32.exe -u “C:\Program Files\Comodo\VEngine\VEngine.dll”

where the “C:\Program Files\Comodo\VEngine\VEngine.dll” is change to suit your machine, with machines that are 64 bit you are going to need to alter the line as the files exist in both you c:\Program Files AND your C:\Program Files (x86) folders

Here are the lines i used to clear the DLL

regsvr32.exe -u “C:\Program Files (x86)\Comodo\VEngine\VEngineIE32.dll”

regsvr32.exe -u “C:\Program Files\Comodo\VEngine\VEngineIE64.dll”

For each of the lines you should get a success message.

Reboot your machine once complete.

Your machine will work again.

Hope this helps you all.

Fimble, please do not double post. one post is sufficient.

Double post?
No my friend they are not double posts they were replies.
If this is your reaction to my helping to sort out your ■■■■■■ software then stuff you and your forum too!

Yes, double post. You posted the identical reply in two separate threads.

We don’t allow this in order to cut down on spam across the forum. Note that I’m not calling your post spam, it’s just that we don’t allow users to spam identical posts in multiple threads.

Please note that I am not an employee of Comodo, simply a user like yourself that is trying to help. I’m sorry if you feel offended, as that was not my intention.

Hi fimble,

Yes, it was a double-post in the 1st place, as HeffeD pointed

Here is another one :;msg535097#msg535097

Then, before posting please read multiple threads here regarding the matter

In many cases users will not be able to do what you’ve posted since already crippled Explorer is involved

Anyway, whether your advice can help or not (in most cases - not - according to my experience with this issue) , I’d rather suggest you can refrain yourself from messages like above, where you are expressing disrespect to members here with familiarities/sarcasm like “dear friend” or “stuff you and your forum too!”
You just joined the forum for goodness sake!

… and if any free Software is “■■■■■■” - you have an alternatives : either try to help & be patient or just drop it & stop frustrating yourself


Accepted and apology given, however it’s a local peculiarity here to call someone Friend just as Australians say “Mate” so on that point you are incorrect.
Also in the post i said about booting up in safe mode which only loads drivers, so access to windows dialogue boxes can be successfully accomplished.
I found this forum when trying to work out a solution to my own problem, so thought it would be helpful to others to post how i did it, the reason for the “Double Post” is that the OP gets a message saying there has been an answer, so was done in the best of intentions. I did not take kindly the response i got from a member just saying don’t double post!
It’s not the friendliest welcome i have experienced on a forum.

One point i would make about the installation of the VEngine is that the warning is made much clearer, and perhaps something said about it will break your OS.
I would also suggest contrary to your comment, that the solution i posted does work, i am proof of that.

Understood. However, a better approach would have been to post a link to the reply you had already posted.

I’m sorry about that. I guess I should have said “Welcome to the forum, by the way…”

As a moderator on this forum, it is my job to enforce the Forum Policy. This is what you agreed to when you registered for an account. Since double posting is not allowed, (Please read the policy, section 8 (Unacceptable Behaviors) subsection 4) I would have been remiss if I had not brought this to your attention.

So I apologize if you didn’t appreciate my correction, but even new users have to follow the forum policy.

Welcome to the forum, and please enjoy your stay here. :slight_smile:

:slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile:

I have it !.. Problem solved…

I had the same issue after installing the Windows 7 Service Pack 1…
Error Message “Windows Explorer has stopped working”

Well after trying everything here and under the sun I did it my way.
I logged on in “Safe Mode” and went to the “System Restore” via the
Windows search box and restored the system to just before the “Service Pack”…

And Presto !.. Now, go into your "Add\Remove Programs and remove “Verification Engine”…
Then, reboot. Then go into Windows updates and install your service pack normally…

No problem. All working and no Errors.
Man you guys make a simple thing so complex. Sheesh.

:slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: :slight_smile: