Windows 7 could not Boot

I installed CMT on XP SP3 without any problem replacing Rollback. After installing on Windows 7 32 Bit the computer did not boot and I got a message that there is a problem with C:\Boot\BCD, I was able to repair it with the Windows Installation DVD but still could not boot the computer. After Uninstalling CMT using the HOME key on first start the system came up without any problem, so I am back with Rollback.
I do hope this problem can be fixed since I like Comodo and I am using CIS and more.

Well I think I know what is the problem after a test I did on my virtual machine.

When you install CTM on a computer that did not have Rollback you are fine and CTM does the job very well. But if Rollback was working on your computer and you uninstalled the program than in most cases you will have problems, the reason is that both application are changing the file BCD in the BOOT folder.

After uninstalling CTM and reinstalling Rollback I did not have any problems, CTM must fix the process that handling the BCD file.

CTM is not compatible with Rollback, and u can not use those 2 tools at the same time.

Mr. Flykite: Looks like you have Reading comprehension

I have never mention that I installed both programs.
I installed CMT on XP SP3 without any problem replacing Rollback
When you install CTM on a computer that did not have Rollback you are fine
But if Rollback was working on your computer and you uninstalled the program than in most cases you will have problems

CMT is an exact copy of Rollback so there is no need to install both programs.

Rollback RX, EAZ-FIX, and CMT are not the exact same programs. They share the same engine but all are different. All however, share the ability to make and restore snapshots. Installing any 2 of these together could be a disaster.

The point is that I have never installed both programs together and it was very clear in my post.

I was very happy to find CTM because it’s FREE and I do have excellent experience with Comodo. The problem I had on Windows 7 was AFTER UNINSTALLING ROLLBACK, I did not have the a problem with CTM on XP SP3 AFTER UNINSTALLING ROLLBACK.

BTW Rollback was reinstalled on Windows 7 after CTM failed and it’s working fine, I think CTM has a problem handling the BCD (C:\BOOT\BCD) file if Rollback was installed but was removed from the computer.

Your post states “I installed CMT on XP SP3 without any problem replacing Rollback.”. You call that clear? Does it say you “uninstalled” Rollback RX or does it say you “replaced” it? One could easily read in the comment that you installed over it.

Replacing means instead
Did you ever tried to install CTM when Rollback is installed? CTM will not allow you and ask you to uninstall Rollback. Also if you installing CTM after uninstalling Rollback but there are some leftover CTM will let you know that and ask you to remove it.

My post was to let Comodo know about a problem with the BCD file.

Calm down guys :P0l :P0l :slight_smile:

I apologise.

hi, Tal

I’ve tried the problem several times on virtual machine, but it didn’t reproduce. This is my reproduce steps:

  1. Install win7 with the system reserve in the only one partition C and install vmware tools
  2. Install Rollback 9.0 (not 9.1 because I cannot install 9.1 on virtual machine) and take some snapshots
  3. Uninstall Rollback 9.0 to Baseline (not current system) and I didnot clean the registry
  4. After restart, install CTM
    The result is win7 booting successfully and CTM works fine.

Did I miss anything when reproducing?

Thanks & Regards

Could u tell me what the difference is? Nobody wants to tell me, some kind of mystery. What’s the difference between RollBack Rx and CTM? Internally. I’d be very grateful.

This is as I understand it.
Rollback RX is the original program. Their engine can be licenced out and re branded. EAZ-FIX is an example of this. EF usually lags behind on new versions (they just released 9.1 which came our months ago with Rollback RX).
These companies have merged. The product keys are now shared. These programs are basically the same.
CMD has been modified more. It has a much simpler user interface and has a 1 button update which Rollback RX says can’t be done. Lots of nasty talk on their forum about this.
For the money you can’t beat CMT but since I paid I will stick with Rollback RX.

This is Horizon Data Systems official response…

[i]Both Horizon DataSys and EAZ Solutions are sister companies that jointly develop and market RollBack Rx and EAZ FIX. RollBack Rx is marketed specifically for the commercial, educational and consumer market. EAZ FIX is the original brand that is offered to worldwide resellers and OEM distributors.

RollBack Rx can be purchased and supported directly from Horizon DataSys (

EAZ FIX can be purchased from any of our resellers such as or as well as many others.

Both products are exactly the same. Both RollBack Rx and the Resellers of EAZ FIX are supported by the same technical support team at Horizon DataSys.[/i]

The situation is not the same because:

  1. I am not using VmWare and I tried it on a real machine NOT Virtual.
  2. I did use Rollback 9.1 which is compatible with Window 7 according to Rollback web site, and I am not sure about version 9.
  3. It’s very important to have Windows 7 on ONE PARTITION and to make sure that the 100 MB Hidden Partition is part of C drive.
  4. When I uninstalled Rollback I did it to the current system NOT to the Baseline

Here is the way to get rid from the 100 MB Hidden Partition during the Windows 7 installation.

I do like Comodo and I am using Comodo Internet Security for a year. I also used the registry cleaner but had some problems.
As for CTM I am back with Rollback 9.1 (Latest Version) and don’t have any problems. Looks like CTM is not ready and needs some improvement, I’ll keep my eye on it and will try the next version.
:frowning: :frowning: :frowning:

hi, Tal

This issue is caused by unclean uninstalling Rollback. Please check if the regkey of SOFTWARE\Microsoft\Windows\CurrentVersion\Uninstall\Rollback Rx exists before installing CTM. If there is, remove it and CTM can be installed succesfully. Thank you very much for your feedback! Enjoy CTM!

Best Regards

Well I did registry cleaning before installing CTM.
I know the new version 2.5 is out but I will follow the forum and see what other people dealing with it, meanwhile I’ll stay with Rollback.

Yes same exact thing happen to me kinda.

Read my post here to fix and for info.

Re: Post here if CTM distroyed your computer -;msg369620#msg369620