Windows 7 CIS error during system restore

After the latest Windows update the system would not start, I decided to do a restore from a previous Restore Point. I have tried many Restore Points and Critical Update Points and I ALWAYS get the same error. ==>System Restore failed to extract the file (C:\Windows\System32\drivers\sfi.dat) from the Restore Point. <== At that point the restore terminates.

My system was not restored, no changes were made. the SFI.dat file is a locked CSI file that Restore doesn’t know how to deal with. How to I fix or work around this so I can get my computer working. I don’t have my original Win 7 CDs with me.

I do not know what version of CIS i am running but it is fairly recent. Obviously I can’t start the system and look.

Thanks for helpful suggestions

Try this. Restart your computer and, as soon as it starts booting up, tap F8 repeatedly until an options menu comes up. Then select the option to “Repair Your Computer” and press enter. Answer any questions the wizard asks you and let it fix whatever problems it finds.

Let me know if that was able to fix whatever is happening.


Without his windows CD that could end up in an infinite loop from windows repair. I really hate that tool.

Maybe will help.
Reply #14