Windows 7 / CDE boot loader conflict


No wonder i was pullin my hair out… i discovered by accident after changing a few hdd’s around in my pc that the cde password prompt exists and is working fine, but won’t show up if the hdd’s are plugged in different order. So the problem at the moment is that when the hdd’s are switched to allow the CDE password prompt, windows won’t load. tells me bootloader is missing (even though im pretty sure the system hdd is the hdd with the bootloader on it, ie not on a seperate drive), and the only hard drives ive got plugged in is the encrypted disk im trying to access, and the normal system drive. swapping them around allows windows 7 to load normally, but it won’t display the boot time password prompt.

ive tried fixing the bootloader using win7 cd / repair, hoping it would reallocate/ammend the bootloader to the system drive if it wasnt already on the system drive, allowing me to both enter the password and then continue loading as usual… but the repair kept coming up with a bootloader error which it refused to fix for an “unknown” reason even though it knew it was the bootloader and i seem to be stuck between swapping hard drives around.

im going to double check to see if the bootloader is indeed on the system drive or not. in the meantime i’d appreciate any advice/help on the problem.

once again thanks for your time

Bootloader is correctly stored on the main system drive. its there, just the stubborn CDE doesnt want to realize its there.

Tried using rescue cd to restore my encryption settings, all good till the point “no matching hard drives found”, despite the comodo-encrypted hard drive being inserted and detectable by the bios. no changes were applied, im assuming.

Bios settings did affect the process, system hard drive had to be 1st boot priority otherwise it would say “missing operating system” as opposed to “BOOTMGR missing”, also tried changing them arouind to trial and error. the flash drive/key is detected properly; and regardless of the password being right or wrong, it just doesnt click over to load the OS as normal, and the boot.ini/other system files dont recognize or list the presence of a seperate bootloader or OS entry. theres seemingly nothing for me to work with in order to get this to work.

I would really like to know whether comodo records/stores hardware-specific information about the partitions or hardware itself when encrypting the drive, and whether it calls for the same information/assumes the same hardware configuration when attempting to restore the settings.

help required please!