windows 7 black screen full screen game launch work around

When I have defense+ turned on… any games that launch in full screen will disable keyboard, mouse, and make the screen black… the only way out of it is to reset (power button power down doesnt work). Games that launch in windowed mode (or allow you to edit the launch file to make them windowed don’t have this issue).

If i turn defense+ off (turn off permanently not just disable from the taskbar) then the games will launch with no issues.

i check the defense+ logs and nothing is mentioned… i also can’t seem to find anything in the windows logs when this occurs either (it appears to freeze before anything gets logged perhaps?).

i am posting this here for the googlers of the world… when they have this issue they can disable defense+ (Open comodo click the Defense+ tab choose advanced choose Defense+ settings then checkmark the "deactivate the defense+ permanently then reboot) and the game should launch.

i am also posting this here for comodo… anyone have any ideas what a fix for this might be? i don’t like trusting that there is no malicious code in every game i play… would prefer to have defense+ running :smiley:

have a good day

info: video drivers are current nvidia drivers for a 9800gt (, machine is a quad core intel 4 gigs ram, windows 7 pro upgrade fresh install.

There are 2 ways to work around.

Either first time you start a game you has to switch CIS to Training Mode before or you add the game to D+ and threat it as trusted application.

1.Change Defense+ mode > Training.
2.Change Firewall mode > Training. your game. your game for a while.
5.quit the game.
6.change defense+ and Firewall mode > default.
7.go to ‘Network Security Policy’ ‘Computer Security Policy’
8.choose your game .exe file ex)dragonfly.exe ‘Edit’>select ‘Use a Predefined Policy’>Choose ‘Trusted Application’ ‘Apply’
11.feel free with your game.

The key point is training mode.

Thanks for the suggestions, however that is what I was doing. Even in learning mode it will freeze windows 7. Total disable of defense plus is still required with some games… like FarCry… not sure why.

Did your follow exactly what I said?

Please show me following details.
1.your D+ settings including ‘Computer Security Policy’.

2.Windows 7 build number?

3.Windows 7 edition?



Is that Farcry 2?
Farcry2 works fine in my system.(Windows 7 Ultimate Retail X64)
I think your have other problem.

Maybe your Firewall is not set correct, and the cause of freezing is Firewall.

Please check this.

What I’d like to know is why this happens. I have a number of games which routinely make encoded modifications to encoded keys in their CLSID. Under XP & Vista, I just as routinely block these & the game works fine. It’ll even work without an Internet connection so I don’t think these are ‘reporting’ back, but I still don’t trust encoded data that isn’t necessary. I’m pretty sure it’s added by the distributor, probably to support their DRM.

What I’ve found is that under Windows 7 HP (64-bit) I can run the game as Installer (not Installation Mode) and it works. If I run it ‘normally’ then even when I Allow all modifications, it doesn’t. So what’s the difference between treating it as an Installer vs. Allowing it to make changes each time I’m alerted?

(By the way, I don’t want to change to a different distributor. This is the only distributor I’ve found that does allow the games to run without an Internet connection.)

All applications who run in full screen (games) freeze the computer with a beautiful black screen.

This problem is know since February 2008.
Single solution change firewall and defense+ to training before and rechange after (

I have installed CIS since 2 days and I have had it, I am “fed up” to reset my computer. :-TD

Any chance for a updating for CIS ?

Hello, and thanks for your answers.

But, from what I understand, your workaround is considering the application as safe in the first place, isn’t it? Is there a way to have games running while still monitoring what they do to the system or if they try to send (or recieve) data from the web?

For instance, how am I supposed to do when I want to run a full screen application without allowing it to connect to the network, or to write to places in the system where it should have nothing to do?

Anything new on this? I’ve had the same issue, and as mentioned in several forum threads it can be circumvented by going into training mode. Is there a chance of any other solution coming up in future releases, or is it simply something which can’t be helped? Also I’d be interested in the technicalities of this; the discussions never seemed to mention any possible causes.

Best regards,

The problem is, that when the game goes into fullscreen mode and no action of this game is already allowed, a CIS alert window appears behind the fullscreen. So you can’t access this window to allow/block an action. So the game doesn’t respond as long as you can’t access the CIS alert. So in best case you can switch with strg+tab or with strg-alt-del to desktop and allow/block the alert. In worst case, you can’t do this and you have a freeze - only restart helps.

Are you using CIS v4? I have only tried a few games so far but I have yet to experience the old lock-up behaviour again. The new sandboxing feature will cause some games to hang or crash, but system controls were still fully accessible when that happened (any files in “My Own Safe Files” bypass the sandbox entirely).

I wasn’t aware of the new version, because I relied on the Check for Updates option; sounds interesting. I’ll probably check it out later or wait until an update release comes out.

Well this problem still persists a black screen locking me out of my pc with only a hard reset offering a way out. I had problem with Cities In Motion and Dead Island. Very annoying problem! Especially when you have no visual error to go by. Two years to sort this problem out… I feel sorry for the other gamers out there thinking they have a buggy game.

Happily, Windows Vista has brought back “classic”, like in NT4, Ctrl-Alt-Del behavior, when Ctrl-Alt-Del brings us to secure desktop, instead of simply launching task manager in XP. So we’re, being “locked” by such “black screen” circumstances, now able to press “magical” Ctrl-Alt-Del and click “Start Task Manager” on secure desktop’s screen. After that, not in all cases, any time and with any game, but in most cases our regular desktop with CIS alert will reappear and we’ll be able to take decision on CIS’s question.

So, there is no solution for this?

the most irritating point of this is that we don’t have to be gamers to suffer this, in my case and MANY others, we could be full of work then we want to take a breake, a little game and then you lose ALL your unsaved work, this happened in two machines both with windows7 and comodo, an different games apparently a not so friendly combination.

Now i know if i want to play i have to disable comodo, nice, but still i am concious that one day i’ll forget to diable it and then i’ll have the problem again.

There is no need to disable CIS to be able to play a game.

Let’s take a look at your situation and find a solution.

Can you show screenshots of the Defense + logs (View Defense + Events) and Firewall logs (View Firewall Events)?

Can you also show screenshots of your firewall Application Rules and Defense + Rules?

What version of CIS are you using?

Hi everybody,

I have just installed Comodo firewall for the first time. I have been using it for a couple of days now, and I love it. Being a (hopefully former) Zone Alarm Pro user for almost 10 years now, I find Comodo much stronger in customization support and it’s also free.

But there is one thing that really annoys me, and people in this thread have explained it in quite detail.
Why is Ctrl+Alt+Del blocked when (I suppose) a Comodo firewall popup window blocks the full screen application ?
I believe it should be configurable. It would be great if experienced users could configure the firewall not to block Ctrl+Alt+Delete.