Windows 11 - Computer stops responding shortly after boot & logon

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
At first it appeared only from time to time, yesterday it was 100% reproducable.

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1: Boot Computer
2: Logon to Windows
3: Wait 10-30 Seconds

One or two sentences explaining what actually happened:
After the computer boots, and I logon to the computer it takes a few seconds and my computer is in a weird frozen state. The applications I have already opened before the “lock” are working. I am unable to launch new applications (absolutly nothing happens if I click them), this includes taskmanager with the hotkey or anything else.

One or two sentences explaining what you expected to happen:
Well, obviously that my computer does not semi-freeze.

If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
It started happening after updating my computer from Windows 10 21H1 to Windows 11 21H2. In the beginning it occured only rarely, like once a week. Like said, after I logon to the computer, if I start immediatly let’s say the browser, it opens and stays usable (until I try to close it, then the window freezes). But I am unable to launch any other processes a few seconds after I logon to my computer, taskmanager does not open, not even CTRL+ALT+DEL gives me a response, only chance was the reset button. As an IT Engineer, I tried to troubleshoot it myselfe quite some weeks ago (needed to find the reason first), but oddly, for example in the event logs there was absolutly nothing suspicious. I disabled as much as possible from my autostart programs (left CIS intact) but it did not help. Yesterday the problem started to occure permantly. So I disabled as much as I could from CIS in safe mode, then managed to logon normally and trigger the uninstallation, the issue was gone with CIS… after a few clean reboots I reinstalled CIS and the problem immediatly reappeared after the reboot, so I keep it uninstalled for now.

I need to add, that I only used the firewall. For AV I kept the Defender running. The onliest other things that dig deeper into the system /network stack which are running are Oracle VirtualBox and I would say: Cfos Speed, which comes with my mainboard software from MSI…

Exact CIS version & configuration:
Latest available as to 29th December 2021

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
HIPS, Firewall

Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
Probably, been using CIS for quite a long time.
if so, have you tried a a a clean reinstall - if not please do?:
Yes I did
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 11 Build 22000.376

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
Windows Defender

Not much of help but CIS V12.2.2.8012 has been released to be compatible with Windows 7, 8 and 10.
For some users CIS works on Windows 11 for others it does not.
Maybe better wait for a new CIS version which is officially compatible with Windows 11 too.