Windows 10 Mobile Hotspot blocked by Comodo firewall (solved)


In Windows 10 (with the Anniversary Update) there is a nice easy to use feature called “Mobile hotspot”. Here is how it works:

How to Turn Your Windows PC Into a Wi-Fi Hotspot

When Comodo firewall is enabled I can connect to the wifi hotspot but all network data is being blocked by the Comodo firewall.

How can we allow the Windows 10 Mobile hotspot in the firewall?


Does no one have a solution? Should I just by an Access Point device for 60 dollar at my Internet Service Provider?


What happens when you set the firewall to disabled? Also try disabling the network filter driver from the network adapter properties window by unchecking comodo internet security firewall driver. I’m guessing comodo removed the functionality to handle requests when the computer is setup as an ICS server.

With the Comodo Firewall disabled, the hotspot just works like it should.

Is there a way to make an exclusion in the Firewall settings to allow the Windows 10 Mobile Hotspot to work?

When you have the firewall enabled are their any blocked events in the firewall log? Do you have Enable anti-ARP spoofing enabled? What does your global rules look like? Temporary set the firewall to ask for incoming connections by running the stealth port task under firewall tasks and select “alert incoming connections”.

There is nothing in the Firewall log about this.


I clicked on “Stealth ports” and then on “Alert incoming connections” and tried to connect my adroid mobile device to the hotspot Wifi. No Comodo warnings poped-up on my computer.

But the mobile device instantly connected to the hotspot instead of giving the error “Failed to obtain IP address”.

I started the browser on the device and I noticed I had internet! :smiley:

Thanks for your help!

Looks like a global allow incoming rule needs to be set if the firewall is set to stealth ports mode. Sounds like a rule to allow incoming DHCP requests and maybe even DNS requests. For DHCP ports 67 and 68 and DNS port 53 and set the protocol to TCP or UDP in the firewall rule window.

I opened those ports in Comodo Global Rules, but it does not work. (see image attachment). Any idea?

I guess it would be better to just create an allow in rule like the following: Allow direction: In Protocol: IP Source Address: MAC address of phone Destination Address: Any Protocol: Any. Then just remove those other rules as they won’t be needed anymore. That way you’re only allowing incoming connections from the phone and not other devices an the LAN.

Thanks so much, this solution works! :azn: