Windows 10, Comodo CIS and Sandboxie

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Yes. 100%
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Use Windows 10 Build 10240
2:Install Comodo CIS 8.2 or higher
3:Install Sandboxie
4:Open File Explorer (My Computer)
4.1: Right click on a folder or harddrive > Run Sandboxed
4.2: explorer.exe “Application was unable to start correctly”
4.3: Using “work-around” instructed in this post fix some problem (ie. able to run few certain software but most don’t work) See:
One or two sentences explaining what actually happened:
Seem like there is a compatibility problem with Comodo. Either due to comodo blocking Sandboxie or it doesn’t play well since Comodo have a virtual desktop.
One or two sentences explaining what you expected to happen:
Software to work/launch when sandboxed like it is with older version of Windows.
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Yes. Only some program/software work when using Sandbox. See: and
For references, discussion.
Any software except CIS/OS involved? If so - name, & exact version:
Comodo x64
Windows 10 x64 Build 10240
Sandboxie 5.04 x64 Bit
Any other information, eg your guess at the cause, how you tried to fix it etc:
Might be due to “Detect Shellcode Injections” since that was a workaround that fix some (5%) of the problem. I tried to disable to and see it that 5% can increase to 90% but no luck. Many program/software will refuse to run.

Exact CIS version & configuration:
Comodo x64
Enable HIPS: Safe Mode
Auto Sandbox: Disable

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Antivirus - Sateful
Firewall - Custom ruleset
Autosandbox - Disable
HIPS - Safe mode
Viruscope - Eanble
Have you made any other changes to the default config? (egs here.):
Disable all Comodo online function: e.g show message from Comodo center, Cloud Lookup and yet Comodo Agent (cmdagent.exe) still try to spam you with over 1000 connections a day.
Have you updated (without uninstall) from CIS 5, 6 or 7?:
Clean install from a clean Windows 10
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
No. All setting is manually allow/block
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 x64
UAC Never notify/disable
Account: Local admin
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=? b=?

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)
Always attach the diagnostics file (instructions on how to do this provided here) and the KillSwitch Process List (instructions on how to do that provided here) and put the resulting file in a zip file. Both should then be attached to your post.
Note that additional information may be requested by the processing Moderator.

Thanks for you tell us the issue , our devs need time to know why , then to solved it


Re: Flykite,

Thank you taking notice. Another user (gjf) also report the same/similar problem, see:

It seem that other x64 software also showing conflict. For example, Irfanview (Image Viewer), x32 run fine and work but when it come to the x64 version you will encounter an error.

For download link:
x32 -
x64 - download: files/

Hi ,fghcoc

I'm sorry :( ,i can't reproduce your new issue (about:iview.exe),I download your files and run on my win10x64 os ,all well .Can you tell me more information if you awlays reproduce the issue ,thanks

Best regards

Good read to all those who have trouble with this. I finally discover a work-around or fix if you can call it that. I am uncertain of the security risk should anyone follow my instruction.

By adding exclusion to “Shellcode detect” (see post #1) to “Executable” all" *.exe" files will work from now on. Rather than adding Sandboxie’s folder or “exe” file, add “File Process > Executable”.

How I came to discover this is as follow:

  • Uninstall Comodo. Restart computer. Try Sandboxie all software that did not work and throw the 00000e5 error. All work fine.
  • Install Comodo, try it again, error appear. So it obvious that it not my customized setting that causing this. It must be Comodo.
  • Initially I thought it was my HIPS setting. Then I try adding Sandboxie installation folder and it’s Container folder. Some improvement to what I can open Sandboxed but still many error.
  • Then I look through it all and try Executable and this is the result. As said above I’m not sure if there is a security risk doing this.

I hope Comodo v9 will fix this issue (is it an isolated one?). Else this is the best (workable) method in th emean time. Should anyone come up with a better solution please advise everyone.

Thank you.