Win7 CD stopped working under standard user, still works under admin

Win7 64 up to date, CD up to date, firewall, malware scan clean, chkdisk clean, been running in Standard user for a year to try to block malware installs. Been using CD for years and years. And last night it pops up “doesn’t exist or you don’t have permission.” All the other programs I tried still run in Standard. Then I found CD will start and run if I log in as Admin, but won’t if I right-click and RunAsAdmin. I don’t think I did any updates yesterday.

Is there any way to track down why this happened? What file lacks permission? And how to fix it? (I’d rather not give it admin permission)


I have the same issue. It was fine last night but this morning upon logging in my admin account came up with this and then my user account also did. At first the user account was fine, but after rebooting a couple times it does not work either. It’s really annoying and if you use Comodo’s online support unit they want you to pay for them to t/s your computer. It’s not the computer, it’s an issue with Dragon.

EDIT: Interestingly, I am able to open Dragon while running in safe mode. All of my previously open tabs are there as well. Not really sure whats up!

Just thinking out loud. Did the two of you happen to run a Windows update directly before the problem started to arise?

What files cannot be accessed or should I ask files in what folders cannot be accessed?

No, I have not run Windows update since last month’s bug patch Tuesday and this month’s is still three days away. I’ve run CD hourly since the last Windows update. I did install the Windows update the month before, before they yanked that because of problems. I didn’t see any of the problems some were seeing and the uninstall instructions were complicated enough that I decided to leave it. I wasn’t able to find out whether last month’s update repaired the previous month or not.

It may or may not be related, but I did run CCleaner to flush old files prior to this showing up. Some have reported problems with version 4.18 I think, but I’m still sitting at 4.17. I’ve run CCleaner repeatedly in the past and have never seen this problem with CD in the last year. I’m also not sure that CCleaner even incorporates checks for CD.

I also ran Secunia to check for out of date files and it found zero files that needed updating last night before I had this problem. I believe the last updates I did were the Adobe mess middle of last month.

I did get one other bit of advice from elsewhere, “Nobody knows, Nobody cares, UNIVERSAL Windows response: Reboot. Did it fix it? No? Then uninstall, reinstall and move on.”

But before I do that. I did some Google searching for “Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.” in quotes (which doesn’t include the target file or device name, unfortunately, I wish it did).

One suggested that perhaps your AV thinks some file is a threat. See if your AV has it blocked. I searched through the Symantec menus and logs and I don’t think this is the case. I also searched through the threat history to see if any report matched my trying to start CD and again, no match. I even repeatedly tried to start CD while watching and refreshing the AV history. No hits. So I think that might make this a less likely explanation. I also checked Norton File Insight and all files appear to be rated good or better.

One suggested some permission might have been turned off. So I used Windows Explorer to walk down the path and check read and execute permissions of everything down and including all the files in the Dragon folder, for System, Admin and user. All seemed identical and allowed user to read and execute. So if it is a permission then it is outside the CD tree.

One suggested trying to boot in safe mode and see if the problem goes away. I rebooted into Safe mode With networking and as user was able to start and use CD as an ordinary user. That helps narrow this down a little bit, but not in a way an ordinary user can determine exactly where the problem is. BTW: running CD Always starting and running Incognito.

I have for the last year or two been running Chrome along side CD without problems and Windows doesn’t report the same problem starting Chrome.

Since the other person seeing this is also reporting this when logged in as admin that seems different from what I’m seeing. As admin I have no problem, but “run as admin” and user consistently fail. I’ll certainly log in as admin and export all my configuration so I can have that if I end up with the uninstall/install.

I’ve tried looking through the event logs to see if I can get more information. Unfortunately every software problem I’ve had never leaves anything in the event logs.

I’m still looking for a way to identify exactly which file or device is causing the problem.

So, cautiously and carefully try each of the things I’ve tried and report back. I would NOT start installing anything, that seems as likely to add problems as it does to fix anything.

And thank you and anyone else for just thinking out loud, or even quietly mumbling over in the corner, just as long as I can make out what you are saying and aren’t afraid it might cause more problems than it fixes.

And I did not do any Windows updates either. All I know is it was working Friday night as normal and Saturday morning its not. And I cannot re-install or uninstall it either. Windows 7 64 ultimate. I run a user account for gaming only purposes. Otherwise the standard login for me has admin rights.

“Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item.” ----same with me. Everything else on my computer is running normally.

Hi BillSimpson and yobosaeyo,
In case corruption to Dragon’s user profile has occurred, try the following.
With Dragon closed, try deleting the ‘Web Data’ and ‘Web Data-journal’ files found in the following location.
C:\Users\Username\AppData\Local\Comodo\Dragon\User Data\Default
Note: The above procedure will cause loss of auto-fill entries and search engine preferences etc.

If the above fails try creating a new user profile.
To create a new user profile in Comodo Dragon-Comodo Help
Note: All user preferences and settings etc will be removed.
Be certain to back-up important data or items such as bookmarks etc.
Tip: Export your ‘Bookmarks’ to a HTML file to a known location for safe keeping, they can then easily be imported into a new user profile.
Importing And Exporting Bookmarks-Comodo Dragon Help

Kind regards.

Cold boot this morning into standard user and the instant the desktop appeared I clicked on CD on the task bar. I was very surprised that it opened! I checked that CD was working, closed, tried to open again and same error. Log off and into Admin to backup settings and again same error. That seems perhaps the two of us are more likely seeing the same thing. It takes 10-20 seconds for Win to finish getting everything initialized and I am guessing I got CD to open before something else was finished initializing.

Reboot into Safe mode, drag the Web Data and Web Data-journal onto the desktop, so I might be able to drag them back later. Back to standard user and CD same error. Tried dragging the entire Default folder onto the desktop. Same error. Back to Safe, open CD, backup my bookmarks, thankfully, exit and rename Default profile to Backup Default. Back to standard user and same error.

Thanks for all the efforts.

After boot today i tried CD as Admin as usual and have the same problems. Before this i updated to a new version of CryptoPrevent and removed stuff with CCleaner 4.18. I am running Win 7 64…

Tried this, main admin rights account still a no go. User account opens with crashes of shockwave on default Yahoo homepage. When you close browser and attempt to re-open then back to original error. Did not even get to attempt of importing. Just tried and not stable. All the default extensions not happy before attempted re-launch

Are the others using CCleaner 4.18? This version introduced a form of active monitoring. May be that is interfering?

No, nothing has been run like that. my setup is running off an ssd I just installed in September. So everything is pretty fresh. I use webroot, an antilogger and super antispyware. It only started yesterday so I don’t know what to say. Nothing has changed on my computer and no suspicious web sites that might have done anything. All I know is it’s really annoying not being able to use the browser and not being able to install over or uninstall.

Hi yobosaeyo,
Just looking back through the topic, I noticed that Dragon opens for you in safe mode.
Considering this, it might be worth checking the logs of any active anti-malware/spyware programs to see if one of them is suddenly blocking any part of Dragon.
Sorry I have no other ideas at this stage.

Kind regards.
Edit: Spelling correction.

I use Webroot and a antilogger. I just checked the antilogger and saw that it had blocked dragon.exe. So i allowed it and launched dragon which went to my home page as usual. Dragon.exe was blocked by the antilogger on 10/12 at 1:26 PM.

When I inspect the Norton logs I see it say Dragon was preparing to access the net, just like I see it say that Chrome was preparing to access the net, but no indication that Dragon had been blocked. I see irregular entries in the log that CONHOST.exe was blocked, but these do not seem to match the times that I try to run Dragon. It is certainly possible that I’m missing something in a log somewhere.

Yeah, it looks like for whatever reason my Zemana Antilogger did block it. And the block time seems to correlate with when I booted it up yesterday. So, it looks like Zemana didn’t like something out of the blue. Glad we got that figured out. Thanks for the detective work. With enough of us running into the same issue we had to have some sort of commonality.
OT:Now, how do I get Dragon to use the Webroot password manager like Chrome does?

IF Dragon being blocked and by three different brands of malware filters, and I still see no clear evidence that is happening in my case, and all at roughly the same time, but apparently not by enough of at least thousands of other users because there doesn’t an uproar going on, then what are the plausible explanations for this happening? What happened in these three (and likely at least some other) cases? If it was one brand of malware filter it could be a bad update.

Could you other two folks check with the support site for your vendor and see whether anyone there might offer some information? If I thought I was seeing in the logs that this was the case with mine I would do the same.


I just tried turning off the Norton firewall and I still get the error message.

Sure, I’ll reach out to Zemana and inquire as to why it would have all of a sudden blocked Dragon. I’ll get back whe I get a response.

On Mon, Oct 13, 2014 at 11:20 AM, Armagan Tugsal wrote:

Dear ,

Thank you for contacting us,

We have forwarded this issue to our developers for their review. As soon as we have received their response, we will contact you to pass on the relevant information.

We thank you in advance for your patience and look forward to working with you to resolve this matter in a timely manner.

Best Regards,
Armagan Tugsal
QA/Support Engineer

Zemana Ltd.

On Mon, Oct 13, 2014 at 12:57 PM, Armagan Tugsal wrote:

We are unable to reproduce the issue, it should probably be a temporary false positive issue which is automatically fixed with the latest IG database.

Please open AntiLogger and navigate; management console → rules → click the rule which you want to change by the right button of your mouse → you can choose ‘delete this rule’ or ‘delete all rules’ option on the pop up window and restart your PC.

We hope this helps; please feel free to contact us if you require any further assistance.

I updated with this morning’s latest Norton rules, did a full scan, it found no new threats, CD then still gives the same error and more searching of the logs still finds no report that seems to be related to blocking CD.

Apparently the first guy’s advice was actually right. Uninstall, Re-install, and move on.

It works fine now, except that no matter how many times I import my previously exported bookmark html file I can never get the bookmarks back.

I now find that both copies of the exported bookmark files are identical and consist of only



Bookmarks bar

and nothing more.

■■■■. I really depended on those, incorrectly assumed that Export would have saved all those for me and all that information is gone now.


Very fortunately, before I followed the directions to delete some of the CD files several days ago I also made two complete copies of the
C:\Users\Username\AppData\Local\Comodo\Dragon\User Data\Default folder. Saving the current Default folder and replacing that with
the copy I made days ago seems to have recovered my years of bookmarks and other information. Hopefully nothing will go wrong with this.
If this continues to work then that is a great relief.