Why this comodo rule doesn't work?

I just hope all the executable files under the 3 folders in the upper left box can’t visit other files on my computer. They can only visit files in the specified 3 folders.

So, I have the settings like this: in the attachment.

But, it didn’t work. When I try to visit files anywhere on my computer with the player under QVODplayer folder, the files can be played normally.

WHY? How to fix?

[attachment deleted by admin]

Can you see if there is a rule called “All Applications” in Defense +? When the rule is there look for the rule you made for Qvod Player. The rule for Qvod Player is likely at a place under the “All Applications” rule. Now drag and drop the rule for Qvod Player to a place above the “All Application Rule”.

Thanks for the tip. Seems it didn’t fix the problem.

I tried to drag the rule for qvodplayer to the top of the list and put the rule for “all applications” to the bottom of the list, the problem is still there.

This won’t work, this option prevents from WRITING to the C;D;E drives, not reading.
There is currently no way to prevent an application from reading files.

Thanks for your help! I’m clear now.