why my comodo always receive 445 port connection?

recently my computers offen received connection ports just like 445ports 137ports 138ports and 139ports,however,the IP addresss from anywhere.for example the IP address Latvia in morning and IP address from american and IP address from china beijing

in this morning I start my computer just 2 hours but received 4conncetion from anywhere in the world.
this question happened several days. as if my computer installed comodo firewall ,the connection from anywhere offen ask comodo to received other computer’s connectings
why my computers offen received so lots of connection from anywhere in the world?how can I do it?

Hi Cups,

Welcome to the forums!
It seems your PC is directly connected to the internet without a router/firewall hardware in front of it.
In your case I would strongly advise to run the firewall stealth port wizard and chose the option to ‘Block all incoming ports and make ports stealth for everyone’.

There are a lot of infected hosts other noise (portscan etc) and crackers actively searching for new targets to infect, that’s probably the biggest reason you see those alerts.

thanks to reply my question
I checked my computer just now and I found my computer’s comodo’s firewall setting is correct
just you said,my comodo’s firewall’s Port setup wizard choiced Intercept all network connection and the others I hide the port but always received ms-ds(445)port’s and 137/135/138/139ports try to connecting my computer from anywhere in the world.
i want to know,why lots of ms-ds(445)ports always try to connecting my computer?whether my computer has virus?but i used antivirus f-secure scan computer it’s not found any virus.

i want to know if i choiced allow ms-ds(445)port connecting my computer, then ,horse program can connected my computer and download virus and destroy my computer’s program?

what is the reason of lots of ms-ds(445)port try to connectting my computer?

This is what I wrote what I call ‘Noise’ on the Internet.

  1. The IP you now use, might have been from someone else in the recent past, things he did (shared/port-forward etc) might now end up on your logging because you now have that address.
  2. Infected systems are ‘scanning’ the Internet to see if they can infect more pc’s so they will knock on your door (IP address) also to see if you are there.
  3. Crackers are scanning systems for a specific port to try to attack those, so they will also show up in your logging.

That’s what you are seeing, so seeing those does not necessarily mean you are infected.
If you just wish to block that traffic without logging then you have to create extra FW Global rules.

thanks to reply my question.
my computer used moden to connecting internet from ISP。so it’s means my IP addredd is Dynamic not static IP address in this case,why lots of computers from anywhere in the world want to try to connect my computer?what are their want to do?

if I want to kill or shut or hide ports such as 445.135,137,138,139,what should i do.i was very confused that los of windows message popup in my screen. i want to know how to set the popup message will not appear to my screen.i set comodo’s firewall’s network security rule,in port rule i add ports 445 137.138.139 ect in port manage’s hide but lots of message popup in my screen.

what should i do,please help me ,thanks

You need to change your Global Rules from the default settings where you will be asked about incoming traffic to stealth settings.

Go to Firewall → Stealth Ports Wizard → now choose the option “Block all incoming connections and make my ports stealth for everyone”. Now your Global Rules are set to stealth and you should no longer be bothered by those requests.

The default settings make sense for being behind a router. You will only get access requests from others on your local network that you may or may not want to give access. But with a modem directly connected to the web you get all the noise.

thanks to reply my question
thanks for your advices.mycomputer’s comodo are quiet.comodo firewall is very very strongly。thanks for EricJH and Ronny’s help~~thank you