Why is the Virtual drive not showing up in "My Computer"? [Solved]


yesterday I downloaded CDE and have successfully created a virtual drive - G.

In the supported notes it would seem to suggest that this virtual drive will appear in “Computer”.

This doesn’t seem to be the case.

When it did not appear I did hit refresh under View and still no result.

I was lead to this problem when I double clicked on the virtual drive - G , and was told that I was unable to browse as it hadn’t yet been formatted.


It was my intention to format virtual drive - G when I found it within “My Computer”.

I’m unable to format it as it doesn’t appear in the “My Computer” window.

I’m running Vista Home Premium.

Please advise.

Kind Regards,


[attachment deleted by admin]


Open CDE and go to Virtual Drives > Right Click > Mount
It should prompt you with a password and then go to MY Computer
You should see it now, if not go to the URL/Location Bar and Enter "G:" (Of course if CDE says its supposed to be "G:" Then it will direct you there, if needed to be formated Windows will prompt you.

Did this help?


If you are using Windows Vista please turn UAC off.

COMODO Disk Encryption requires administrator rights in order to mount/unmount vitual volumes. The virtual volume is not visible in windows explorer when UAC is on because when UAC is on, explorer.exe is running with limited permissions.

Thank you.

You are most correct.

Indeed, when I turned off UAC the virtual drive did appear as promised.

Thank you again for your technical nous.

Kind Regards,