Why is Comodo blocking this connection attempt

I am attempting to force MSN Messenger to connect to the service through a SOCKS proxy on the local machine. It works fine if I allow all connections from the program, but if the proxy is not functioning, MSN will connect to the service directly over the Internet, which I do not want. So I decided to try to block all connections from Messenger to any IP not in the Loopback zone. I defined two rules for msnmsgr.exe in the following order:

  • Block TCP OR UDP In/Out From IP Any To Not In [Loopback Zone] Where Source Port Is Any and Destination Port Is Any
  • Allow TCP OR UDP In/Out From IP Any To IP Any Where Source Port Is Any And Destination Port Is Any

Any connections to a server not in the loopback zone should be blocked by the first rule, and anything else should be allowed by the second. This seemed to work fine at first, but now it is blocking everything from Messenger and I am unable to connect. I look in the logs and it says that it blocked TCP communication from msnmsgr.exe with Source IP, Port 49300 to Destination IP, Port 8050. Why would it block this communication?

My Loopback Zone is defined as:
IP In [ /]

Try these rules for messenger instead:
allow/tcp-udp/out/any/Loopback Zone/any/any

If you use exclude checkbox for destination address, it can be same bug as for exclude checkbox for ports and port ranges. However, not sure.