Why does Comodo Firewall keep alerting me to Firefox connections each load?

I have loaded FireFox a bunch of times and each time I get prompts from Comodo to allow its connection. I click allow and I make sure the set it to remember my answer but it still asks me each time I launch FF. What gives?

p.s. I am using Custom Policy and alert settings are high

thank you :slight_smile:

[attachment deleted by admin]

What ports are hidden by ellipses in this rules window? You may want to allow connections from any source port, because source ports are randomly chosen for each outbound connection.

Or you can choose “treat firefox as web browser”