Where's my TV gone?

I just updated to version 7.0.315459.4132 and my 2 computers have disappeared from my TV’s network connections.
I have streaming turned on on my computers and stream movies from my computers to my tv over my wireless network.

This worked fine until I updated, now my computers have vanished. My TV still registers on my computers list of network devices, so the firewall is only blocking my TV from accessing my computers, but not the other way round.

If I turn off the firewall my computer reappears on my TV’s network. Turn on the firewall and it vanishes again. So it’s definitely the firewall that’s the problem.

So what setting(s) do I need to change in the firewall to get this working again?

I’ve had to turn off Comodo firewall and temporarily use windows firewall (sucks), but I’ll only do this for a few days before getting rid of comodo (which I don’t want to do) as I stream all the time and one computer is on 24/7. I don’t trust windows firewall to do the job.

Any help would be greatly appreciated.

You need to check the Global rules, if you have a block all rule at the bottom or any other type of block rules set them to log then check the logs to see what is blocked.

Or change them to ask so you have alerts.

I’ve just checked the global rules, all are ‘allow’.
I did notice that the list of global rules is different between the old and new CIS, with several of the rules in the previous version not being in the new one.
So I added the rules that were missing from the new one, but was in the old.
Didn’t make any difference.

Incidently I removed the new CIS from one computer and reinstalled an older version. The streaming works fine on that computer, but is still broke in the new one.

Some kind of help here would be great. I Have a similar problem.

A few days ago the PS3 and the TV stopped being able to see the PC media server while comodo firewall was turned on. Ive alterred nothing in the past few days bar an update of comodo.


I have a similar problem with my TV too. It started right after last update.


same here. all my external media devices are being blocked by the firewall after the latest update.
marked as blocked in the log under the generic “windows operating system” description, comodo still needs to enable to make rulesets creatable from the log and allow the log to supply accurate info which is the logs are meant for.
if i,ll find a fix that doesnt involve installing a better firewall app i,ll post back here.

Same here. LG TV used to see WIndows 8 laptop no problem. Comodo update broke this. Now can only see laptop when I turn off firewall. No amount of tweaking the rules seems to fix it. I did see the blocking listed in the log, but using these specific details to create a new exception didn’t help either. Please help!

Comodo’s response “Please open Comodo Internet Security, navigate to Tasks → Firewall Tasks → Open Advanced Settings → Network Zones and create a new Network zones that include IP address of your Smart TV to fix this issue.”

Not helpful, already done that. So if anyone has or can solve this. Please help!!

Comodo's response "Please open Comodo Internet Security, navigate to Tasks -> Firewall Tasks -> Open Advanced Settings -> Network Zones and create a new Network zones that include IP address of your Smart TV to fix this issue."

Not helpful, already done that. So if anyone has or can solve this. Please help!!

Was the first thing I did too. Individual IP of each affected device and tried an IP range. Neither worked.

Hello people. I have some ideas that may help with this issue. After reading

, I’m thinking, simply creating a new network zone, without creating a Global allow incoming rule for that particular zone, may in fact still have no effect. So I suggest, if you make a zone for whatever system, be it tv ip, console ip, device ip, etc, be sure to make a rule for that particular zone to suit your taste.

Also, if you are sure you have no global block ip in rules set, a few things I do for situations like this, since I like to be alerted when an ip attempts to connect to my system, I make sure my stealth port settings are set to (alert) instead of (block) incoming connections. I also like to make custom application rules which (ask) ip’s in. This can be helpful for situations like this.

After applying these changes, you can check by having your pc on and close by, then turn on your tv, game console, device, pc, etc., and see if you are alerted by comodo to the incoming connection. If you are, simply check the allow button (be mindful of the remember my answer check box, unless you do not want the alert anymore).

Lastly, be sure to carefully check both global and application rules for any block rules that may be present that you were not aware of. I can recall times in the past when I either did not answer an alert in time, or clicked (block connection) prematurely (without reading) during an alert and accidentally made a rule (be it global or application rule) that I thought was a comodo preset and would have never realized without carefully looking over.

Good luck and keep us posted.

well i found a fix for my media devices, i removed all the application rules for a clean slate and tested one at a time.
the rule that worked i selected from running process “windows operating system” and used “allowed application” rule, the actual service that needed to be allowed was smss.exe lower down on the tree list and that didn’t work when selected to make the new rule from.

so this is probably a new bug in comodo and again looking at how many people have problems with trying to create and manage rulesets an option to create and service rules should be selectable from the log like blackice and visnetic firewalls used to have.

Brilliant. Thanks, Suicide Eddie. I did the same.
Advanced Settings
Application Rules
Add new Rule
Name - browse for Running Processes
Choose the group that is headed by ‘windows operating system’ and contains SMSS.exe
Personally I wasn’t sure about making it a trusted application, so I created a custom rule in here that allowed anything in and out from this application when it was in my home network zone (that comodo had previously created)

Now it works. No idea what broke this. I had comodo looking at it live through geekbuddy and they couldn’t fix it. So again well done, SuicideEddie.

@ suicide eddie and comdoughnut1

Thank you both very much.
After days of frustrating over windows and my Onkyo receiver it’s working.

Kind a lame I had to set some crazy rule to allow something like DLNA to work but I’m happy it is finally working.

Thanks again!