When I nega-Comodo block Internet Explorer

Hi all,
sometimes when I open to programs. Some programs, they wish to access Internet, Comodo personal firewall open an windows near watch for ask me Yes or nega. When I click on nega Comodo personal firewall block Internet Explorer. (with me happen with program System Mechanic Professional) Then Internet Explorer disable to open pages. Then I close Internet Explorer & open Comodo personal firewall ,clicck on application monitor & edit block Internet Explorer (Allow).Then I can navigate in internet.
My question is this, why don’t comodo only block program access to Internet (place of Internet Explorer)
Thanks to all.


Comodo Firewall Pro blocks Internet Explorer because the OTHER application is using Internet Explorer to send data via the internet. In the example you’ve quoted, System Mechanic Professional is not access ing the internet directly, it is using Internet Explorer to access the net. CFP blocks the communicating medium, not the originator of the outbound call.

Hope this helps,
Ewen :slight_smile:

Hi panic,
Yes ,I know,But problem is this:-
When sometimes I entered in my e-mail pages to see e-mails or other pages ,then open windows of CFP to ask me for yes no, when I click on no, then Internet Explorer go disable to open all pages. CFP forced me to close Internet Explorer & open CFP clicck on application monitor & edit, In this condition I can navigate. I re-open e-mail server ,rewrite id- pass etc. & same happened all other my finished work in Internet.
Can’t CFP block only programs (Applications) to access Internet not block Internet Explorer ?
Thanks for quick repely.


In the case of opening a link from your email, when CPF gives you the alert, you know it’s happening, and know you want to see the website. In that case you can click to Allow the connection. If you also choose “Remember” when you click Allow, you should not see that alert for your email client again.

When one application tries to use another different application to access the internet, CPF is programmed to alert you. The popup message will tell you the exact nature of the connection attempt.

If you choose to Deny the connection, CPF will shut down your internet connection, as you have experienced.

If you choose to Allow the connection, without choosing to “Remember,” CPF will only allow the connection for that instance only. That way you are not creating an Application Rule to always allow that type of action.


Hi Little Mac,
Yes ,I know, this is simple thing . But problem is this,that I cannot click to Allow the connection of some applications,only for this purpose I installed CPF.
With a lot of thanks,


I know this issue. Some applications are mentionned without the two buttons expected, accept or deny. I don’t understand why they doesn’t appear. There might be a rule for that, a rule coded by the dev team ; nothing to be set by end users, :(.




If you mean the same as:

I think that some aspects of Application Behavior Analysis may not give the option for Allow/Deny; I think I have seen that before, although only very rarely. I would need to see a screen shot to better understand what alert you are seeing.

If you mean that you are not sure whether to Allow or Deny as a user, I would answer this way: If you Allow (without choosing “Remember”) CPF will only allow the connection for that instance; it won’t create a permanent rule. If you Deny (without “Remember”) then CPF will block your applications. You may be able to recover the internet connection by closing and re-opening the applications in question.

If you think you want to Deny, make a note of the Application and Parent Application (such as winamp.exe, with Parent of explorer.exe, for example), then create a rule in the Application Monitor to Block that Application and Parent (you can also simply set the parent to “Learn”).

In either case, a screenshot of the popup alert you are getting would be helpful.