When CIS Is Installed XBOX Games Cannot Login To Accounts [M928]

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    I can reproduce the problem each time i launch some XBOX games from the Windows Store, (ex : Wordament, Microsoft Mineswepper, Microsoft Mahjong, Microsoft Solitaire Collection, etc…).
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:I did a clean install of Comodo Internet Security v7 and do everything it asked, like a quick scan and computer reboot.
    2:I launch a Windows 8 App from Windows Store that requires a loggin from user to a XBOX game account.
    3:Next, the application says it fail to login, and it looks like Comodo without any alerts from firewall or anti-virus compomnents, block Xbox login.
  • If not obvious, what U expected to happen:
    I expected that the Apps could work properly and can login without problems.
  • If a software compatibility problem have U tried the conflict FAQ?:
  • Any software except CIS/OS involved? If so - name, & exact version:
    Every Windows Store Apps with login to XBOX games accounts (some examples mentionned above)
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    The problem appears when you install Comodo and restart your computer. The worst is that even if all components are off , the apps are still unable to login to XBOX games. To solve this problem, you must completely uninstall the product.
    I tried also to install antivirus alone (without firewall) but there is the same problem.
    Also i tested this on four computers, and all had the same problem.

A workaround for this (which must be done every time) is provided below:
Download Process Explorer and run it with administrator privileges.
Then open the Xbox game.
Then use Process Explorer to kill cavwp.exe and cmdagent.exe.
The game will then be able to connect.
After that cavwp and cmdagent will automatically restart.

[ol]- Exact CIS version & configuration:
Comodo Internet Security 7.0.313494.4115, default configuration (Internet Security)

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    Modules enabled by default.
  • Have U made any other changes to the default config? (egs here.):
  • Have U updated (without uninstall) from CIS 6 or CIS7?:
    No i did a clean install.
    [li]if so, have U tried a a clean reinstall - if not please do?:
    [/li]- Have U imported a config from a previous version of CIS:
    [li]if so, have U tried a standard config - if not please do:

    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Windows 8.1 64 bit, UAC on, Microsoft Account and XBOX account.
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=Hitman pro and malwarebytes (third party softwares, on demand scanning) b=no

[attachment deleted by admin]

Thank you for submitting this bug report. Please create a diagnostics report and attach it to your first post.
To create this left-click on the question mark icon near the upper right corner of the CIS main screen. Then select Support and then Diagnostics. This will run the diagnostics, and after it is done offer you the option to save the diagnostics report. Save this and attach it to your first post.

Let me know when you have accomplished this, or if you have any questions.

Thank you.

Here it is, I attached the diagnostic. :-TU

No problems were found so far by the diagnostic but the problems i found are still on.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Here it is, i attached the “CIS configuration.cfgx” file asked.

The problems i encountered are stil there.

[attachment deleted by admin]

Thanks. I have attached the configuration file to the first post.

Just to say that Praetorian has reported the same issue that I am experiencing. Cannot log into Xbox games.

Using Windows 8.1 and Comodo Internet Security 7.0.313494.4115. A Clean installation of CIS.

Thank you. I have updated the tracker letting the devs know that at least one other user is experiencing the same issue.

Thanks again.

Not fixed in new version : CIS 7.0.315459.4132…

Thanks for checking this. I have updated the tracker.

Not fixed in CIS v 7.0.317799.4142… ( OS version : Windows 8.1 Update 1)

I would like to remmember that this bug can affects many people and not just me; mart44 is an example.

If people (not fan of Comodo) install your antivirus and they discover that it blocks what they want to do, what will they do ?

They’ll just uninstall it and switch to another security software from another company and they will remember comodo as a buggy software that they’ll never want to install again and you’ll loose possible customers… :-\

Thank you for checking this. I have updated the tracker.

Just letting you know I have the same problem with signing in to xbox games in Windows 8.1 with or without update 1.
I can sign in the the games app ok but individual games wont sign in.

I did not uninstall cis at first and spent a few hours today tiring to fix it.
Then I unistalled cis and I could sign in again.

Then I checked to see that it was a known bug and at least it’s not just me.


I just looked at the trusted vendors list and noticed Microsoft Live gaming on Windows is listed twice.
Not sure if that is correct or not but I thought I would let you know it case it helps.


Thank you. I have updated the tracker with the new information.

The bug still present in CAV/CIS version 7.0.317799.4142 that causes blocking games to connect xbox service.
Under version 6.3 works, or disable helper service.

Thanks. The tracker has been updated.

Same issue for me. Windows 8.1 Update 1 with latest Comodo Firewall. Uninstalling Comodo fixes the issue. Even specifically allowing the individual EXE files does not allow them to connect. Oddly I can log into CutTheRope fine… but Uno, Solitare, WSOP, PinBallFX, etc. refuse to connect to xbox.com. The issue seems to block the eBay app (eBay.CoreApp.exe) as well. Firewall is behaving normally otherwise.

Thanks. I’ve noted in the tracker that multiple users are experiencing this, and that it seems to occur only for those on Windows 8.1. If anyone is experiencing this, but is not using Windows 8.1, please let me know.


I have same problem with Windows 8.1 Update 1 and latest version of Comodo Firewall 7.