What could it be?[SOLVED]

So, during the morning, after being working with a virtual machine connected to the Internet (shared connection with Host), I noticed that my connection started to go crazy. Such thing never happened before.
I went to see what processes were connecting to the internet and that could be somehow messing with it; then I notice that CIS (the firewall) does not show the inbound and outbound connections. I performed a diagnosis with CIS’s tool and found no errors. I uninstalled CIS and reinstalled it. No deal.

I even repaird the Winsock LSP, but no deal.

What I don’t get is that I can see what connections are happening, for example, with LinkScanner Pro. So, why can’t I with CIS?

Note: I created a thread in CIS - Firewall Help. https://forums.comodo.com/firewall_help/no_inboundoutbound_traffic_shown_urgent-t31039.0.html (No answers so far). I decided to create this one with new info, also 'cos I think it may not be related to CIS at all? No idea.

Does anyone have a clue?

Tried to reset and reinstall TCP/IP, but worthless.

Could this be a bug in Comodo’s firewall? Did, somehow, VMware ■■■■■■■ up the firewall’s hability to monitor outbound and inbound traffic?

I just don’t get it!

it sounds like an incompatibility to me. What other security software do you have installed?

Hello Egemen.

Thanks for the feedback! Truly appreciate it!

I considered that option. But, I don’t think it is the situation, as the security apps I have installed are the same since CIS (at least the second updated version) came out.

I also forgot to mention that it totally messed with Norton Antivirus 2009 as well. The SONAR feature wouldn’t work. I couldn’t fix it. I had to uninstall Norton and reinstall. Then, I noticed the system was slow. I checked what was wrong and it was the DNS Client which was turned ON. I use a custom HOSTS file, so it needs to be turned off. I thought this could be it, but, then again, CIS never had any issues before.

I can’t explain how, but, somehow, VMware totally messed with CIS and Norton. I could fix Norton, but can’t fix CIS. I even deleted CIS configuration INI file. No deal.

Anyway, these are my security apps:

CIS (except the AV) + SafeSurf
Comodo BoClean
LinkScanner Pro (which I can monitor traffic, so, I guess nothing wrong with my system, right? The way they function to monitor network traffic is the same?)
Norton Antivirus 2009
Haute Secure
Trend Micro RUBotted (Still haven’t uninstalled this one (Never conflicted with CFP/CIS.). Norton offers such protection. But, too lazy for that. Will do it, perhaps, in a few days, if in mood :slight_smile: )
Spybot Search & Destroy


Edit: Don’t know if relevant, but when all this started to happen, I uninstalled VMware.

By the way, is there any way to tweak the CIS registry entries, so that it monitors traffic once again?

I’m not concerned with the protection CIS offers, as it is protecting. It was the first thing I checked! :smiley: It’s just the traffic… it won’t monitor it anymore.

Also forgot to mention that before all this happened, everytime I connected to the Internet (Vodafone Connect Box), Defense+ would alert me to allow or block the connection to the DNS servers. No longer does it. I guess it is related to the fact it does not monitor at all.

The problem has been solved! It was related with DNS Client. Somehow, VMware messed with it! I had to delete my custom HOSTS file, then enable DNS Client to automatically load at startup and now it works just fine!!!

Once again, thanks egemen for your feedback!!!

Best regards

You fixed it yourself man:)