went to install on my pc and getting a warning message

I have the firewall on my old laptop running Vista and have never had a problem. I had gotten a new desktop quite a few months ago, but really haven’t used it much since there were some family & health issues and I used it very little.

Anyway, I downloaded the free firewall software yesterday and went to install it on the desktop running windows 8.1 (64 bit) and got a message across my screen stating Windows Protected Your PC and that running this app might put your pc at risk.

I am guessing that this is just windows not wanting me to use a different firewall. But just want to be certain before I go any further. I did download the program directly from the comodo website Free Firewall | Best Comodo Firewall Software Download 2022


I do hope that I posted this question in the correct location and I do apologize if it was posted in the wrong spot. :-\

Try downloading it from the release topic here: https://forums.comodo.com/news-announcements-feedback-cis/comodo-internet-security-8204674-with-win10-support-is-released-t112353.0.html

thanks, I will go to the link you suggested and download it from there and try installing it. Thanks Again :slight_smile:

Thanks that link / download did not give me that warning message. Going to restart my pc now so the changes can take affect. Thanks Again :slight_smile:

the install went smoothly as did the restart with one little problem. My volume icon that sits in the system tray (where is shows my internet connect and the icon for installing the windows 10 update) is now missing and it is not in the show hidden icons section either. The only thing there is the Dell Audio icon and that was there before the install of the firewall.

Any idea of how to get that icon back so I can easily control the volume ?


I actually have no idea, sorry. :-\

I was doing a search and most of the steps that I could find were not resolving the issue. The one for turning it back on by right clicking near the clock and selecting properties and it takes you to control panel>all control panel item>notification area icons>system icons had the volume option greyed out and in the off postion so I couldn’t turn it back on that way either.

Finally found that by going to Task Manager and clicking on the Details tab and finding explorer.exe and stopping it then going to file > run a new task and typing in explorer.exe the icon is now back in the tray.

Thanks again for everything.