Weird ICMP Ping Request filtering in v2.3 final (worked in 2.3 beta)

GRC is failing constantly on this one even though it worked in CPF 2.3 beta (properly!). Why on earth is this not working anymore?!
Now i have to block my PC from answering this instead blocking it in the first place.

So instead blocking inbound ICMP Echo Request i have to block outbound ICMP Echo Reply.
Basically both do the same job done, except i had to use “backyard” path instead the more obvious one at the front doors…

No, wait. Now even this ■■■■ isn’t workin’ anymore >:( WTF!?

I wouldn’t say both do the same job, if you are blocking it from getting out in the first place.



Heh now it’s working.
Btw, you don’t get it. Echo Reply and Echo Request aren’t the same. Echo Request is initiated by remote PC. Echo Reply is the answer from YOUR PC to a remote PC that requested this in the first place. So if you block the Echo Request you won’t have to filter Echo Reply asy ou already blocked it. Allowing Echo Request requires filtering of answer to it which is Echo Reply.
Though i don’t get it why it worked and it didn’t and now it works again. Huh.

Correct, but as you said in the first post… < Now i have to block my PC from answering this instead blocking it in the first place> So if you block it from answering you are blocking the outbound not the inbound which is a bit different? You wanted to block the incoming to begin with, correct? Perhaps I poorly worded my reply, well actually there’s no doubt that I did, but there is a difference when blocking access to or blocking the answering is what I mean. There is a difference in allowing \blocking incoming and blocking \allowing outgoing. Do both do the same job in a way? Yes, blocking the return, but there is also a difference here. Ahhh, anyway, you got it working, that’s what matters, and I am no good at explaining so maybe you can decipher my scratchings, lol.



Ok, this thing is clearly broken. C’mon, it worked in v2.3 beta but in final version it’s broken ::slight_smile:
Please fix this asap because everything depends on it here. Without it i may as well use Windows firewall…

Did you make a clean install?

It works very well on my system…

Reinstalled like 4 times already and each time i get weird results. v2.3 beta ALWAYS worked perfectly. Donno what Comodo guys changed in Network Monitor part…

strange… ???

We havent changed anything actually. Can you describe us exactly what behavior r u seeing? More details for us to be able to reproduce?

C’Mon? You are receiving an error about some CPF subsystems?

Sorry wasn’t checking forums here…

CPF 2.3 BETA always got Full Stealth on GRC by using BLOCK Inbound ICMP Echo Request packets.
Ping Reply was not responded back to GRC. But now in CPF 2.3 final even if i set it exactly the same it will always show as Ping Reply failed. Like it’s not filtering packets properly.
I’m not getting any erros, just this weird behavior. Logs were also empty even though i’ve set it to log such events (so they weren’t even filtered).

CPF 2.3 BETA always gave me PASS as result for Ping Reply test but now it doesn’t. Exactly the same rule.

You are not behind a router are you?

No, direct ADSL connection to net using PPPoE.

So, an ADSL modem? If so, which one?

Doesn’t matter a sthere is no firewall in it if that’s what you mean. System is not aware of it, like it’s not even there. All i get is internet connection into my LAN card.

What you can do is to add ALLOW & LOG IP IN/OUT FROM ANY TO ANY WHERE IPPROTO IS ANY rule just below the ICMP rule you created to see what CPF allows. I.e if it allows outgoing ICMP ECHO REPLY you will see it in the logs and we will understand what is happening.