Weird font, can't get rid of

It’s probably not a “bug” per se, but the version of IceDragon on my stationary computer (but not on either laptop) has somehow switched fonts on certain programs – primarily it’s the headings and the names on posts in Facebook, and the inbox in Yahoo mail – to a weird block-cut-type font where I can’t see what’s bold (unread in Yahoo) or not.

The only font setting I find in IceDragon’s options is under Content, Default font. When I checked, it was set to Times New Roman (which is definitely not the font I’m seeing). I tried changing it to Arial, but it hasn’t made a difference. The other two computers I run IceDragon on show a normal sans serif font (presumably Arial or something similar) on these pages.

Can anyone tell me how to change it back on my PC?

It sounds like the problem you’re having might be similar to the topic discussed here:;msg764958#msg764958

Hmm. Thanks, but it’s not the buttons or links in Yahoo mail, it’s the message list. If I could figure out how to upload a screenshot, I’d do it.


Oh, and IceDragon is set to allow websites to show their preferred font.

See UploadScreenshot image below.

Thanks. I clicked on Additional Options, but somehow didn’t see the attach box… Which makes it even more likely that I’ve clicked on something in IceDragon that I don’t want.

I was wrong, the buttons are in the block-cut font, too, but mainly it’s that the whole message list is written in this font that doesn’t have a bold variety. The top spam message is new and would be bold if it were in a normal font. While, for example, the Comodo page is in a standard sans-serif font. In Facebook (I was wrong there, too) it’s the “Like”, “Comment”, “Share” and “Reply” links that are in the weird font. No other pages seem to have it – Gmail, Google,… So it’s just something I’ve somehow done to Facebook and Yahoo Mail.

Have you tried using the default theme? Are you using any add-ons/extensions that could interfere with fonts?

The image below is what I get using the default theme and IceDragon

I haven’t changed themes recently, but here’s what it looks like on my laptop. Completely different font, easily recognizable which messages are new. Up until a few days ago it looked exactly the same on the PC. Obviously I’ve changed some setting somewhere, but I’m ■■■■■■ if I can figure out where!

Did you check to make sure gfx.downloadable_fonts.enabled preference is set to true in about:config?

Oo, never tried that before! Will do so as soon as I’m back on my stationary computer in the morning, thanks!

Alas, that wasn’t the problem. It was set to true. I skimmed the other settings with the word font in them and switched “gfx.font_rendering.cleartype.use_for_downloadable_fonts” to true (it was the only setting that seemed remotely likely to make a difference) and restarted IceDragon, but that did nothing. Changing themes didn’t change the font either. This is just plain weird.

Try searching for font.internaluseonly in about:config. Did you get any results? If so what are their values? If any of them are bold, change them back to default.

Are any of your font choices different from what is shown in the image below?

Thanks! font.internaluseonly.changed was bold and set to True, so I changed it to False per instructions. My language settings window looks the same as yours except for the Windows XP-style layout. And it didn’t have the option “Western European” under legacy content, just “Default for current location” or “Other (includes Western European)”. I assume “default for current location” (which IS in Western Europe) should be correct.

Annnnd, on restart after toggling the font setting… nothing. Still the weird block cut-type font.

Sorry for the confusion. That image was from a different browser. My bad.

I don’t think this is your problem, but you may want to check what your selection is for text encoding. Go to View, click on Text Encoding. Unicode should be selected.

I think it is time to find out what that weird font is. On one of my systems, Yahoo Mail is using the Arial Bold system font for all unread messages. The image below shows the steps to take to find out the name of the font. I will repeat those steps here for the benefit of those that need to translate.

  1. Hover your mouse over the text you want to inspect, then right-click and select ‘Inspect Element’. It may take a few seconds for the results to appear.
  2. The text you hovered your mouse over should be highlighted. I circled that text in red in the image below.
  3. Click on ‘Fonts’ to display the name of the font. In the image below, Arial Bold which is one of my system fonts is the name of the font for all unread Yahoo messages.

Let us know what that weird font is and if it is a system font.

Now we may be getting somewhere. I get:

font: 10pt HelveticaNeue, Helvetica Neue, Helvetica, Arial, Lucida Grande, sans-serif;

Looking in my Windows font folder, I have Helvetica Neue Bold and Helvetica Neue LT 55 Roman, but not one called HelveticaNeue (joined) or just plain Helvetica Neue. I also have several with Lucida, but no Lucida Grande. So perhaps what I’m seeing is a font substitution.

I hate to be dense (but I’m so good at it!), but where do I click on View to check the text encoding? IceDragon doesn’t have a standard menu, just the little drop-down one, which doesn’t have a View.

Hi ChangelingSE,
To show the menu bar.
Press ‘F10’ or ‘Alt’ to temporarily show the menu bar.
Or right click a blank area on the tab bar and select ‘Menu Bar’.

Kind regards.

OK, thanks. Yes, it’s set to Unicode.

Thanks for helping out, captainsticks. Sometimes I can’t respond very quickly because I’m away from my computer for an extended period of time, so any help is appreciated.

ChangelingSE, if you haven’t already done so, check your laptop to see what fonts Yahoo Mail is using for the unread and read messages, then compare that to your desktop computer. On one of my computers, the Arial Bold system font is used for the unread messages and the Arial system font is used for messages that I have already looked at.

I’m about to give up. I don’t know how to see what font it shows in the message list, because I can’t select text in the message list (clicking opens the message, clicking and dragging drags the message). But if I open a message and highlight text, I now get this. It claims that this is supposed to be Arial, but it’s not.