Weekly schedule setup ignores Sundays

It does not matter if I set the schedule from a script using the following command line:

/schedule_Mode weekly /scheduleSettings “Sunday|Monday|Tuesday|Wednesday|Thursday|Friday_00:01”

OR I use the GUI and tick the options as per the attached screen shot (all days except Saturday), Sunday is omitted from the task that CBU creates in the Win7 Task Scheduler.

When I amend the task in the scheduler, the result is overwritten by CBU after that task has run. This re-writing of the task not only removes the correction to the days of the week, but also removes the other changes like run when not logged on, kill after 1 days etc, which I would like to keep for unattended, service type runs.

I note the “/onsucces” also needs to be mispelled. Perhaps parsing spellings is the problem with “Sunday” as an argument?

[attachment deleted by admin]

Please make sure you have the latest version.
The issue with Sunday was reported in an older version.
The issue with “/onsucces” will be fixed in next release.


Ver: 3.0.171317.130

Update button says “The application is up to date”.

So I guess that patch didn’t stick?

Our QA department tested the issue and could not reproduce it.
Please post the script file you used for setting the schedule.


Since I was able to cause the same issue via the GUI as well as via a script, I can only assume we are not using the same code-based. I am using a version that reports itself as Ver: 3.0.171317.130, with no updates to be found on checking.

Script as follows:

@echo off

rem On-line help on Comodo Backup
rem Comodo Help
rem On-line help on command line options
rem Comodo Help

rem For testing
rem set sources=“U:\website”
rem For real
set sources=“U:\website|U:\shared|U:\home|C:\inetpub\wwwroot|C:\Users”

set backup_path=
set backup_dest_file=“%backup_path%\backup.cbu”

“C:\Program Files\COMODO\COMODO BackUp\CBU.exe” ^
/backup_operation ^
/type filesandfolders ^
/source %sources% ^
/exclusionfilter “.tmp|.bak|Thumbs.db|ZbThumbnail.info” ^
/description “Daily Scheduled Backup - Incremental” ^
/destinationtype destinationtypediskfile ^
/destinationpath %backup_dest_file% ^
/backup_type incremental ^
/parent_backup_storage_type destinationtypediskfile ^
/parent_backup_path %backup_dest_file% ^
/compressionlevel medium ^
/diskusage high ^
/processorusage high ^
/compressionlevel medium ^
/diskusage high ^
/processorusage high ^
/locked_files_treatment vss ^
/emailnotification ^
/onsucces ^
/onfailure ^
/smtpserver xxxx.xxxxxx.org.uk ^
/port 25 ^
/subject Daily Incremental Backup ^
/sender backup[at]xxxxxx.org.uk ^
/recipient me[at]xxxxxx.org.uk ^
/emailusername “xxxxxx” ^
/useSSL 0 ^
/guiRunModeServiceModeRun ^
/silentRun ^
/scheduleTask ^
/schedule_Mode weekly ^
/scheduleSettings “Sunday|Monday|Tuesday|Wednesday|Thursday|Friday_00:01” ^
/log_file “\backup.log” ^
/log_method “append”

Thank you.
The problem will be fixed in the next release.