Webmin Plugin

Last Comodo WAF client can be easily integrated into Webmin

You may use this guide to install CWAF on your server under Webmin management.

Release Notes:

Webmin supports a lot of Linux and Unix OS. We couldn’t check new CWAF client on all Webmin-supported systems, it was tested with the last Webmin Webmin 1.750 on the next OS:

  • CentOs 6.x
  • Ubuntu 14.x
  • Debian 7.x

Please send us your feedback to improve Webmin support.


Thank you for webmin plugin, I’m waiting so long time :slight_smile:

I install on Centos 7, but css, js, img, tpl files does not load.


ln -s /usr/local/cwaf/web/cwaf /usr/libexec/webmin/cwaf/

Best regards,

Thank you, Hasan, we’ll use your solution in the next version of installer.

22/03/16 09:46:59 updater[4862]  debug is ON, level = 10
22/03/16 09:46:59 updater[4862]  create pid file
22/03/16 09:46:59 updater[4862]  rules are not installed, try to install
22/03/16 09:46:59 updater[4862]  lwp_params: timeout=60 sec, save_to_file flag: 1
22/03/16 09:47:00 updater[4862]  HTTP response code: 403
22/03/16 09:47:00 updater[4862]  Error reason: Auth failed
22/03/16 09:47:00 updater[4862]  ERROR: can't connect to CWAF rules server
22/03/16 09:47:00 updater[4862]  update process finished!

I can login on waf.comodo.com but got the above message trying to update via webmin.

It was a special char in my password. Fixed now.
ln -s /usr/local/cwaf/web/cwaf /usr/local/cwaf/web/webmin/cwaf/ solved my css problems on ubuntu 14.

In case you didn’t know, Virtualmin 5 comes with a brand new HTML 5 theme, great improvement so likely everyone will want to be using it. However the Comodo WAF plugin won’t display with this new theme and you have to switch back to the old one to use it.

Any chance we can get this compatible with the new theme?


please delete below line in /usr/libexec/webmin/cwaf/cwaf/tpl/index.html

<script type="text/javascript" src="cwaf/js/plugins/jquery-1.11.0.min.js"></script>

After the last update (to version 2.18.1) breaked my interface…

Can anyone help me to fix it? (I’m using Debian Jessie and the lastest webmin… everything worked fine before the CWAF update)

Please, try to run:

# wget https://waf.comodo.com/cpanel/cwaf_client_install.sh
# bash cwaf_client_install.sh -- --update

Not worked… when I open the console debugger on browser, I got this errors:

Content Security Policy: A directiva ‘frame-src’ está obsoleta. Por favor, use a diretiva ‘child-src’ em vez disso.(unknown)
ReferenceError: jQuery is not defined [Learn More]jquery-ui-1.9.2.custom.min.js:6:2
ReferenceError: jQuery is not defined [Learn More]jquery.qubit.min.js:4:1
ReferenceError: jQuery is not defined [Learn More]jquery.bonsai.js:247:1
ReferenceError: jQuery is not defined [Learn More]chosen.jquery.min.js:2:10864
ReferenceError: $ is not defined [Learn More]cwaf_catalog.js:65:1
ReferenceError: $ is not defined [Learn More]cwaf:50:1

Have the same problem like eulergui.
Looks like the problem comes form:
Uncaught TypeError: e(…).uniqueId is not a function
at HTMLAnchorElement. (https://localhost:10000/cwaf/cwaf/js/plugins/jquery-ui-1.9.2.custom.min.js:6:166998)

Anybody could direct me how to solve this problem?

Hi guys

Try to modify file /usr/local/cwaf/web/cwaf/tpl/index.html
You will find here lines:

[% IF main.virtualmin != 1 %]
<script type="text/javascript" src="cwaf/js/plugins/jquery-1.11.0.min.js"></script>
[% END %]

Please remove [%someting%] lines so it will look like:

<script type="text/javascript" src="cwaf/js/plugins/jquery-1.11.0.min.js"></script>

Regards, Oleg

Tanx Oleg. Tried your suggestion and I get : TypeError: $.url is not a function .
A blank screen now.
Is there no way to switch to newer less buggy versions of jquery and jquery ui?


Please write ticket to support (Submit a ticket - Powered by Kayako Help Desk Software department ‘WAF Support’) so we can ask for remote session.

Regards, Oleg

This worked for me!! Thank you very much! :slight_smile:

Glad to hear it :slight_smile:
I hope soon we will prepare improved version of plugin which will work for any Webmin theme

Regards, Oleg

Hello friend,

You have to change the webmin theme. You are using the “Authentic theme”, a HTML5 theme, correct? So… you have to use the “Virtualmin Framed Theme”… ok… it’s ugly but is what works for now :slight_smile:

To change the theme go to: Webmin > Webmin Configuration > Webmin Themes > Change Theme
Then, select the theme “Virtualmin Framed Theme”.

EDIT: After changing to “Virtualmin Framed Theme”, reload the browser with Ctrl+F5 (I’m using Google Chrome) to entirely reload everything. It will work now :slight_smile:


if any of the Webmin users can not install the module (manually or via install script) due to the following error:

Undefined subroutine &main::init_config called at /usr/share/webmin/install-module.pl line 45

I’d like to inform that I had already reported the bug to the authors - fix has been already commited on github and in the new version there won’t be any problem with that: Current dir is not always in the path https://www.virtualmin.com/node… · webmin/webmin@e4af713 · GitHub

Generally everything that calls “&init_config()” function from “WebminCore” gives the same error, including “cwaf-cli.pl”:

/usr/local/cwaf/scripts# perl cwaf-cli.pl
Undefined subroutine &main::init_config called at cwaf-cli.pl line 45

I would like to ask maintainers of Comodo CWAF to add one line. I am sending a diff below:

root@host:/usr/local/cwaf/scripts# diff cwaf-cli.pl cwaf-cli.pl.patched
>    push(@INC, ".", $root);

Best regards,


Thank you for reporting this problem. We crated a bug for this and will fix in next release of plugin.

Regards, Oleg

Can’t get comodo cwaf in webmin centos 7. I just get a blank page!


The issue is related to the Webmin’s Authentic Theme. For example, with default or Gray Framed Theme everything works fine.

Still, there is a workaround available for the problematic theme, try replacing “1” to “0” on your “blank CWAF page”:
https://localhost:10000/cwaf/?xnavigation=1 ==> https://localhost:10000/cwaf/?xnavigation=0