Web Page Display in Firefox [NBZ]

The bug/issue

  1. What you did: [b]go to: http://www.vcdq.com/[/b]
  2. What actually happened or you actually saw: see photo below
  3. What you expected to happen or see: Normal display, see photo below
  4. How you tried to fix it & what happened: Disable CFP
  5. If its an application compatibility problem have you tried the application fixes?: n/a
  6. Details (exact version) of any application involved with download link: Firefox 4.0 Beta 7
  7. Whether you can make the problem happen again, and if so exact steps to make it happen: Enable CFP
  8. Any other information (eg your guess regarding the cause, with reasons): Attached

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug: Attached
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List: n/a
  3. A CIS config report or file. Attached
  4. Crash or freeze dump file: n/a

Your set-up

  1. CIS version, AV database version & configuration used: n/a
  2. a) Have you updated (without uninstall) from CIS 3 or 4, if so b) have you tried reinstalling?: Clean Install
  3. a) Have you imported a config from a previous version of CIS, if so b) have U tried a preset config?: New Config
  4. Other major changes to the default config (eg ticked ‘block all unknown requests’, other egs here.) n/a
  5. Defense+ and Sandbox OR Firewall security level: CFP - Custom Policy Mode
  6. OS version, service pack, no of bits, UAC setting, & account type: WinXP Pro SP3 32 Bit
  7. Other security and utility software installed: SAS and MBAM on Demand
  8. Virtual machine used (Please do NOT use Virtual box): n/a

When visiting http://www.vcdq.com in Firefox, CFP is blocking TCP Out from to which keeps the site from loading completely (no prompts from CFP). I have Firefox and IE both set as Web Browser in my CFP configuration. Viewing the page in IE works fine. If I disable CFP, the page loads fine in Firefox. Could you point me to a fix for this? This is the only page I visit that I have this problem.


Attached screenshot of rules that allow page to fully load.

[attachment deleted by admin]

actually this was happening to me in firefox, i never throught CFW was the problem, i think firefox was the bad guy cuz i can enter in any page in Chrome without problems.

BTW i fix it uninstalling adblock and no scrips, then intall adblock again
(i not install no scrips again) and the problem was gone

I just tried a fresh, new Firefox profile with no add-ons. I still get the same result. In my case, it isn’t the add-ons.

I’m having the same result in ff v3.6.12, I have AddBlock and NoScript add-ons installed and I’ve told NoScript addon to allow everything from the page temporarely but the result is the same. I think this site maybe doesn’t work well with Firefox, I’ve encountered situations like this before and after some time I saw that the pages were working so it either could be the website or ff. Using win xp pro sp3 32 bit.

So you say dissabling cfp fixes it… hmm… I had a couple of cfp.exe crashes myself… see here: https://forums.comodo.com/bug-reports-cis/high-cpu-usage-firewall-t64990.0.html

I’m not experiencing any CIS crashes. If I temporarily disable the firewall through the right click in the System Tray and reload the page, Firefox displays it fine. CFP is preventing the page displaying properly, but I don’t know what to do to correct it. If I change my CFP settings for Firefox from Web Browser to Custom, I can get the page to display properly. It just won’t do it with CFP set to Web Browser (although this setting works for IE).

So to clear this up… what does cfp.exe does ? I thought is for the firewall but somebody on this forum told me is for the gui ! Which is it… I’m confused ! I had some cfp.exe crashes, I received a message that said Comodo has encountered a problem and needs to close and was at the same time with a cfp.exe crash report alert in the win event viewer !

Just now I’ve set ff to custom and it did displayed the page correctly ! Then I’ve switched back to Web Browser and accessed the page but… weird… it displayed it correctly ! Guess I have to close ff for the cookies to clear.

Yep, closed ff and accessed the page again and it doesn’t display it correctly anymore !

cfp.exe is the file for the CIS GUI (I don’t know why it isn’t cis.exe).

Other Abbreviations:

CIS - Comodo Internet Security
CFP - Comodo Firewall Pro
CAV - Comodo AntiVirus
CSC - Comodo System Cleaner
CRC - Comodo Registry Cleaner
CDC - Comodo Disk Cleaner
CPC - Comodo Privacy Cleaner
CTM - Comodo Time Machine

Same issue I’m having.

Same response on my system.

I get the exact same results with IE8 when set to Web Browser as I do with Firefox. They both look like your screenshot.

Do you think there’s any drawback to having Firefox set to Custom instead of Web Browser?

Hi L.A.R. Grizzly

CFP 3.14 on both Systems & different platforms (as in my signature)

The said page is displayed perfectly.

Browsers: Fox 3.6.12 ; IE8 latest 32bit & x64 , Chrome 7.0.517.44)

Fox has all Add-ons (& discussed Addblock+/NoSscript are enabled)

All Browsers are set to “Custom”


[attachment deleted by admin]

What do you get with Firefox set to Web Browser (if you don’t mind checking)?

I added an image above

I will test on both systems and write an addition here,
Just give me some time, cause Win 7 will be back in 15 min
XP will be tested straight away

I’ll B back

*** added ***

The Policies were changed on both systems to WebBrowser … all is fine
(images are attached) … That’s Interesting 88)


[attachment deleted by admin]

Well, after all, you’re using v3.14. Maybe there’s something different in 5.0. BTW, I’m using Proactive Security.

Proactive as well here as in my signature
Nothing was changed in Firewall at all since

At least that was an answer given quite a while ago when I requested that

That’s why I said “interesting” :wink:


You got me… I just thought that the Web Browser policy was the more secure way to go with web browsers. :smiley:

I just had a weird occurrence though… I installed Comodo Dragon ( beta) to see what it did, and the page rendered perfectly. I loaded it in Firefox and it also loaded perfectly. Then in IE8, it looked like your screenshot. ???

Oh yeah, must set Dragon to Web Browser… 88) Reload Dragon, same image as IE8. Reload Firefox, same image as IE8… Not sure what happened there. :o

Opera seems immune to this issue.

I’m running in Internet Security configuration.

I think I’ll just leave the configuration set to Custom. I checked my ports at ShieldsUp! and all’s well. The anomaly just had me stumped! ???

Thank you for your Bug report could you please include the info below in your first post, and also if possible attach a screenshot to your first post of your Custom rules you have now that allow it to display correctly.

6. OS version, service pack, no of bits, UAC setting, & account type:
7. Other security and utility software installed:
8. Virtual machine used (Please do NOT use Virtual box):

Thank you


  1. OS version, service pack, no of bits, UAC setting, & account type: WinXP Pro SP3 32 Bit
  2. Other security and utility software installed: SAS and MBAM on Demand
  3. Virtual machine used (Please do NOT use Virtual box): n/a

Sorry about not completing the info. I skipped some. I edited my first post.

[attachment deleted by admin]