VMware Workstation 8 - vmx86.sys error

The bug/issue

  1. What you did:

I tried to start a virtual machine as a standard user in VMware Workstation 8.0.0 build-471780

  1. What actually happened or you actually saw:

[i]I got the two following error messages:

First error message:

Could not get vmx86 driver version: The handle is invalid.

You have an incorrect version of driver “vmx86.sys”. Try reinstalling VMware Workstation.

Failed to initialize monitor device.

Second error message:

Cannot find a valid peer process to connect to.[/i]

  1. What you expected to happen or see:

I expected the virtual machine to start normally.

  1. How you tried to fix it & what happened:

First I tried to reinstall VMware Workstation as suggested in the first error message. This did not solve the problem. Then I tried to fix it by running VMware Workstation as administrator. The virtual machine started normally when doing this. I also uninstalled Comodo Internet Security and ran VMware Workstation as a standard user. This also fixed the problem. When I installed Comodo Internet Security 5.8.211697.2124 again the virtual machines could only be started successfully when run as administrator

  1. If its an application compatibility problem have you tried the application fixes here?:

  2. Details & exact version of any application (execpt CIS) involved with download link:

[i]VMware Workstation 8.0.0 build-471780


  1. Whether you can make the problem happen again, and if so exact steps to make it happen:

It happens every time when starting VMware Workstation as a standard user

  1. Any other information (eg your guess regarding the cause, with reasons):

Files appended. (Please zip unless screenshots).

  1. Screenshots illustrating the bug:
  2. Screenshots of related CIS event logs and the Defense+ Active Processes List:
  3. A CIS config report or file.
  4. Crash or freeze dump file:
  5. Screenshot of More~About page. Can be used instead of typed product and AV database version.

Your set-up

  1. CIS version, AV database version & configuration used:

Comodo Internet Security Product Version: 5.8.211697.2124
Virus Signature Database Version: 10474
Standard configuration

  1. a) Have you updated (without uninstall) from CIS 3 or 4:
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:

No I have first uninstalled Comodo Internet Security 5.5 and then installed version 5.8

  1. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:

I did not import a config from a previous version of CIS

  1. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):


  1. Defense+, Sandbox, Firewall & AV security levels: D+= , Sandbox= , Firewall = , AV =
  2. OS version, service pack, number of bits, UAC setting, & account type:

Windows 7 Ultimate 64-bit service pack 1, UAC on, Standard user account

  1. Other security and utility software installed:
  2. Virtual machine used (Please do NOT use Virtual box):

Please read here


Thank you


Ah thanks… I did search the forums for VMware but it didn’t give any results. Probably did something wrong.

Your welcome, the search does not always work well.

I usually use Advanced search this works a bit better but not always.