Visual C++ Runtime errors EVEN IN SAFE MODE!

Hi I have had VC++ runtime errors a few times now whilst submitting files.
A dialog points to a file called CFPSBMIT.EXE and says ‘Abnormal program termination’ (Not much else)
Once OK’d the submit file pop up closes and all returns to normal. (CFP running)

I am running D+ in CleanPC Mode and the firewall in ‘train with safe mode’. I am not sure but the last error may have been in installation mode.

I am running AVG antispyware and anti virus on XPpro SP2 all updates. CFP V3.0.14.276 x32

UPDATE I am unable to submit files at all. Runtime error as described above. Tried killing all running AVG process
but made no difference. does not seem to matter what file is submitted. cfpsbmit.exe crashes every time…
Thats right even in safe mode

ha ha!!!

I thought my RSS Reader (Attensa) was doing it. Oh you are my hero. Thank you.

I TOO AM GETTING c+ errors

Please download new runtimes from

X32 windows http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=32bc1bee-a3f9-4c13-9c99-220b62a191ee
X64 Windows http://www.microsoft.com/downloads/details.aspx?familyid=526BF4A7-44E6-4A91-B328-A4594ADB70E5&displaylang=en

Look for any Microsoft Visual C++ 2005 Redistributable package in your control panel uninstallation dialog and remove that.
Then install the new runtimes from safemode.

BTW please refer to the bugreport board stickied topics to read about bureporting guidelines.

Thanks for your understanding,
gibran

I’m getting a runtime error as well and after that I get a popup that says “The exception uknown software (0x40000015) occurred in the application at location 0x0064585e.”

I tried downloading those new runtimes but I’m using Vista 64 and when I try installing them I get an error that says “This installation package is not supported by this processor type.Contact your product vendor.”

I’m using version 3, any ideas?

Thanks,

Mick

Hello

I am also have the exact same problem as described in the first post. Could you please help me through this?

Windows XP Home Edition/SP2/Ver.2002/x86
Activly-running; Avira AntiVir PEClassic/ SpyWare Doctor/ COMODO FP ver. 3
Utility applications; Panda Anti-Rootkit
I installed Microsoft Visual C++ 2005 Redistributable Package (x86)/vcredist_x86.exe
and tried to submit My Pending Files with no luck, still received the runtime error.
My COMODO setup is Train with safe mode and Clean PC mode.

You might also want to know that Norton Internet Security was uninstalled using add and remove programs.

Thanks

UPDATE: Microsoft Visual C++ 2008 Redistributable Package (x86) has been released should i uninstall 2005 and install the 2008 version?

Yes, I can confirm it.
Reinstalling the 2005 redistributable doesn’t solve the issue. Don’t know yet what happens with the 2008 version

Thought i would give it a try, unistalled 2005 and installed Microsoft Visual C++ 2008 Redistributable Package (x86). Problem still exists.

Microsoft Released Microsoft Visual C++ 2005 SP1 Runtimes and added Vista support.

Please download new runtimes from

X32 Windows http://www.microsoft.com/downloads/details.aspx?familyid=200B2FD9-AE1A-4A14-984D-389C36F85647&displaylang=en
X64 Windows http://www.microsoft.com/downloads/details.aspx?familyid=EB4EBE2D-33C0-4A47-9DD4-B9A6D7BD44DA&displaylang=en

Look for any Microsoft Visual C++ 2005 Redistributable package in your control panel uninstallation dialog and remove that.
Then install the new runtimes from safemode.

NOTE: Installing Microsoft Visual C++ 2008 runtimes will not affect applications bulit with Microsoft Visual C++ 2005

If you still get issues then:

  • Disable DEP for cfpupdat.exe and cfpsbmit.exe (XP, Vista)
  • Report if you are using any skinning patch(uxtheme patch) or product
  • Remember to report the exact error message (all of them if applicable)

BTW. If you didn’t please refer to the bugreport board stickied topics to read about bureporting guidelines.

Thanks for the help gibran.

I still get this http://i180.photobucket.com/albums/x155/camifex/Screenshot.jpg unfortunatly.

Windows XP Home Edition/SP2/Ver.2002/x86
Activly-running; Avira AntiVir PEClassic/ SpyWare Doctor/ COMODO FP ver. 3.0.16.295
Utility applications; Panda Anti-Rootkit
My COMODO setup is Train w/safe mode and Clean PC mode.

I installed Microsoft Visual C++ 2005 SP1 Redistributable Package (x86) like you said in the above post.
I added both executables to the disable list in DEP.
I dont know what a skinning patch(uxtheme patch) or product is, please explain.

During the submit process it goes through the trouble of preparing the files im not totally sure if it prepared all of them but after a while the error message flashes up with no indication if they’ve been sent. Then every 10 mins or so a bubble comes up tring to send the files again. Pushing abort shows me this http://i180.photobucket.com/albums/x155/camifex/screenshot2.jpg and another runtime error appears.

I see you use the default windows theme and thus you are not using any other hack to load unsigned themes.
That alert was not helpful at all. This issue need a lot of work without any gurantee it will be solved. :-[

Usually an error like that means that one file needed by that failing app is not the required version. This scenario is known as DLL HELL

The first utility to run is sigverif to perform a default scan.
This will usually display dialog listing all unsigned files. Look at the attached pic and and see if any of the filenames match.

If there is no luck you could try to download individual dll files listed in the attached pic from http://www.dll-files.com/ and place them in the same folder containing cfpsbmit.exe
NOTE: you don’t need to consider Kernel32.dll user32.dll gdi32.dll ntdll.dll winspool.drv from the attached pic when you are going to download the dll from that site

[attachment deleted by admin]

Gibran, i appreciate all the help, but this is just way out of my league, i will be looking for someone who can do this for me. Guessing isnt really what i should be doing.
Just out of curiosity would uninstalling and reinstalling COMODO do any good?

Thanks

It’s worth a try but I guess it will not solve this issue.