Vista Updates Major Bug[CLOSED]

hello yep i am confirmed

I got very same problem. After installing Beta 2 no automatic update is available any more. I also noticed, that last time the system has looked for the new updates was the day before the Beta 2 was released. Additionally, when I force the system to download new updates manualy (Control Panel → Find new updates), first it asks for allowing to install the software update(??), then the update console closes and re-openes with an error, saying that system can not start the serching module. The error code is 80070643.
I looked up what does the code mean and all I found was that it’s connected with M$ Office. I have Office 2007 installed and I will reinstall it but I doubt it will help.

Any suggestions highly appreciated. I will update this thread if I find the solution or some new info.

I’m on Vista Home Premium. Other security software: NOD32 2.7, BOClean 4.25

There has been a recent active X update on windows update site for vista and XP.
Error code 80070643 link below.
I also had this error code for the Time update the problem is I have not got Office installed so I have given up on this update, all other updates install with no problems after stopping CPF v3.0.8.214.

Instead of uninstalling CPF I download updates failed install, then offline when to run/msconfig start and disabled CPF from starting restart install updates restart then run/msconfig enable CPF and restart.

I have experienced the same problem. (:AGY)

Getting the mentioned error 80070643 with KB933360 on Vista. Disabling Comodo to start up didn’t help either.

I used Autoruns from Sysinternals to disable all instances of Comodo and also disabled the client to start from the settings department of Comodo. Running the Windows update after rebooting, none of Comodo was started, still gave the same error. The following instances were disabled with help of Autoruns:

I tried the trick with starting the OSE as mentioned before to no avail. Oddly enough I can’t load the installer from the download pages of Microsoft as well. When I get redirected to the downloadserver the file cannot be found. Disabling my hosts file filter didn’t help either.

One thing I know for sure. It is not Comodo interfering.

The only way to solve my problem with Windows updates installation was to remove CFP completely. I also shut down BOClean and antivirus to make sure that nothing would interfere. When the updates were succesfully installed I put Comodo back into my system and now everything works fine - no more errors when updating Windows. It seems that the new Windows Update Software (v.7.0.6000.381) that was downloaded along with the updates is compatible with Comodo Firewall.

I had to uninstall Comodo in order to be able to install the KB933360 for Vista.

I tried to disable Comodo first like described before. That didn’help. Then I disabled a list of background programs and services to no avail.

Uninstalling did the trick. Makes me wonder though why disabling the start up of the above mentioned parts of Comodo didn’t work.

P.S. the problem of not being able to download a single update package turned out to be related to DNS problems of my ISP.

Thanks for the info about KB933360.
When they release a new beta I will install this update I thought the update file on my vista computer might be corrupt and had been searching for it, had this problem with XP approx a year ago and found the update file easily they have found new ways of hiding these system files on Vista.

Same problem here regarding that update, put it on hidden when I saw it only had to do with the clock settings :stuck_out_tongue:

But it would be nice this could be fixed, I totally agree.

experienced the same problem yesterday with beta2.

Uninstalling CPF allowed me to install updates without having them fail upon reboot.