Vista 32bit - uninstall v3 firewall - no dhcp

I uninstalled Comodo Firewall v3 using uninstall tool, also tried using the cleaner bat file that can be downloaded from this forum…

No matter what I do DHCP dosent work anymore, I dont have any system restore points and Statis IP’s works fine… How can I fix this?

Welcome To The Forums Terr1

What other security programs do you have and what OS are you using?


Windows Vista 32bit

Had AVG - uninstalled it as well…
Norton Security Scan
Disabled windows firewall
Windows Defender is running

Some other firewall might have been installed in the past but uninstalled now…

(Im trying to fix a laptop for some people I know, so not sure what has been installed in the past)… But I cannot see any other firewalls installed, or weird services running…

Have 2 other vista PC’s using the same ethernet cable no problems using DHCP, its not the server (router).

Ok, Terr1

I’ve had the same problem before and this is how i solved it,

Install Comodo Firewall Once Again, Restart … DHCP Should Be Working, Then Uninstall It From Add/Remove Programs … Then It Should Still Work, I’ll Ask Other Mods To Help You If this does not help :slight_smile:


Tried to install the lastest free version, dhcp still not functioning (it wasent before I uninstalled comodo firewall v3) not sure if its a setting somewhere…

Im not 100% sure if it was comodo that messed it up, just cant see what else…

What shows if you right click the connection in Network Connections,
Properties, highlight TCP/IP and take Properties. That can (and usually
is) set to obtain DNS (and IP address) Automatically, but might have got
changed to ‘use the following’ without anything actually set there

Some Other Steps

  1. Unplug the router
  2. Shutdown the PCs
  3. Restore power to the router
  4. Restore power to the PC with the conflict. It should now be able to
    pull the address from the router.
  5. Restore power to the other PCs. If one of them had an old lease that
    was causing the conflict, the renewal request will be denied and it will be
    able to pull a new IP.

Did This Solve Your Issue?


Hmm Im abit amshamed to say I rebooted my router (had it limited to 6 devices, forgot I had my PS3 and XBOX connected as well… and maybee a few not leased) so it prob. hit the limit heh… STUUUPID ME? Sorry for wasting your time… I will try to uninstall comodo again.

It’s ok,