Virus definitions do not update at all

I am currently running Comodo interment security version I had the same issue and already tried installed and reinstalled Comodo.
Comodo is telling me “Needs Attention”
I click on it the “The virus signature database is NOT up-to-date” window opens
I click on the “Fix It!” button
“Updates are ready to be installed. Would you like to install them now?” opens I click “Yes”
The window that is left at the top has the green check and said “Complete” BUT in the window the status of the “install update” is showing as “In progress” then the timer at the bottom right counts down from 15 and the window closes without completing the update. Comodo continues to tell me “needs attention”
Is this a bug with comodo? How can I fix this issue?

I have exact the same problem with the following version:
Product Version:
Database Version: 24928

I’m still looking for the way out.

Still no solution to this problem. tied to uninstall and reinstall. that did not fix the problem.
Can someone tell me where i can manually download the new virus definitions as a work around?

As if.

Do you think I’m stupid?

Please don’t hijack another person’s topic. You have your own topic.

ErichH, are you telling me that I’m a liar?

I’m going to try this again right NOW.

Then we can ascertain whether I’m a liar or not…

Please take a deep breath and count to ten. We don’t allow cross posting. It is described in the Forum Policy in paragraph 8 section 8. Please continue conversation about your problem in your topic.

Hi Craigind,

I’m updating now my Comodo manual. I’m using cav files from a VM (virtual machine) whti Comodo. I don’t have any problem with Comodo on that VM.

I realise that this is only work around, but I don’t have any better solution for now.
Have you found something?

Well yes I did find a solution… The nuclear one. Wipe the hard drive and reload Windows.
Seems to be working fine now

Roger that.