Virus database update stops at 30%

I’ve never had this problem until a day or two ago and since then I can ont update the virus database.

Program updates work fine. Am running 3.9.95478.509. Virus signature database version 1153.

OS is Win 7 RC 32x. (build 7100).

What am I doing wrong?


The udpate for the AV database is pretty big. The progress indicator stays at 30 % between 5 MB and 30 MB of the download reported somebody. So when the update is going slow it may take a while.

See if waiting solves it for you.


Get the message:
Failed to update the virus signature database.
Please check your internet connection and try again later.

The only thing is the connnection is OK and I can download, install, etc programs of any size.
Of course, can also signin to this forum and so on and so forth.

If I can figure out how to include an attachment, I’ll include the save I made of the error msg text using the Snipping Tool in Win 7.

[attachment deleted by admin]

As far as I know, Windows 7 support is not 100% yet.

If you hate XP/Vista etc, maybe you should use Linux, and therefore you won’t need Comodo. Good luck!

This also happens here as well.
Stops at 30% download and reports the same message.

COMODO 3.9.95478.509
Win XP,
Version 8 IE,
FF 3.5b4

Previous beta of COMODO did not report this and downloaded successfully.

Time to re-install Windows I think (joking!). I’ve got exactly the same configuration as you and Comodo is running as smooth as ever.

[s]Try to download the full base file here:
…link removed this is a incremental update…
rename it to bases.cav and copy that in safe-mode to c:\program files\comodo\comodo internet security\scanners

Reboot and see if CIS reports db version 1164 in the Misc, About window.

Then see if the next update works as expected.[/s]

Also getting failed db download at 30% with 3.9.95478.509.

Attempts to download every 15 minutes or so.

Have 1164 with last update reported in the program about 50 minutes ago. However my “Bases” files is dated yesterday at 8:38 AM ET.

UPDATE: Scratch that. Must have been temporary. Connected fine and told me DB was up to date after about 5 manual update attempts. As long as 1164 is still the current version, I’m good.

SECOND UPDATE: I see the current version is 1166. Updates either tell me I’m up to date at 1164 or fail at 30% (quickly - no hang) telling me to check my internet connection.

Same issue here. I can’t update from 1164 to 1166: updater tells me either I’m up to date or to check my internet connection.


I followed your advice of downloading 1164 and followed the procedure given.

Success! Then immediately updated antivirus the “normal” way and have 1167.

Whatever Comodo messed up, is now fixed again.

Many thenks,


They fixed it. I’m at 1167 now.

A word of warning:

same problem…stops at 30% and says to check internet??
should i follow ronny’s suggestion or how do i get the latest updates???
i am only at 1153!

I have seen some people say that the update problems get solved with a clean reinstall. Usually something is messed up in the registry. Try doing a fix and see if that helps, if not I would recommend a clean reinstall.


I had the same problem.

I followed Ronnie’s (sp?) suggestion to the letter and my system upsated to 1164. Then I once again chose the the Antivirus icon on the top line and then I chose “Update Virus Database” which updated me to the latest anitvirus database.

My OS is Win 7 RC 32x.

Hope all goes well,

did that …worked ok…the updated to 1167…thanks


Well, I’m back with the same problem again!

Since 1) I deleted the file I downloaded after problem was “fixed” and
2) the powers that be removed the link to the direct download of the database
I’m stuck once again.

I certainly am not fond of the idea of doing a uninstall and reinstall of Comodo. That’s rather like throwing the baby out with the dirty bath water. Once one has gone thru setting various options as desired, then rehashing and redoing past efforts is just no fun.

OS= Win 7 RC
Current database = 1174
CIS version = 3.9.95478.509

I have two User Accounts–one with administrator privileges and the other standard privileges.

I have tried both. I have had only one account open at any one time. The only app running is Firefox.

I use CCleaner regularly (run as last thing before shutting laptop off) but this has not caused any problems at anytime.

I installed, ran, and removed after a comprehensive scan gave me a clean bill of health–my favorite antimalware program, namely, MalwareBytes AntiMalware.

If something is corrupting the database, I’ve not located the source as of yet.

What I woulld like is a URL where I can download the latest database and also I need the procedure for installling the downloaded database.



If you used my download link, there has been a change over 3.8 to 3.9 where i wasn’t aware of the suggested download/rename to bases.cav thing is no good at the moment.

You could be missing updates from before 1164.

Can you revert back to the version residing in the \repair folder and then update again ?

Boot in Safe-Mode and make sure you are using Administrative privileges while copying \repair\bases.cav to \scanners\bases.cav after the reboot you should be back to 1157, if you now check for database updates it should update to the latest version.

Sorry for the trouble caused…

Good People,
Here is cure I found which worked for me. Turns out there are two very similar threads on this general topic so some of you may have already seen this.

Am now up to 1182 and CIS says I have the latest.

What did I do?
Exited from CIS
I burrowed down to bases.cav,
right-clicked on same,
chose “Restore previous version”,
chose ctp.exe to open the file,

Now all is OK.

I suspect the problem was related to that I had not used the standard user account for a couple of weeks but rather had been using the administrator account, after finishing a task at hand, went to the standard account and tried to update.

Somehow I suspect that Comodo is not handling the case where more than one account on the same machine are using CIS.

I do not know whether I hit upon a solution or a fluke cure, but I do have a working system now.



What’s the size of this 1182 version you have currently ?
Should be around 86.9MB

MD5 - D937E0C0BA85DF4E6BCC4ED54DA8439F
SHA1 - C220578B0285B9DB49DDD2ABFDAF8B30BC1208BF

If you don’t have a HASH tool you can download one here: