Virtual Keyboard Layout Incorrect when using non-US layout [M2142]

A. THE BUG/ISSUE (Varies from issue to issue)

Can you reproduce the problem & if so how reliably?:
The problem can be reproduced every time

If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Computer set to English UK Keyboard
2:Run Secure Shopping
3:Open Virtual Keyboard

One or two sentences explaining what actually happened:
When the Virtual Keyboard is used, although the Computer keyboard layout is for English UK, the Virtual Keyboard is in English US and so some keys are displayed in the wrong position.
i.e click on the " and the [at] symbol is typed and vice versa.

One or two sentences explaining what you expected to happen:
The correct characater entered in the text box

If a software compatibility problem have you tried the advice to make programs work with CIS?:

Any software except CIS/OS involved? If so - name, & exact version:

Any other information, eg your guess at the cause, how you tried to fix it etc:
Secure Shopping Virtual Keyboard layout is not the same layout as the system keyboard

Exact CIS version & configuration:
CIS Premium with Secure Shopping.
default “COMODO - Internet Security” configuration.

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Internet Security

Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
If so, have you tried a a a clean reinstall - if not please do?:
Clean Windows 10 and CIS 10 Installs

Have you imported a config from a previous version of CIS:
If so, have you tried a standard config - if not please do:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 10 1607 bld 14393.576, 64 bit, UAC: default, account type: administrator , V.Machine used: No

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=N/A b=N/A

Does this also happen with the virtual keyboard within virtual desktop? I do remember a bug that didn’t honor user input language with virtual desktop but I thought was fixed? maybe they forgot to apply the same checks with the secure shopping virtual keyboard.


This also happens in the Virtual Desktop as well.