Virtual desktop not working on Windows 10 Pro


I want to report an issue regarding VirtualDesktop and browser virtualization for Win. 10 Pro.
System data:
Windows 10 Pro with the latest updates installed
System type 64-bit
AMD Athlon X4 750K Quad core processor 3.8GHz
CIS version:

The last installed Win. 10 pro. updates are:
Security Update for Adobe Flash Player for Windows 10 Version 1511 for x64-based Systems (KB3174060) — info only
Windows Malicious Software Removal Tool for Windows 8, 8.1, 10 and Windows Server 2012, 2012 R2 x64 Edition - July 2016 (KB890830)
Cumulative Update for Windows 10 Version 1511 for x64-based Systems (KB3172985)
Update for Windows 10 Version 1511 for x64-based Systems (KB3173428)

Issue description:

  • VirtualDesktop engine does not start, the progress window at VirtualDesktop startup stays open while the entire Win10 system is blocked (no other processes can be started only a hardware reset is possible);
  • browser virtual mode is not working, this also blocks the entire system without the possibility to shut down or do any other operation you can think of (no other processes can be started only a hardware reset is possible);
  • for browser virtual mode I use the following browsers Comodo IceDragon(, Internet Explorer(this browser opens in virtual mode but it is very slow), Chromodo(, Comodo Dragon( and Opera(38.0.2220.41 - Opera is up to date).

In my opinion this can be reproduced on a system with similar configuration. You can also see the attachments if you need more info for reproduction.

Did anybody have the same issue? I checked this forum and I found nothing to resemble this.
I would appreciate your help thank you.

[attachment deleted by admin]


Could you check this issue with version <> ?

Thank you.

For what’s it’s worth. VD works on Win 10 Insider 14393 with CIS 10 beta 5144.

edit: corrected the Windows build number

I will give it a try. Thank you very much for your answer.


I installed CIS beta version, the first installation for the first time went well and it is very fast.
But I found the following problems after installation:

  1. After CIS was installed and the system was restarted I get an error message (added a screenshot here see err1.png) which requires to run the CIS diagnostic service, this
    service (added a screenshot here see err2.png) finds no errors and generates a report attached here I did this twice so I attached the second report too (see the attached zip files).

  2. CIS takes a lot of time to completely load after system start the Windows systray icon is not loaded nor the desktop widget, this works only after I double click on the CIS desktop shortcut.

  3. I tried to open Comodo Dragon in virtual mode this time it opens but very slow and does not load any pages. The link chrome://about-virtual is displayed but the page fails to open and the browser displays the kill window announcing that something went wrong. The whole Windows 10 system is stuck after this one and can not be shut down normally. The disk activity is incredibly high with very high resource consumption.

  4. After a forced reboot I tried to use the virtual mode. The system blocks at the load window (screenshot added see stuck_here.png) and can not shutdown normally. Here the ressource consumption is just a little bit lower with CIS beta and I was able to start the Task Manager and trigger a shutdown which took too long to complete and another forced reboot was needed.

  5. The WatchActivity panel does not work (added screenshot here see watch_activity_fails.png).

  6. CIS uninstall fails (added screenshot here see uninstall_failed.png).

One thing I want to ask. Will the online installer be available in the final release? Because in my opinion an offline installer with a good update process after installation will do better. I don’t have a very good feeling about the online installers anyway.

[attachment deleted by admin]

  1. This is usually caused by corrupt installation or/and messed up permissions (eg due to 3rd-party applications). Also, it’s recommended to use removal tools before installation / after uninstallation .
  2. It’s a known issue.
  3. You could use the downloaded MSI for uninstallation or later use. Do note that users asked for web installer for a long time.
    x86 :
    x64 :

As for your other points, it could be related to #1. If not, additional data should be provided (eg dumps). Also, could you try to virtualize another application (unrelated to Chrome)?

I was able to uninstall CIS only by using a removal program and only worked with the option forced uninstall. Unfortunately I can’t provide a dump for this. The permissions were all available since I do not use a low permissions user account. The same problem I would have had if I used Opera for example or Chromodo the system was so blocked that I quit doing further testing. After the forced removal I was not able to reinstall CIS again apparently some Windows registry settings were not removed.

I seriously think Comodo needs to use other than a web installer. Bad choice, it is.

Did you resolve this one? Do you need any assistance?


Try running the clean up tool as Administrator in Safe Mode.

No I was not able to fix the windows registry problem the only way to get rid of it and be able to reinstall CIS was to do a Windows restore to an earlier date. At this time I’m back to the old CIS (the last not Beta version) which is a little bit more stable. The virtual mode and the CIS virtualization engine still doesn’t work.

Please check with Comodo Internet Security V10.0.0.6071 Beta thanks.

Hi I’m using the CIS version at this time. And none of the issues I reported before were found.
This version works fine in Windows 10.

Thanks. Glad it’s fixed.

Have a nice day.

Not resolved, as I am using Windows build 14986, and I still cannot run the virtual environment.

Note, programs will run in the sandbox, and Secure Shopping work ok, I just cannot open a virtual desktop.

Note too, with the next public release of Windows due very soon, and the Fast Track beta builds being what will become the next public release, many people will find they cannot use the Virtual desktop once Microsoft releases the next public build.
And yes, the Windows core code has changed.
This issue needs to be resolved as fast as possible

Hi John,
That’s a different issue, actually. Thanks.

Hi then I can expect for the virtual desktop not to work again with the next Windows major update.
Thanks for this information this way I will not be taken by surprise again.

I’m using the Windows 10 Pro version 1607 with OS build 14393.479.
For the time being everything works fine and I thank all of you for this very good job.