Very strange IceDragon problem


I’ve been using IceDragon for some time and have been very pleased with it. However, a problem has recently surfaced.

I access an on line database through IceDragon. This holds information for my websites and I’ve just noticed that IceDragon isn’t saving the changes that I make to it. If I click on my “update database” button the updates show in the browser but, if I log out and then log back in to the database, the updates have not been saved.

IceDragon has worked in the past and Firefox and Dragon both save the changes no problem. I’ve disabled all plugins, repaired the installation and also re-installed IceDragon but it still won’t save.

Any ideas would be appreciated.


Can you check the Comodo Secure DNS option in IceDragon and see if disabling it solves the issue? You’ll find it in the Options menu, under the Advanced tab.


Morning George

Thanks for the suggestion but I had already tried that. I have, however, found out what the problem was.
I have NoScript installed as a plugin. That’s worked perfectly well for a while. I started ID in safe mode and the problem disappeared so I disabled all plugins and tried again. All was good. Enabling the plugins one at a time revealed the NoScript was the culprit.

I had the site referred to in my original post, registered in the plugin’s whitelist but, when I checked, it had disappeared. Once I put it back all was well again. A plugin update might have altered the whitelist.