Very slow connection to Buffalo NAS Drive with Comodo Firewall V6

I have been using Comodo Firewall V5 for sometime now with no issues. I have just carried out a clean install of Comodo V6 Firewall (final release) and although I can see and access my Buffalo NAS drive ok any file copying etc takes forever with very,very slow transfer rates.
Web surfing etc appear to be working ok.
Even if you ‘disable’ the firewall the problem still persists!
Uninstalling V6 and reinstalling V5 fixes the problem instantly. Default settings.
Is this a known bug?

Operating System Windows 7 32bit, No other real time security software running.
Netgear Adsl modem/router

Any ideas/suggestions welcome


If the problem reproduces as clear cut as you describe it I would call it a bug. Is there a program that you run on your computer to contact to the NAS or is that not needed?

No special connecting software used, just appears like an local network drive.

It is strange that Comodo V6 Firewall is definately causing this problem but the problem cannot be corrected by using it’s own ‘disable’ option.

As stated earlier uninstalling V6 and reinstalling V5 all is well again. Very odd.

From your description I understand this to be a bug.

If you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

that’s strange I have a western digital my live book duo 2 terabyte raid nas.
I get 70 megabits down and 40 megabits up.
and that’s the best i could get because the CPU is only 800 mhz in the western digital nas. running Linux.
i don’t know the throughput of a buffalo. but that’s what i am getting with this.
but your buffalo could be more high end then mine. mine runs about $379 - $400. so for that price i don’t expect more than that.Western digital did recently have a firmware update for windows 8 for it. i flashed it anyway and i still get the same rates and don’t use any software either to connect to my nas.
and configure it with a web interface through comodo dragon or what ever browser i choose.
and if i transfer files from a PC that has the avast internet security on it i get the same transfer rate.

I was able to reproduce SLOW un responsive copying from my western dig My Live Book Duo.
c:\windows\system32\drivers\etc\hosts file
if your host file looks like this localhost
::1 localhost

change it to this

# localhost
#::1 localhost
that fixed the lag

Hi DrHaze
Thanks very much for your suggestion and for spending your time spent looking into my issue.

I will try this out your suggestion later today after re-installing V6 and let you know how I get on.


Hi DrHaze

Regret to report that your suggestion did not solve my issue. Thanks anyway …
Still have extremely slow connection to my Buffalo NAS Drive. With V6 installed it takes 5mins to copy a 5Mb file. With V5 installed takes less than 10 Secs the same file.


May be the firewall logs bring any new insights here. Can you post a screenshot of them?

Hi Guys
I have made an interesting discovery …

My PC is usually used wired to my Adsl modem/router but I have now tried using it in the wireless mode and the ‘slow transfer’ issue to my Buffalo drive is corrected and all is ok!

Wireless and wired mode both work ok with V5

Any idea’s anyone?


Nothing other than it may be worth a bug report.

Are there other scenarios where downloading from the web or the local network is slow on the wired connection and not on the wireless?

I have carried out a bit more testing in an attempt to pinpoint the problem and have now ruled out my NAS drive as the slow transfer is also an issue when copying files to another PC on my home network.
The interesting points so far are:

  1. Slow connection only occurs on my Home LAN when I am using the ethernet connection.
  2. problem does not occur when using my wireless connection.
  3. Problem still occurs even with the firewall disabled
  4. Internet connection appears to be working at normal transfer speed, wired or wireless
  5. I do not have any problem when using Comodo Firewall V5

It’s probably worth checking the advanced configuration properties of the NIC(s) in device manager, particularly with regard to any ‘offload’ settings and Jumbo Frames. These settings shouldn’t change between different installations of CIS but one never knows. It’s also worth running:

netsh int tcp show global

From an elevated command prompt, again with versions 5 and then 6 installed.

Hi Radaghast
Thanks for your suggestion. I have checked the NIC settings and run ‘netsh …’ on my pc and they are the same when running V5 or V6

Any other ideas?


Not many I’m afraid. Is it possible to connect your NAS directly to the PC, maybe with a short crossover cable? If so you can see if this makes any difference. You might also try disabling the firewall driver on the properties of the network adapter, see if speeds change.


If it’s any help my NIC device is a Intel(R) PRO/100 VE

I was really trying to ascertain where the problem is occurring. I appreciate it’s only with CIS 6 installed, but if we can eliminate parts of the problem it may give us some clues. By using a short crossover cable you’re, in effect, connecting the NAS (or other PC if you wish) directly. Also, there are various ways to disable the firewall. If you do this through the interface the driver is still active. if you disable it at the NIC, it’s not.

A couple of other thoughts. If you haven’t already, you might try disabling the following, which you can find on the Firewall Settings tab:

Block Fragmented IP traffic
Do Protocol Analysis
Enable Anti-ARP Spoofing

Do you have IPv6 enabled and does your NAS support it?

Other than the above, I can only suggest you follow Erics advice and file a bug.

If you untick the Comodo Firewall Driver checkbox in my NIC properties my transfer speeds return to normal when copying files across my home network but have no firewall of course.

It appears the V6 firewall driver has an issue when used with an Intel Pro/100 VE NIC.

V5 firewall works fine with the Intel Pro/100 VE NIC

For the time being I am running Comodo V6 using my wireless connection which works ok with it. Normal transfer speeds available to my home network.

Please file this as a bug report.

This is usually the key to getting NAS’s (and wireless printers) to work. “Block Fragmented IP traffic” was not enabled by default in V5 but may be enabled as default in CIS6.

Worth checking.

Hope this helps,
Ewen :slight_smile: