Version 8 creates ghost paths and doesnt follow rules

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
Tried several origin games, each time comodo created ghost paths in the question. Example: C:…\origin~1\game~1.
This leads to never ending questions.
Even if you make a real rule manually, comodo doesnt see it. Even if there are several IDENTICAL ghost path rules at place, comodo asks again.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
Here is another case of someone else. He gets ghost paths with ~2 … i get them with ~1

One or two sentences explaining what actually happened:
Comodo is not usable at all. Its asking no matter what you do
One or two sentences explaining what you expected to happen:
That it works like the years before
If a software compatibility problem have you tried the advice to make programs work with CIS?:
Its the new version itself. With version 7 all is fine again.
Any software except CIS/OS involved? If so - name, & exact version:
Any other information, eg your guess at the cause, how you tried to fix it etc:
It doesnt happen with every file. But if it happens, you cant use comodo at all.
It affects fw and d+ (couldnt test autosandbox)

Exact CIS version & configuration:
version 8, april
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
fw, d+, av, everything else disabled. proactive, safe d+, custom fw.
Have you made any other changes to the default config? (egs here.):
I did what i allways do.
Have you updated (without uninstall) from CIS 5, 6 or 7?:

Have you imported a config from a previous version of CIS:

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
win 7 64
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:

C. ATTACH REQUIRED FILES (delete this section (section C) after attaching required files)

Similar bug with Firewall function of CIS!!

3 topics are about this.
It affects all aspects of comodo which are based on rules. Thats what people can see.

Probably it affects other functions as well, but we cant see.

It may be caused by ms dos file names that windows creates for compatibility, and comodo has a serious bug.
Introduced with newest comodo version.

Comodo version 8 is broken

Ditto the above bugs under Win 7 x64 and

  • Firewall rules are getting ignored. Thus Comodo tries to recreate already existing rules from the alert popup and continues to generate the alert popup despite the existing rule handling it.

  • svchost.exe is presented as a separate app despite its clear presence as a member of the Windows System Applications file group.

  • Comodo sometimes requires two separate application rules for the same app, for example, “C:.…\AppData\Local\Mozilla Firefox\firefox.exe” and “\Device\HarddiskVolume2.…\AppData\Local\Mozilla Firefox\firefox.exe”

  • Before my last reboot, Comodo would not show any alert windows despite the log showing ongoing requests were “Asked.” Now after my last reboot, alert windows are popping up every few seconds and dismissing themselves within a half second.

Comodo is notorious for releasing non-functional, bug-laden firewall updates. Like a dupe I keep trusting Comodo and installing them. And here I am a again with a non-functional firewall. Doh.

To see this bug in action all you need to do is this:

Create a folder named 1234567
then create another folder named 1234567 a
next to it.

Comodo will fail to handle anything in the second folder.

Not just x64. I have seen this on x32 also.

Developer staff is aware of this huge problem?
When is supposed to be released a fix?

This version is totally broken.
I’m wondering how is possible that has passed the alpha and beta stage and quality controls in pre-release test. Is quite shameful.

Same Problems, FW is since the last update buggy when you use own rules mode.

Couldn’t reproduce it.
Vista HP SP2 x86, Win7 Pro SP1 x86, Comodo works correctly, no fails in the second folder.

Anyone knows how to downgrade to the previous version without losing all the settings and rules?
This version is completely unworkable!
I should make it a habit not to upgrade software that runs fine… :-\

Then use win 7 64 bit and/or use the settings i did.
Safe mode d+, but a file that isnt in the vendors list,
custom mode fw,
proactive config.

All questions set to high.

Agreed. Please post if you find a way to downgrade to something stable. I imagine just transferring the config files might work if one stays within 8.x, but I read elsewhere all of 8.x has problems.

If I had the choice I’d still be on 5.X which was simple and just worked. But I presume newer versions close security vulnerabilities and a firewall with vulnerabilities is not much of a firewall. That’s why I feel chained to this unending parade of dysfunctional upgrades that break basic firewall functionality.

Before you try something new, export the settings of the former one (under configurations) and keep the last known working version installer.
So you can get back in minutes.

Its an usefull attempt in general.

The last version of comodo 7 was good to use.

It’s not a good idea to reinstall OS to test any bug.
My settings are similar except 2 differences:

  1. ADS is OFF
  2. not clean install but upgrade from version 7.

You said, you cant reproduce the bug.
What i said rather meant, then you are not affected with your system. Instead of you proving it cant get reproduced.
Also 64 bit.

Update fix anything?

After much scrounging around I was able to find a random site that for the moment still has up

Downloaded it, installed it on top of broken, am manually re-creating all my firewall rules. So far no problems, firewall working correctly again.

ehm try this?

If you investigate the link in that thread you’ll see it is a general link to the latest version of the software. Using that link at this point will just get you