Version 6 GUI and widget very slow


Per Chiron, have started this thread for advice on getting version 6 to work. ???

Been running CIS firewall and defense+ happily for ever alongside AvastFree. Now on CIS v5.12. Rare need to post. Fancied v6 for new Kiosk etc. No point waiting for updater as better to fresh install and re-enter rulesets.

Downloaded cispremium_installer.exe file version 6.0.2566.2708 124MB.

Uninstalled v5.12, rebooted, clean installed v6. Opted out of AV, Geekbuddy and Yahoo. Systray icon and widget took maybe ten minutes to appear, though Action Centre reported CIS firewall on and processes running in Task Manager. Icon and widget finally appeared after a very long time but clicking either had no effect. GUI finally appeared after another very very long time - five minutes? - but wouldn’t interact with me either. Tried uninstalling, system restore point, and reinstalling. Same symptoms. Uninstalled. Reinstalled v5.12 , config imported, and life back to normal.

Wondered if Msoft EMET causing issue so uninstalled EMET. No change. So went back to v5.12. Working perfect.

Haven’t tried safe mode instal as can only get back to v5.12 by installing v5.10 and updating. Bit of a pain if the problem is still my system - which it has to be if other folks can get v6 to work.

v6 seemed to be running, just ignoring me. :embarassed:

Sorry, posted in wrong place. Should be on install help board.

To rule out a few possibilities would you mind trying to reinstall it by following the advice I give in this post? Be sure to run the uninstall tool to remove any remnants. Those could possibly cause trouble.

Then, if after reinstalling it you are still seeing the same behavior let me know and I’ll ask that you check out something else.


Hi, sorry for delay, been footering with v6.

Followed the list of advice: turned off every setting in v5.12, uninstalled, booted into safe mode, ran the uninstaller as directed twice, checked device manager as directed. All clear. Didn’t venture into registry or i’d still be wandering in there. Rebooted. Installed version 6. Made no changes (couldn’t!).

No improvement :cry:

On reboot or any logoff/on user accounts, CIS widget and systray icon don’t show for 5-10 minutes.
Action Centre shows CIS firewall on.
Task Manager shows CIS processes running
HIPs, sandbox and firewall alerts seem to be fine.

CIS is working. Reliability monitor says installation successful: “Windows Installer installed the product. Product Name: COMODO Internet Security. Product Version: 6.0.2566.2708. Product Language: 1033. Manufacturer: COMODO Security Solutions Inc… Installation success or error status: 0.”

But then RM reports unsuccessful reconfiguration (nothing to do with me): “Windows Installer reconfigured the product. Product Name: COMODO Firewall. Product Version: 6.0.2566.2708. Product Language: 1033. Manufacturer: COMODO Security Solutions Inc… Reconfiguration success or error status: 1602.”

So it is working, but not very friendly!

Can’t access settings from either widget or systray without very long delay (minimum five minutes).
When the GUI opens I can flip Home/Tasks screen, but clicking any tasks options takes more delays.

Clicking Virtual Kiosk in widget works okay.

Widget tells me 7 applications are running in the sandbox but Quarantine is empty and I’m a wee bit lost
finding where everything is…no untrusted files show in list.

Downloaded Killswitch as asked and all’s well in Autoruns too (apart from reporting unsafe vbs script in System32 “gatherNetworkInfo.vbs” that’s been there since OS install - have stopped that for now).

Don’t want to uninstall v6 all over again. Have entered all my filerewall rules and exported them so i suppose i could uninstall if you say so :-\

v5.12 was happy and I’ve changed nothing on the system. Lost…

Ah, found your bug report on the false autoruns report on the vbs script. One thing solved !

Okay, I have a few ideas. Hopefully one will work.

Do you have any other security software running on the computer? If so please uninstall it and then run the cleanup utility for it, as linked in my post about how to uninstall Comodo. Also, please run the cleanup utility for any security software which was every installed on the computer.

If that doesn’t work it’s possible that this could possibly be caused by you importing your old configuration. I know that there have been some issues reported with this. Thus, did you experience this behavior even before importing the old configuration?

If that still doesn’t work, can you please take a look at this bug report and see if this is what you are experiencing? I’m not sure it is, but it would be helpful if you could let me know for sure.



I didn’t import my old config but here’s the thing… :-[

Since I’ve been online today, shut down and rebooted, everything in the v6 camp is perfect. I swear I made no changes. I have no idea what’s changed but just rebooted and everything is opening as it should.

I think I’ll just slink off… :-\ Thank you for the positive waves. Probably all it needed. Off to play with the new toy. :-TU

Glad to hear it’s working. However, if you run into any other problems feel free to let me know.

Hello! :azn: I have similar problems. It takes about 5 seconds to open the GUi from tray and about the same to open advanced settings. I have not any other av installed, I 've run uninstallers for all the ones that I had in the past.
In general, navigating through the UI is slower than you would expect. What’s strange is that twice, I found CIS UI to be significantly faster after reboot for some seconds. The UI appeared when launched from tray in 2 or 3 seconds, settings opened faster and even the animation effect when switching tasks-home was not laggy and was faster. After some seconds it became slow again as always.
I had CIS6 installed about two weeks ago, I uninstalled it, tried other products (ESET, Kaspersky, Avast), removed them (used cleaning tools also as said before but some folders remained-I guess this doesn’s matter) and returned to Comodo yesterday. I imported my settings from that time, but then I tried exporting again my configuration as I made some extra changes, deleting the old configuration, and importing the new in case this is the problem but nothing changed. Both of them are proactive mode with some rules and changes in scan settings.
Any advice or further ideas?
Thank you!

Before reinstalling CIS did you also use the uninstaller tool for CIS?

Also, does this slow-down occur even if you don’t import old settings?

I just uninstalled and deleted bymyself Comodo folders etc via searching for “comodo” in system drive. Do you mean that I should test with Internet security preset for example? The configuration that I use was exported today and imported again so to delete my old (as oldi mean the conf. that i was using two weeks before). The old conf. is deleted.

Please try reinstalling by following the advice I recommend in this topic. Running the uninstaller tool referenced in that topic has been able to solve some problems similar to this.

Once you have reinstalled CIS do not change any settings or import any configuration. Just leave everything the way it is. Let it complete the initial quick scan and restart the computer. Then, see if the slow-down still occurs.

If it still does, even though you reinstalled and ran the appropriate removal tools, and it’s not caused by any settings, then you are in a very good position to create a bug report. All other options will have been eliminated.

Thus, please let me know what happens when you do the above. Please feel free to ask me if you have any questions.


I did all these in the guide (cleanup with the tool was done is safe mode). After this I got into trouble. When CIS 6 just finished installing, system freezed. I could not click anywhere for several minutes so I pressed ctrl+alt+delete but nothing happened again so I pressed the button on my PC tower to do an immediate reboot. After logging in to windows I checked Comodo and it was responding faster than before. 5 secs became 2 and a half. If it was all the rest ok I would be satisfied. BUT I could not connect to the internet as the internet adapter was not working (code 31 error-Windows could not load the driver etc- in driver properties in device manager). I checked system files with sfc /scannow command and it found several corruptions and some of them could not be repaired. After seeing this I restored my system to previous state where CIS was not installed. Now I am trying to set up my pc to be in normal state with all programs working as Avast and MBAM which were installed before needed reinstallation.
I don’t know if it was the cleaning tool that messed up my system or CIS itself but I am very dissapointed and not return to Comodo until bugs will be properly fixed. It’s a pity as CIS except bugs, is a very good product, maybe the best security software for personal computers. Maybe the tool did the bad work, but as there isn’t an official removal tool to do the work, it is not my fault or decision.
Best regards,

I’m very sorry about this. This tool is almost always entirely safe.

Although I already do warn users in that post to make a System Restore Point I’ll edit the post to make it more obvious. Also, can you also please let me know which Operating System you are using, so I can try to figure out if perhaps there is an issue with certain operating systems.

I’m very sorry you had to go through all of that. If at some later time you decide to try Comodo again please let us know and we’ll do what we can to make sure it goes smooth. This appears to have been caused by my advice and so I’d really like to know which OS you are using so I can warn others.

Thank you.

I use Windows 8 Pro Χ64. No need to be sorry, it’s ok, and it’s great that the whole suite is free of charge. I 'll definitely try Comodo again in the future as I cannot find any other product that offers this level of protection. I hope this to be fixed soon so I can install CIS again as my main security product. If you want any other info about my system feel free to ask for more.

I’ve seen one other user who had problems similar to you. They were also using Windows 8. Thus, I think it’s possible that there’s an issue between the uninstall tool and Windows 8. I’ll add a warning to my topic until the next version of the uninstall tool is released.

Sorry. Hopefully things will go more smoothly in the future.

I believe they 'll go better. Windows 8 is a relatively new OS. Also, it says “Use this tool at your own risk” so you are not responsible as it is not official and not associated officially with Comodo group. What’s urgent to be fixed in my opinion is the problem with the UI in CIS 6 so to work properly.

I 'm glad that I 've just come back to CIS! Now with the latest version, the UI is ok and works smoothly. CIS cannot be compared to anything else in security software if you know one - two things more than a novice user. xD keep up the good work!

File description 	COMODO Internet Security
File version		6.2.20728.2847
Product version		6.2.282872.2847
size	149 029 376 bytes
CRC32	a6156094
MD5	23be38947aa802673811c13a488bfe61
SHA-1	56ebcb3f04c2a4ca98a802cf63c4e7eb77eac97d
SHA-256	302c0003aa641df6f35cd6f3ee7c8b94eb21ef7285084e5eac1163f90e57cf55
SHA-512	7070dc3227b3331b4dcbab7708e8f3add19d06253e90757f1e2c30aa2da31ab6de38e84ffaeb2f72eea5fb13c79baec2c3272ec7b23c5fff384bcd8c9deef146
Digital signature stated OK


  1. Just installed win7 ultimate x64 on empty drive (no other OS:ses installed)
  2. Installed service pack 1
  3. Installed comodo (version mentioned above)
  4. Bug occurs… starting from moment of install finishing
  5. Comodo UI takes forever to start. Fetched firewall settings from file (painfully slow).
  6. (Comodo UI…) Installed winrar (normal speed, no trouble, but comodo workking still slowly)
  7. Intalled bunch of other software, and few reboots… comodo still same.
  8. …connected internet. Comodo suddenly starts working like charm.

comodo log…

2013-07-23 10:10:07 	C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe 	Blocked 	Out 	UDP 	192.168.XXX.3 	62812 	53 
2013-07-23 10:09:59 	C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe 	Blocked 	Out 	UDP 	192.168.XXX.3 	52413 	53 
2013-07-23 10:09:36 	C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe 	Blocked 	Out 	UDP 	192.168.XXX.3 	52588 	53 
2013-07-23 10:09:29 	C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe 	Blocked 	Out 	UDP 	192.168.XXX.3 	58080 	53 
2013-07-23 10:06:51 	C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe 	Blocked 	Out 	UDP 	192.168.XXX.3 	56976 	53 
2013-07-23 10:05:52 	C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe 	Blocked 	Out 	UDP 	192.168.XXX.3 	49678 	53 
2013-07-23 10:05:14 	C:\Program Files\COMODO\COMODO Internet Security\cmdagent.exe 	Blocked 	Out 	UDP 	192.168.XXX.3 	54999 	53 

…from rule made intentionally to block comodo during this slow working time to get some info.

Seems like comodo does some dns calls to address “”. And it’s programmed way that it waits for answer before continuing.

This still happens at version 6.2.285401.2860. Same install of OS as mentioned before, only after comodo updates.

If computer is not connected to internet UI takes forever to start, and is painfully slow to use.

still happens at version 6.2.285401.2860
still happens at version 6.2.285401.2860
still happens at version 6.2.285401.2860

Does the slowness also happen after the AV of CIS is updated? Do I understand correctly this problem reproduces each time you block internet access? If so then it happens every time; let’s say shortly after boot, after an hour of working, after two hours of working… The reason for asking is that for previous versions of v6.x it has been noticed the UI got slower after the computer has been running for longer stretches of time.

Antivirus… if you looked at version information (the first thing in my post), it should be version without AV.

“Do I understand correctly this problem reproduces each time you block internet access?”
After update, it seems to have slightly gone away… not happening everytime, least not at same extent. But definitely still happens.

“…previous versions of v6.x it has been noticed the UI got slower after the computer has been running for longer stretches of time.”
Nope… I have not noticed that kind of behaviour, but I know this… many internet connections tend to get badder shape longer you are online (especially with heavy load), and rebooting modem solves that (also sometimes waiting modem to cool off is required as well).

EDIT(2013-08-22): Did few reboots just now, with blocked internet connection … and few more with modem totally off. Result… no slowing GUI.

I’m starting to think it was related to some windows update, there have been big updates since service pack 1. It might be related to specific network card(s). Mine is “Marvell Yukon 88E8056 PCI-E Gigabit Ethernet Controller”. And I have I gigabit network active (with cat6a cable).

EDIT2(2013-08-24): Today morning it happened slowing happened again… so it’s still there.

I’ve this same behavior with a Win 8 VM machine. If the computer is disconnected CIS 6 GUI is as slow as a herd of pregnant turtles; as soon as the computer is connected, the GUI behave normally.