version 3.5.57173.439_XP_Vista_x32 causes network driver problems on asrock n61p

system: asrock n61p mb with nforce 430 chipset, athlon 64 x2 dual, 2GB , winXP sp3 32bit, newest bios and drivers.

without comodo, network works just fine.

after installing comodo firewall, no network packets are sent out, network connection cannot be estblished, dhcp hangs, comodo reports network driver failure, but offers no further diagnosis.

after uninstalling comodo firewall and rebooting, network works again normally.

please advise.

Your motherboard has a NIVIDIA chipset. These come or came with a build in firewall. Make sure it is disabled. It is a known troublemaker.

i checked this, no firewall installed, even tried to install the latest version from nvidia, told me that the firewall is not available on my system.

With CIS still uninstalled delete all Comodo related folders under Program Files, Program Files\common files\ and all you can find under documents and settings. Also clean the registry with Comodo System Cleaner: https://forums.comodo.com/comodo_system_cleaner_fileregistryprivacy_cleaner-b124.0/ .

Then go to Device Manager and make it show hidden devices (under View). Then see if under Non Plug and Play drivers there are Comodo related entries. If so uninstall (click right on the entry) them and reboot.

Then try a new install. Let us know if that works.

There were no obvious CIS-related files neither in “Programs” nor in “Documents and Settings” (apart from “Temp”), the registry cleaner didn’t come up with any obvious keys, no left-over drivers in Non-PnP. Not really astonishing, this is a clean fresh WinXP-install on a completely new PC.

Installed CIS again (see driver list below), network stopped working. When activating the network device, it tries to get the IP address via DHCP, but doesn’t send out any packets and finally runs into a timeout. Tried to disable various network-related devices, no good. Uninstalled CIS, network device works again. Windows firewall is disabled, btw.

Non-PnP:
Gerät: AFD
Gerät: Beep
Gerät: COMODO Internet Security Helper Driver
Gerät: crpf
Gerät: csdf
Gerät: dmboot
Gerät: dmload
Gerät: Fips
Gerät: Standardpaketklassifizierung
Gerät: HTTP
Gerät: IesDrv
Gerät: COMODO Internet Security Firewall Driver
Gerät: IP-Netzwerkadressübersetzung
Gerät: IPSEC-Treiber
Gerät: ksecdd
Gerät: mnmdd
Gerät: mountmgr
Gerät: NDIS-Systemtreiber
Gerät: RAS-NDIS-TAPI-Treiber
Gerät: NDIS-Benutzermodus-E/A-Protokoll
Gerät: NDProxy
Gerät: NetBios über TCP/IP
Gerät: Null
Gerät: PartMgr
Gerät: ParVdm
Gerät: Treiber für automatische RAS-Verbindung
Gerät: RDPCDD
Gerät: TBPanel
Gerät: TCP/IP-Protokolltreiber
Gerät: VgaSave
Gerät: VolSnap
Gerät: RAS-IP-ARP-Treiber

Networking:
Gerät: WAN-Miniport (L2TP)
Gerät: WAN-Miniport (IP)
Gerät: WAN-Miniport (PPPOE)
Gerät: WAN-Miniport (PPTP)
Gerät: WAN-Miniport (IP) - Paketplaner-Miniport
Gerät: NVIDIA nForce Networking Controller #3 - Paketplaner-Miniport
Gerät: Parallelanschluss (direkt)
Gerät: NVIDIA nForce 10/100 Mbps Ethernet #3

Are there newer drivers for your network adapter? Do you have a spare PCI network card for testing? Slot it in and see if the same thing happens or not. May be there is a driver issue with the NVIDIA network adapter.

I already installed the latest and newest drivers from asrock as well as nvidia. I’ll try with network adapter from the old PC.

Update: I installed an old 3Com-based ethernet card, same symptoms: I get a normal network-connection without CIS installed, but when CIS is installed, the network stack hangs when getting the address via DHCP. Uninstalled CIS and it works again.

I noticed something else that might help in finding the bug: when CIS is installed, the latest Firefox will not come up but simply hang. Internet Explorer does come up and tells that there is no network connection. This only depends on if CIS is installed or not, when CIS is installed and the network interface is deactivated, Firefox hangs before showing the GUI, without CIS, Firefox comes up and correctly cannot get a network connection.

BTW, is there a previous version of CIS available? I’d like to try latest 3.0.x version and see if the problem predates 3.5.x.

You were looking for a software firewall with the nVidia chipset. Would this be something found in that MB’s BIOS? (Just asking).

no, there are no firewall settings in the bios, and the nvidia-firewall-software cannot be installed on that motherboard.

What other security applications do you have installed? Try disabling them to see if there are compatibility issues.

no other security-applications, the install happened on a fresh winXP system with sp3, no special settings in windows en- or disabled (because I figure that CIS must be able to handle that).

what about a previous version of CIS? I’d like to try CIS 3.0.x and see if that works…

I tried the new v3.8.x, still the same symptoms. Another note: when I start firefox and it hangs, it cannot be terminated via task-manager, so this looks like some deep problem…

Go here Comodo Internet Security - Free download and software reviews - CNET Download
and select a previous version from drop down choices, good luck & post back your findings
Cheers :■■■■
Xman :-TU
8)

sorry, that page says:

Download doesn't provide access to previous versions of this program

somewhere else?

ok, I found a download link by searching for “released” in the forum. sorry to report that version 3.0.25 also shows this behaviour. I’ll try a v2.x next…

Filehippo still has the 3.0 versions for grabs: Download Comodo Internet Security 12.2.4.8032 for Windows - Filehippo.com .