Verizon & CAS [RESOLVED as bug]

Hi Junhua:
I downloaded and installed CAS. I have completed your recommendation of adding emails manually to the system. However my problem continues. CAS won’t process incoming emails nor does it seem capable of of storing the passwords to access the email account for the POP and SMTP servers. When I attempt to set the ports recommended by my ISP, CAS wont’ accept them.

This problem is happening with the most recent version of CAS. I mentioned this probem in this thread because I use Incredimail also.

Thanks for your time; I look forward to learning what the solution may be. I’ve not discovered any notification that a download separate from CAS was necessary to get it working. I look forward to utilizing the features of CAS.

Thanks ahead of time.

Here are SSL settings that work in gmail for me. Please do tell me if they work for you and I’ll add this to the FAQ.

Note that, for an SSL connection, the correct settings are DIFFERENT in email client and CAS. This causes failure (in some cases) after first Spam mail is received in XP. For Gmail correct setttings are:

Client settings
POP3 port=995 NOT encrypted
SMTP port=465 NOT encrypted

CAS settings
POP3 port=995 YES encrypted
SMTP port=465 YES encrypted

(1) Outlook tries to second guess you, so double check that it has not altered the port settings when you ticked the encrypted box. (more intelli-nonsense :slight_smile:
(2) It can take 2-3 send receive for emails to go through the quarantine approval process
(3) Port 587 (in email client and CAS) seems to be an alternative to 465 in the case of Gmail


CAS won’t accept the SMTP port settings used in Incredimail. Also CAS is not processing any incoming mails although I’ve installed the email addresses to accept and block manually. I’m using the latest downloaded version of CAS within Windows XP Service Pack 3.

Thanks for your suggestions, however I’ve no problems using gmail as my webmail of choice. The problem is using CAS to process incoming/outgoing mail through the desktop application Incredimail.

Sorry you are having so many difficulties. OK have installed Incredimail myself and found settings that seem to work for me accessing gmail. I also have XP SP3.

The settings are attached as graphics files. You will need to input them manually in Incredimail and CAS.

Incredimail communicates with these settings, and CAS seems to work too. Please check that the CAS icon is the system tray before trying them.

ALSO very important please check that Incredimail’s port settings are as described. Check this at least once after saving the new email account settings. Incredimail changes its port settings back to default when you change some other account settings, so you must verify this.

You don’t need any additional software to use CAS with incredimail - sorry my mistake. (Did not realise when I said it that CAS works as a semi-transparent proxy).

Please do report back and tell me how you get on.

[attachment deleted by admin]

I’m uploading a screenshot of my Windows XP desktop running CAS. Hopefully the shot will clarify what is happening. CAS will not accept the port settings within Incredimail and it wants to recommend a different port!!

The port settings within Incredimail are behaving properly; Incredimail can access my ISP (which is not gmail) and acquire all incoming mail. CAS however is failing to intercept and process any mail although I’ve entered both the email addresses to accept and those to block manually.

Again, perhaps the snapshot will provide a clue to the programmers regarding what is going on. There are no SSL settings to worry about. I notice however there doesn’t appear to be a means to insert a password to access my ISP’s POP server although there does exist a password field to access the SMTP server. I noticed something which appears odd to me, although there is a checkmark within the SMTP block which supposedly would be used by CAS to refer to the POP User Name and password, because there is no place to enter the Username and password within the POP area within CAS I don’t see how CAS can know what that name and password is. I had been assuming that I had to enter the username and password into the SMTP block which would somehow be passed so that CAS could access the POP server.

Another oddity, CAS can’t retain in the SMTP block within CAS, the username and password to access the server (either SMTP or POP) – whatever the actual design intent is.

[attachment deleted by admin]

If your ISP is not Gmail and you do not use SSL to access it, then you do not need to use port 587. Port 587 cannot be shared between email accounts.

Try port 25 instead which can be shared between 2 email accounts.

Essentially, if you are not using SSL, then you should set the same email account settings in CAS as you have in Incredimail. Double check these carefully as Icredimail has a habit of resetting ports to defaults when you are not looking.

(Sorry about the confusion re SSL. Because you did not give your ISP, I checked your personal profile which gives a gmail address. Gmail uses SSL. Maybe you also have Gmail set up in Incredimail or CAS - that would explain the error message).

Re the password, inserting just the username seems to work fine for me. CAS seems to acquire the password, maybe from the Windows password file, maybe from Outlook where I also have the account defined but currently disabled? But I agree, in principle it should not work. I’d try it out if I were you! Junhua, any ideas?

If this does not work could you fill in a bug report please? This will gve us more info to go on. Also if you can please post all your CAS and Incredmail settings for the relevant account, with usernames (but NOT domain names) obscured of course. Screenshots are the best way to do this.

Think we may be getting to the bottom of something important here… So please do say how you get on…

Many thanks


I do use gmail as my webmail service of preference. However, my ISP is Verizon and instructed all their users to stop using Port 25and use Port 587 for their SMTP servers. I’ve not noticed any documentation from them stipulating that using SSL is required or necessary.

I’ve noticed something else regarding CAS, it appears to reset itself every time the desktop computer reboots. Sometimes CAS finds Thunderbird and Outlook Express accounts I’ve used prior to Incredimail (utilizing port 587) at one boot and when CAS does then CAS functions fine and can process mail correctly as has been reported and advertised. However, when the computer shuts down normally or otherwise reboots CAS “forgets” those account settings – however it retains the whitelist or accepted emails listing – and I’ve got to create a whole new account pointing to Incredimail with the Other designation. When that occurs I cannot insert 587 as the port to use.

If there is some other oddity regarding CAS I come across; I’ll post it here as I prefer Incredimail to either Thunderbird or Outlook Express.

Otherwise the depth of Comodo’s products is quite impressive; it genuinely puzzles me why there is so much difficulty with this one application.

I’m wondering if there isn’t a specific attack that has been designed against CAS. If I can get a report out of Comodo cleanser which is meaningful I’ll post it here just to produce more information in exploring what the problem may be.

Thanks for your attentive input.

All the best…

Verizion are probably trying to persuade people to use port 587 because it is an SSL port, to reduce spam.

So I suggest

  1. Backup your whitelists (if any) to, say the desktop, by exporting to a .bwl file. (Not to a CAS folder). Stop your other email clients from auto-loading if you know how.
  2. Do a complete un-install and re-install of CAS deleting all settings when asked. Don’t import from the other email clients. Check the CAS icon appears in the task tray. (If not close you email client then kill & restart CAS using task manager, then LOG off and on again. Take too long to explain why. Basically CAS is prone to a well known XP windows tray bug).
  3. Re-import your whitelists
  4. Set up gmail settings in CAS and Incredimail
  5. Use my suggested Gmail & port, SSL and other settings in CAS and incredimail.
  6. All should be OK through the reboot cycle unless you disturb the boot cyce in a major way. In which case, if you have the windows tray bug the CAS icon may not appear, and you will need to repeat the cure in brackets above.

NB s far CAS seems to be working much more smootrhly with Incredimail than it does with Outlook, so you may have good reasons for selecting it!

THis should work. Looks like you have residual account settings causing a problem. Give it a go and lets see what happens… I have asked Junhua re the password issue… which I think may help solve another mystery…

He says myseriously…

I’m assuming you are running CAS 2.7.? Again if this fails please make out a bug report as suggested under the CAS Beta corner 2.7 bugs topic.

Best wishes


Unfortunately, Mouse your recommendations are not enough to get CAS to work. I implemented your recommendations to no avail. The image I uploaded earlier in this thread still appears.

By the way, I downloaded and installed the latest version of CAS and as well as the other free Comodo software products.

This is rather frustrating as Comodo’s other products work very well.

I’m not sure what else I can do to report the problem.

All the best…

One last thing to try if you have the patience. Make sure you only have one email account set up in CAS and Incredimail, the Gmail account. Make sure you have prevented all other email clients you may have installed from sending/receiving. Then try setting the SMTP port to 465 in both Incredimail and CAS.

If this does not work I can only think that you have email account settings in your registry that are not getting removed by uninstall.

The extra report I suggest is a bug report. Look above the main forum to find the Beta corner. In this board find the Bug reports topic. The first post gives you a standard format for bug reports. Well worth doing if you want the problem fixed. The developers find it difficult to resolve problems unless this sort of context is provided, and in a standard format.

Sorry if I have been unable to help.


I previously reported problems with CAS where it did no processing of incoming mail at all. After a complete rebuilding and reinstall of Windows XP and the CAS application finally CAS is processing incoming mail. What is puzzling however is that although CAS appears to be working CAS cannot send out messages to the Comodo servers reporting those emails/domains I’ve determined to be spam and which are to be blocked. I do see an error message from CAS reporting that it cannot report messages as spam, then I get an error report which is supposedly sent to Comodo regarding CAS’s crash.

That’s it for now. Anything further and I’ll report it here.

All the best…

Hi Aguila

Very sorry for your continued problems. But glad we are making progress!

If you go to the advanced/miscellaneous tab, you can turn off spam reporting. Sounds like the servers are down. If CAS is crashing when it cannot report spam, this is clearly a bug, so it would be great if you would make a report in the appropriate bug reports section.

It’s possible that the problem is wider than this. CAS may be unable to SEND emails at all. This would probably show itself by an error message every time CAS tried to send a challenge email.

THis might be the case if you had not fully solved your problems with passwords. Have you solved this? If not try the following (no guarantees!). Go to the emails accounts section. Choose to edit your gmail account. Make sure ‘my server requires authentication’ is ticked (Checked). Make sure ‘use same settings as’ is NOT ticked (NOT checked), even if you think it should be! Now you should be able to enter and save your username and password, being careful to ensure the username is in the format Gmail requires (acceptable formats vary). Make sure ‘use secure password authentication’ is NOT ticked (NOT checked).

Meanwhile I’ll check out the server problem myself.

Are you using the Beta (2.7) or the current release version (2.6)? CAS shows this information under when you click on ‘about’.

Best wishes and good luck


Just a word to the wise - recent versions of CIS have been detecting part of increimail as malware. If you want to continue running it, you might want to restrict what it is allowed to do using your security software.

For help on how to do this if you are using CIS, please refer to the CIS help file and the CIS forums.

Merry Xmas


Thanks for the tip Mouse.

The c opy of CIS I installed onto my mother;s computer is working very well with Incredimail and all other products of that company. I guess I keep on top of CIS so that it is learning what is essential and what is not. So I’m doing something right. CIS has the intelligence to ask what should be allowed or not and I tweak how it behaves so that it understands what it needs. So I’ve nothing to contribute along the CIS thread.

The only Comodo tool behaving inexplicably (to me anyway) is CAS for the reasons I previously discussed. I do intend to get around to filing a report to the Comodo team but I can’t say when that may be. I find it odd and annoying that I have to write a technical document for which I’m not going to be paid for. I also find it odd and annoying that I’ve provided as much detail as I would write there as I’ve done in this Forum’s thread and I’ve got to repeat it in a report. It is as though I’ve got to make twice the effort to get someone to listen to correct a problem which the engineering team should have avoided in the first place – and they are too aristocratic to bother about the user complaints presented in the Forum’s threads.

Somehow their time is valuable and mine is not?

Maybe what is irking me about this is that I’m an IT pro in several areas as well. My time is also worth cash especially when I’ve explained, via my compassionate and generous nature, here for free what problems I’ve discovered. And for clarification, the other Comodo products I’ve installed and used on my mother’s system work very well – overall I’m actually quite impressed – CAS however is not functioning at that level. The product doesn’t appear to even have been designed with the same clarity of focus. It “forgets” smtp passphrases and then complains that it can’t reach my server’s ISP (for you Mouse, it is not Gmail).

This problem is within CAS alone. To make my point a little clearer the suite which Comodo has contributed reflects on Comodo. Overall these products are of high quality, but if Comodo is inattentive to what users explain as problems by enforcing time wasting procedures – that is really their choice.

One fellow is not going to be able to cure all the associated problems such a stance creates.

May you and all have a wonderful New Year and glorious holiday celebrations.
Then when everyone gets back I fully expect everything I’ve complained about to just work! : 88)

Hi Aguila and Happy New Year

Think you may have misunderstood me. I was just warning you that Incredimail might include some malware code since a CIS antivirus scan identified one of its files as malware recently.

I did not mean to suggest that this has anything to do with the problems you have experienced getting Incredimail to work with CAS. I still think that the suggesion I made in my last post might resolve your remaining problems with passwords. So please do try it if you have time. If it does not solve the problem a screen shot of the password error message might help me to make other suggestions.

I agree that Comodo needs to fix CAS, and I think Comodo does too. Unfortunately it’s not top priority for them at the moment - I wish they would give it higher priority.

But I am just a volunteer moderator, and so have limited influence I guess.


P.S. Bug reports are entirely optional. Appending technical information (like I do) even more optional. See the bug report format for details. The reason for doing it is to make it possible to fix the bugs more quickly. Bugs are difficult to fix if they can’t be replicated on the developer’s machines. Bug reports make it possible for the developers to re-create your software environment and replicate the bugs.

Having investigated this further I’m pretty sure you are hitting an authentication bug which I have just managed to isolate for another user.

This would be the case if Verizon absolutely requires SMTP authentication (many ISPs prefer it but will tolerate the lack of it). I’ve decided to do a bug report myself which here.

Sorry but there is no work around at present. I’ve tried to find one, even a registry hack, but nothings works.

I’ve also separated out your post into a separate topic for clarity.

Best wishes


Thousand thanks :wink: Mouse1 for your precious indications Kind regards