Vengine Installation bug

Greetings all,

Just read the announcement by Vadym and went through the installation
(over existing as few previous times)

I got the Error as in attached image.

The icon in the SysTray was changed to the new one , so the entry in the Add/Remove

In Firefox 3.6 the Add-on that was marked a incompatible disappeared and never got back … Rebooting did not help

In IE8 the situation is usual: Add-on is present and Enabled but doesn’t work
I am not much concerned about it since I’m not using IE.
Sure, I would prefer it working.

… but no VE in FireFox is a disappointment.

I will try to uninstall and clean reinstall

My regards

[attachment deleted by admin]

I got pretty much the same result.
I ran the installer again and after that second reboot all is OK.
On the second run of the installer Check that the FF box is selected mine wasn’t preselected.


Thanks for reply, Bad Frogger

After uninstallation and subsequent clean installation I got the Add-on back
It’s showing up now in Fox

At the same time it seems to me that not all sites that previously were included are giving green border indication ???

Actually I just found only amazon that displays the border if I hover over the logo at the bottom of the page.


I can’t select FF while installing VE, perhaps because FF is not in the default location.

VE does not work. Enabling the add-on now crashes FF every time as soon as it starts.

Got the same error as in screen shot above when updating, but rebooted, and then had to reinstall CVE. Then, after launching the installer again, was presented with options, and also ability to choose FF 3.6 (IE plugin was already checked so had already been installed first time round).

Works now however.


Hi Guys,

I’m not experiencing crashes as Toxteth O’Grady
but it seems that something is broken with the border indication as mentioned above and here is cross reference where the symptom was mentioned by larlyles

I cannot recall all sites but few: 1st Comodo :o ; (as far as I remember this forum always was showing green … or I am mistaken?)
as I remember Google e-mail initial screen
… etc.

Then I am not sure if that’s by new design, but on some sites the “big Padlock” will flash and disappear and there is no “small padlock” on the Fox’s Status Bar as previously. In the past the big one and the border would be displayed whe you hover over the statubar lil padlock


[attachment deleted by admin]

I run Fx and had the installation bug. Cured it by simply uninstalling the old VE (windows add/remove programs) and running the installer again.
Everything works except there are no green arrows when a website is first loaded.
(I get the status bar padlock icon showing for relevant sites. So far, anyway.)

Hi Guys,

Since I reported the absence of the padlock as in my Reply #5
here is an update - I solved the problem - that is the FireFox’s theme I was using is responsible

After changing the theme say to the default the image of the padlock is displayed in the status bar.

added In particular that was “Vista-aero” theme


It doesn’t work for me, and I still can’t select FF when installing VE. Enabling the (old) add-on always crashes FF. I have tried every combination of installing/uninstalling/updating I can think of.

I suppose the old FF add-on is incompatible with the current version of VE. Could someone upload the new add-on (the VE folder from the FF extensions folder)? Perhaps replacing it manually will do the trick.

Go to Add/Remove Programs and within Verification Change/Uninstall choose Add/Remove Components and tick the Firefox 3.6

Hope this helps

Hi Peroulades,

I think “every combination” that Toxteth O’Grady mentioned means that he tried Add/Remove too

Hi Toxteth O’Grady

Honestly, I didn’t get this phrase, but anyway

As it mentioned above the installation over didn’t work. The clean reinstall worked.

It could be another extension or plug-in that interfere.
Have you tried clean install with new Fox profile without any add-ons installed yet?

Then you can try

  • kill VE process;
  • Disable VE startup;
  • reboot
  • use Revo (in advance mode there should be only one reg entry to remove)
  • than you may try to clean registry … more thoroughly there are kinda 173 entries for Vengine there. I used RegSeeker
    (don’t forget to uncheck “protected registry keys” in Defense+ before cleaning, otherwise old policies remain there … there is lot of old rubbish in the registry because of that)
  • after that you can try to Install the new one

As for the extension uploading I can try to do that despite I am not sure that is correct way
I will upload <>.xpi and the whole content of the extension folder
Keep in mind that the extension is not located in the FF \extensions\ see attached image with properties (HKLM reference)
it points to C:\Program Files\Comodo\VEngine\VerificationEngine_ff3_6

I did not find it in …\App data\ profile\ … but I could be wrong.
If so, please tell precisely what the location and the file(s) that you think is necessary

The extension installer VerificationEngine_ff3_6.xpi is in C:\Program Files\Comodo\VEngine folder

So basically I will upload whole C:\Program Files\Comodo\VEngine folder (~5MB)

You can run XPI… but again - I am not sure that would be the right way,
therefore - first try clean reinstall “the normal way” using Revo prior to that as above


[attachment deleted by admin]

[attachment deleted by admin]

Thanks very much for uploading.

The XPI file was missing from my installation, because for some reason I can’t select anything but IE when installing VE. After installing the one you uploaded, the Comodo padlock is working again, but no green border shows up when loading pages. However, there are quite a few “can’t connect to database” messages", so perhaps this is temporary. I’ll wait a bit before I start messing with VE again. :wink:

Thank you again for your help.

You are welcome

I’m very glad I could help, Toxteth O’Grady

That’s strange that XPI was missing - probably that would be the other serious question to the developers

I was a bit worried after uploading actually and even gathered some additional info about BHO / registry settings/ etc.

As for the “can’t connect to database” message I can confirm that it is coming constantly started from yesterday evening.

added the additional problem with the message (attached) - sometimes it’s displayed after rebooting or when the computer is waking up after the “Suspend Mode” and the browser was not invoked yet ???

I still have a suspicion irrespectively to the message that not all sites are having indication currently compare to what was before as I mentioned above


[attachment deleted by admin]