Various Lists do not update even they are modified


I dont know a better subject-title for this haha.
My problem in detail:

I run Comodo Internetsecurity Premium, Version
Comodo has various lists, for example when you goto “Comodo Advanced Settings”-> “File Rating”-> “File List”
When I open the filelist, it shows me 42 ‘unrecognised files pending for analysis’ - and now the problem, when I select all files and click on ‘remove’ it looks like they are actually removed, but when i reopen the 'File List" all the files are still there.

Same happens with the ‘Quarantine’ - its empty while it should have exactly 100 malicious files in it (no worries I used 100 copys of EICAR testvirus intentionally and moved them into quarantine after the AV scanned them) but the quarantine’s list is empty. But when I manually goto the folder “C:\ProgramData\Comodo\Cis\Quarantine\data” I can see it has 100 encrypted files.
They just dont showup in Comodos Quarantine UI.
I also tried to add a file manually into the Quarantine and it worked (showedup in the quarantine-list) but only until I closed and reopened the Quarantine UI.
The manually added file anyways is in “C:\ProgramData\Comodo\Cis\Quarantine\data” where I have now 101 files wich is correct, but the Quarantine-list doesnt show them.

The same happens for the “Blocked Applications” - nomatter howmany intentionally malicious files I sucessfully block, they dont showup in the “Blocked Application”-list.

It all worked fine until about 3 or 4 days ago - since then, it seems like ALL my file-lists anywhere in Comodo are frozen and changes are not saved and reset when reopening one of those lists.

Im sorry I really cannot explain it better, I hope you guys can understand what Im trying to explain.
Any help would be appreciated :smiley:
I am very familiar with programming, normally not accesseable systemfolders/directorys and regedit, incase this List-Error can be fixed somehow with these.

Greetings ^^

Can you try to do a re-install, I think the database which stores this information is corrupted somehow.

Hi thanks for the answer :slight_smile:

Would you recommend to totally uninstall and afterwards freshly install CIS?

Or simply start the CIS setup without uninstalling it, incase there is some kindof repair function :slight_smile:

Cheers :smiley:

I advice to first export the active configuration to a folder outside the CIS installation folder. Then do a clean install and import and activate the saved profile again. The profile does not contain the database only rules and settings.

To see all files in your ‘File List’ window can you please make sure that both ‘All types’ and ‘Quarantined and not quarantined’ are selected.

@ReeceN: Its setu up like this :slight_smile:

@EricJH: Allright, I will post here when I did that - right now leaving for a 10 hour shift so may take a while :slight_smile:

Thanks allready.

Yes completely uninstalling and reinstalling worked! :slight_smile:

Importing my old configuration/settings was easy.

All fine now, cheers :smiley: