V4 failed to update from V3 - again !

The first time I tried by using the auto -update from V3 to V4 by it failed and came up with error 1603.

Not wishing to make the same mistake This time I followed the instructions . I disabled my anti virus and windows defender, I created a restore point and used Revo uninstaller. I deleted all the bits in bold type and rebooted.

I had previously downloaded the latest V4 - todays one - and saved it .

I tried to install V4 confident that I had removed all traces of comodo V3 , but it still comes up with Error 1603.

Now I am not by any means an I.T. expert, I try not to fiddle with my computer unless it is absolutley necessary, but I am getting quite frustrated that something that is simple - or should be simple is causing me so much trouble.

I am using windows XP SP3.

Perhaps rather than asking about creating new software , Comodo could offer a 24/7 package to people like me who like their product and try to use their product but because they are not techincal minded fail at the second hurdle.

i will have to just stick with V3 and hope for the best as I am not going to keep trying to upgrade.

You will have to completely remove v3 (a cleanup tool is found in the below links), reboot and do a clean install.

Please check the following for additional information:

John ,
this ‘batch file’ does it come with instructions , such as do I uninstall V3 first using revo uninstaller and then reboot and download the batch file , do I need to do anything else after opening the batch file , will it just seek out comodo leftovers , do i need to do anything to get it started?

sorry if I sound confused , but as i said I am not technical and I need things in easy to understand ’ numpty’ language so that I can follow.

I thought I had completed a clean install this time after using revo uninstaller as thats what it is suppossed to do.

thanks for your help so far by the way.

I don’t see CIS under Revo so I can’t comment on it’s use. I do however use Revo on my machine and am happy with it’s performance.

The links provide the information you asked on how to use the clean-up tool.
I would ask that you download it and follow the instructions found in the above link.

This has worked for many users, so I am recommending you give it a try also.

You can try uninstalling Comodo Firewall with Revo and then after letting it delete all leftover pieces it can find restart the computer. I should note that you should select not to restart when prompted by the Comodo Uninstaller. Let Revo scan you computer and remove what it can before you restart.

Then download and run the cleanup tool. It might also be a good idea to download a registry cleaner to see if you can find any other leftovers in the registry.

Hopefully that’ll work.

Thank you both, I will give it one last try this weekend. - maybe !

OK… this was my last try. I uninstalled using the ‘moderate’ feature on revo, searched for bold type leftovers and rebooted. installed V4

still no success, still saying error 1603.

I have read about the ‘batch file’ but I am more confused than anything with various people saying it doesn’t work or needs altering, I am just not confident enough to use it. So I have decided that I will just have to stick with V3 until Comodo switches it off.

Thanks to all.