V3 not remembering my options where Shields up concerned

I am using V3 and I used the option to “stealth my ports”, I selected the 3rd option ’ stealth my ports to all incoming connections’and I then checked this with “shields up” who confirmed that I was stealthed on all counts and I “passed” the ‘tru stealth analysis’.

Just out of curiosity I again checked yesterday and I was surprised I failed the same test on the “common ports” , so I again selected to stealth my ports option 3 , I then re-checked “shields up” and again passed the test.

I have just rebooted my computer and again “shields up” says I have failed until I go back into ‘stealth ports’ and re-enter the 3rd option , it seems that my firewall is not remembering my options.

I assume my global rules are the same as everyone elses and I haven’t altered them :
IP out, Ip any, protocol is any
allow ICMP, when ICMP is fragmenation
ICMP in, when ICMP is time exceeded
block & log ip, Ip any where protocol is any.

Am i missing something or forgetting something .

Just a further update, I am behind a broadband modem.

I have just re-stealthed my ports and Comodo says " firewall has been configued accordingly" I have rebooted and again failed the first “shields up test”.

Hi. Just thinking aloud…

If I read the user’s manual correctly then Application rules have higher priority than Global rules (Stealth Port Wizard does nothing else but set global rules if I’m not mistaken).
Rules shouldn’t change on their own so that sounds weird to me.

Which security level are you running?
What about Application rules?

Try: Firewall / Advanced / Network Security Policy (but do not change anything unless you are sure about it)
Look at the rules of “svchost.exe” and “System” - anything suspicious there?

Both security levels set to “safe mode”
To be honest , not sure if there was anything suspicious anyway, have no idea what i’m looking for. under network security setting " system" shows ‘allow udp in’ and ‘allow Ip out’ I can’t find a “svchost” one .

Try deleting your global rules and clicking apply. Then running the stealth port wizard for block all incoming connections. Then click apply. Unplug your modem and let it power down. Then turn off your pc. Plug your modem back in and let it be completely booted up and ready. All lights green. Then boot up your pc. Try Shields Up again. Also before that delete all your cookies and cache via CCleaner. Does your modem have a hardware firewall?

This is not a standard rule and seems to be a “learned” one.
Does it only apply for LAN Zone only or does it go for any IP-address?
Is there something like “block all” below, too?

Go: Firewall / Advanced / Predefined Firewall Policies
Mark: Windows System, click [edit]
Mark: the mentioned UDP-rule, click [edit]

There you’ll find tabs for Source Address and Destination Address… Which addresses / network zones do they refer to?

Again, of course: do not change anything unless you’re sure about.

(edit: forgot to ask about the “block all” thingy)

Vettetech… I followed your suggestion to the letter, same thing happened , its failed, i again went back into stealth port selected 3rd option pressed ‘finish’ and tried again , this time ‘passed’ , just like before. I do not think that I have a hardware firewall

nomads voice… I know you are trying your best with me , but I don’t understand about LAN zones but what I can say is that there is NO blocking rule under the two I stated.

I won’t be able to follow any further instructions for a while as the wife has said she wants to use the computer before I completely b**s it up !!!..

would it help if i went back into ‘training mode’ for a while ?

If there is no rule that blocks incoming traffic for Windows System this may be a dangerous security hole and my guess is that you’re currently unprotected because of letting any traffic in without blocking.

Unless you don’t know how to create rules by yourself I strongly recommend to deinstall and reinstall CFP to get the default ruleset back.

But before doing so you should probably wait for other forum members to respond to get their opinion. As said, from my point of view your ruleset is screwed.

Training mode has nothing to do with leak tests and Shields Up. If all else fails then why dont you try a complete uninstall and reinstall.

I used ccleaner to clean up , then I uninstalled V3 via start > all programmes etc. having downloaded the latest version. I rebooted and installed again following Little mac’s instructions. [Two things before I forget , firstly it went through the process of installing and after it completed it’s suggested “scan” it went straight to ‘installation complete’ missing out 2f,g & h of his instructions .Also when I checked the stealth mode bit I was unable to click ‘next’ as it was greyed out and I could only check ‘finish’ ]

A shields up check revealed I wasn’t stealthed , which I expected as I hadn’t “stealthed” at this time , when I did go into Stealth options it was as above , the ‘next’ button being greyed out , but it did say “firewall configured” I checked and this time ‘passed’

I rebooted and tried shields up - failed [ it says some are ‘stealthed’ and some ‘closed’ ] but again when i go in again and click on 3rd option - this time I passed [ all stealthed]

i also tried a system restore and went back a couple of weeks , but same thing - “FAIL” , then click on stealth option and “PASS”…

What are your global rules? The stealth port wizard for me is also grayed out but only on the option I already have. I use the P2P option. If I select that then its grayed out and that is cause I am already using that option. If I select the option to block all incoming connections then I can click on next. Go to the firewall/advanced/network security policy and tell me what your global rules are. Did you do a complete uninstall of Comodo? Did you use Revo Uninstaller in advanced mode? Did you check to see that Comodo was completely gone be reinstalling?

my global rules are as in my first post.
I thought I did a complete uninstal, I went to start > all programmes > uninstall and comodo said it was uninstalling ?.. I do have revo uninstaller on my machine , I have used it , but not in advanced mode as I am unsure of what I am deleting , it comes up with a select all and then it ticks all the boxes including windows etc and I am not 100% sure that it wont then wipe out everything on my machine , I have tried to just delete the bold items in the past. I know you are keen on this programme, but I do wish it had slightly more instructions that I could follow . Perhaps I could try and delete from the ccleaner 'registry ’ option - by just choosing anything with comodo written on it ?
when I did delete the firewall my computer did say that there was no firewall installed , so i assume that means comodo had uninstalled.
Unfortunately i wont be able to do alot for a couple of days due to work commitents, but I thank you for your time - and patience…

When you install Comodo the default global rule is the rule for P2P. You need to delete that and click apply. You then need to run the stealth port wizard and select the option to block all incoming connections.

Please post the failing checks for shields up, that could narrow down the possibles.

Probably easier if i tell you which ones were stealthed : 0,21,23,25,80,110, all the rest were ‘closed’ . I even tried to delete the global rules , clicked apply , then selected the 1st stealth option applied local network rules , then deleted them 'applied and selected the 3rd option again , same result. I think I may have to uninstall comodo as best as I can and try a reinstall in a couple of days time .

What other security software do you have running ? it looks like something is interfering.
The ports listed are most of the time not even listening on standard pc’s.

Can you please run the config script from https://forums.comodo.com/help_for_v3/comodo_firewall_pro_configuration_reporting_script_latest_version_is_0722-t20950.0.html
And post the report also ?

I am using the following : windows defender, spybot [ with teatime not used] and superantispyware.

My antivirus is AVG8 - although I am considering paying to have NOD32 as Vettetech seems ito think it is one of the best antivirus products.

i am a slightly concerned about downloading the config script as it says it has a number of personal setting etc and to check through them first - but I dont have a clue what I would need to check and delete first before sending it ?

Thanks for your time and patience .

Thee is no reason this should be happening. Are you sure you do not have a hardware firewall? What kind of modem do you have? It is not me that says NOD32 is the best but its proof. AV Comparatives has picked NOD43 best AV 2 years in a row. Please post a screen shot of your global rules.

When you apply the global rule to block all in coming connections then you go over to your global rules do you see the rule there? Have you tried rebooting after running the stealth port wizard?